Roon Extension: Deep Harmony - rich feature set for Logitech Harmony


(Rene Bouwmeester) #41

@Adam_Goodfellow:

I can replicate the crashes on my Synology. Let me know if there’s anything I can do to help.


(Adam Goodfellow) #42

Thanks :slight_smile:

Have ask both if they can email me logs if they can.


(Brett Kerbel) #43

I was able to install Linux Mint 19 as dual boot on one of my laptops. I verified Docker install and then initiated via:

docker run --detach --network=host khazul/roon-extension-deep-harmony

The extension started successfully and immediately appeared as a Roon extension. I was able to enable, but then when I tried settings, I ended up with a tall narrow window without any content. All I had available was Cancel and Save buttons at the bottom. Cancel returns to the extension screen. Save causes roon and the extension to crash. I can restart the extension and it appears again, but no settings available.

Thanks for all your work on this. I’m very excited to use the extension, but don’t have enough docker knowledge to help debug.


(Larry Post) #44

Ironic, I just completed installing Mint. It worked straight away for me. No issues in Roon.

Maybe restart Roon core and try it again?

A useful command to auto-start the container: docker update --restart always ‘image name’.

Works a treat, thank you Adam!


#45

Ok, I’m no docker expert, but wanted to give this a go.

On my Synology DS916+ NAS I have managed to get the image downloaded and installed and running in a container, and was careful to ensure the network setting is set to ‘bridge’, but Roon isn’t seeing it at all.

The status page looks ok to my non-expert eyes

So, I’m looking for some help in troubleshooting what I am doing wrong…please!

My Roon core is running on a SonicTransporter i5.

Thanks
Nick


(Larry Post) #46

I just setup Docker for the 2nd time. First on Windows 10 but the image doesn’t yet work on non-Lunix…

This morning I imaged with Mint distro of Ubuntu and Debian.

One of the network options is Host - docker run --detach –network=host khazul/roon-extension-deep-harmony

Hope it works


#47

Ok, got it working after a prompt from Larry - I set-up the container again ticking an option to use the docker host and it has worked - I can now see and have configured the settings for the extension in Roon.

Happy days
Nick


(Larry Post) #48

Glad it worked. I reluctantly gave up transport control when switching my dac from network to I2S.

I have it running headless on a mini Dell from days gone by in the garage way up on a shelf.

@Adam_Goodfellow, how do I donate cash to the cause? Transferwise.com?

Anyone know how to make an Alexa skill? speaking ‘next song’ would be awesome. I’ve enabled the Harmony skill but so far no luck getting ‘Alexa, skip forward’ or ‘pause’ to work.


(Adam Goodfellow) #49

Hi Larry, I havn’t given donations any thought, so I am not set up at all for such. Perhaps hold that thought until everything is in more complete state :slight_smile:

As for alexa, this project started as a by product of an alexa project for roon which got sidetracked. That is currently on hold until I have the main features I wanted to get done in this done, and I’m still quite a way off on that. Delaying it also give me a chance to get to know roon under the hood well and learn my way around other tech for this that I hadn’t used before until a few months ago.

Very basic alexa control is not hard as a quick and dirty hack when doing basic commands for yourself as a single user, but it rapidly gets a lot more complex once you do it properly for multiple users with persistent home device connectively in a way that isn’t painful to manage and gives proper consideration of security, privacy etc.


(Adam Goodfellow) #50

Sorry to hear you are having issues. In all cases where I have had the UI crash, it has worked fine after a restart of the control software and that is despite the amount of churn of adding and removing extension I go through.

It may be worth trying loads defaults button on the audio device. I have got into the habit of using that whenever I want to clear out old versions of extensions and it does seem to improve roon setting and device extension stability.

What are you running your roon core on and do you have a big library? While the roon api seems to use very little cpu, I have noticed that it is quite sensitive to system delays of more than a few seconds.


(Larry Post) #51

Understood. I very much appreciate what it does currently and short of any significant feature enhancement will be sticking with what I’ve got running now.

Thanks


(Brett Kerbel) #52

Hi Adam - I tried playing with this a bit more last night, but no luck. I rebooted all computers Core, HUB, and control.

Core is ROCK on I5 NUC with SSD and 8GB memory. Library is medium-large. About 25K tracks in local library + Tidal subscription. I don’t use any DSP, and typically only output to 1 zone at a time. ROCK/NUC has been very stable - never crashed.

While I only use a single zone at a time, I have 6 defined for various devices around the house. I tried disabling all of them but primary, but same behavior.

My hub on the other-hand is quite loaded. I have about 10 devices and 15 activities defined in very complex 2 channel setup within a multichannel home theater.

I did capture a log file from docker if you would like to have a look.


(Adam Goodfellow) #53

Sent you a PM for the logs


(Adam Goodfellow) #54

A thought, do you have a large number of playlists and/or internet radios defined?

Also you mention a lot of activities and devices. That could be contributing factor as it does refresh the activities when settings is opened. Maybe that behavior needs to be tweaked in the extension.


(Brett Kerbel) #55

I don’t have any playlists or internet radio stations beyond tidal integration.

I will send log file tonight

Thank you,
Brett


(Dan Crane) #56

I have a QNAP using contrainer station, and every time I try to install I get the following error after it downloads.

"Background task error for create roon-extension-deep-harmony-2: 400 Client Error: Bad Request ("oci runtime error: container_linux.go:265: starting container process caused “exec: “docker”: executable file not found in $PATH” “)”

Being a docker newbie I have no idea :slight_smile:


(Adam Goodfellow) #57

Are you running the latest version of container station? Please check in app center to see if their are pending updates.

I believe there was a historical issue with docker (back in 2016/2017) that could sometimes result in this error.


(Dan Crane) #58

Yup - latest. I’m an update freak. Have to update the moment they come in :slight_smile:

v1.8.3138

I’m happy to do the research and work it out - I just dont know where to start with this one :slight_smile:


(Adam Goodfellow) #59

The usual reason I have come across for this was an ancient issue with docker. The other reasons are of course legit bad permissions on a file, file not present at all etc, but in these latter cases this should impact everyone always.

I have just updated my QNAP NAS OS and aps including container station but not yet had a chance to re-test (I’ve been running the extension on an R-PI instead for a day or so to test it there). Ill re-test on my NAS this evening when as of course it is possible that something drastic has changed in their new releases, but I would not expect so.

I also quickly did do some reading up on this when you posted, but didn’t see any obvious likely causes other than ancient version of docker.


(Dan Crane) #60

I just completely uninstalled ContainerStation, then reinstalled it - then the first thing I did was try this app - same error.

Typical I get the weird error…such is life.