Roon Extension: Deep Harmony - rich feature set for Logitech Harmony


(Larry Post) #163

@Adam_Goodfellow

All is working as I want, I was confused on a couple of points in the docs. In retrospect mostly my fault not comprehending what I was reading but others may fall into the same trap so the details remain below.

Update: I’ve figured out one is supposed to run either the Docker image or the console app, not both. Sorry if I missed that in the docs or perhaps it’s implied but it sure wasn’t obvious to me reading the install guide.

I’ve got the Docker image doing what it’s supposed to do, however in Roon Extensions I see 3 extensions all stating theres an update and only one of them discovers my single Harmony Hub. All 3 reports v2.10+243 and that v2.11+246 is available. All 3 updated fine and I can ignore the two that exist but don’t have a hub associated…

P.S. Is it possible to have just skip functionality of v1? I don’t use fastforward and would prefer both short and long press be skip (forward or back, respectively) but don’t see a function available to assign in Harmony button setup for the TCL.

Update: just found InputAV and InputUSB are what I want, thanks.


(Adam Goodfellow) #164

OK, that’s interesting. Was v2.1 the first version you ever used?

As for donations there are a couple of methods on the bottom of the ReadMe on git hub - thank you for the thought.

Re your FR: Ill look into it to see what may be done. I cannot promise anything however as a lot of this process is automatic within Roon. I have a list of similar type small convenience features (what to do on switch on, auto off after idle and similar as a couple of examples).


(simon arnold) #165

No I had 2 initially and updated to 2.1 when it came out


(Adam Goodfellow) #166

Hi Larry, I suggest you just shutdown the other instances permanently and remove them from Roon. A single instance can support multiple hubs, a roku emulator per hub (for upto 9 hubs) and of course multiple activities on each hub.

Just leave which instance is most convenient to leave running :slight_smile:


(Adam Goodfellow) #167

OK thanks for that.

I wonder if this may having something to do with the unavoidable switch over in how device controls were managed. I have a suspicion that controls can get orphaned and forgotten in Roon. The 2.1 fixes should put a permanent end to it for new setups, but I think there is not much I can do about existing setups short of a config reset and removing the extension from Roon and re-adding it (which gives Roon a chance to remove any orphans).

I should have suggested trying one of the configuration resets (in tools section) as they were put in in case anyone had issues as a result of the change over. This just didn’t sound like such an issue :slight_smile:

I’m glad its working now.


(Larry Post) #168

I have shutdown all instances including the Docker image

Removed all authorizations in Roon - I have no other extensions and restarted Roon service.

Upon start of the DH image, these three show up. One works.

If I remove any of them, the one that works stops working.

Any logs that would (you) help debug? I’m happy now so only if the logs help your work…

Thank you again


(simon arnold) #169

I used the reset in tools several times it did not help in this case.


(Le Fur Arnaud) #170

Had the same problem with console app.
Delete the config.json and reconfigure.
It should work.


(Adam Goodfellow) #171

Hi Larry, sent you a PM for logs from all 3 if you don’t mind.

Reset in tools only deletes its own settings (or just the activities and controls), it does not delete the Roon pairing information which I suspect is the problem here. I might put another options in here if people are seeing weird stuff like this (delete the pairing, but preserve the Harmony config).

Are people only seeing this since the new Roon 354, or have you seen this before?


(Adam Goodfellow) #172

Deep Harmony 2.1.2 released

Change History

2.1.2

Changes

  • Update to latest Roon SDK (1.2.1) modules to pick up bug-fix.

  • Add reset Roon pairing to settings reset options

The Roon pairing reset will remove the pairing information. To complete this you will also need to click View on settings in Roon and remove the extension there as well. All Deep Harmony settings are preserved (Hubs, activities, Remote, favourites etc), so basically you just end up with a new pairing token when your re-enable which may provide an easy way to clean up if weird things are happening with Roon.


(simon arnold) #173

@Adam_Goodfellow its broken again since this update for me. I cant reset it using the inbuilt controls they just crash the extension and I can no longer see the Allow Remote Control again in the audio settings after resetting all of them to default.


(simon arnold) #174

Wont work at all going back to the latest in DOCKER HUB either.


#175

Thank you! Got it working…is there a way to change the functions of FF/ReW to Next song/prior song?


(simon arnold) #176

Look in the instructions as to what keys on the sudo Roku do and map them accordingly for the remote in the activity.


#177

Thanks for all your hard work Adam.

I’ve now successfully updated to the latest version 2.1.3+251 and can confirm within without issue on Synology NAS (no docker crashes since v1.).

I have now also tried out the ‘dual buttons’ feature, which is also working correctly for me now on Harmony Ultimate

I have one minor requirement left to get sorted. As part of the ‘activity shutdown commands’, I want to add a ‘Stop’ command; however, as the Roku mapping for stop is the ‘Power Off’ command, Harmony doesn’t make this available when I try to add a step. (NB: I could get this to work under v1 as the mapping was different).

The Roku power settings have been correctly set as ‘no power buttons’, but Harmony settings still have this command and it does not stop playback.

The reason I want this command is because I sometimes switch off my amp but forget to stop playback as well (my roon core and endpoint are always on)

Is there another Roku command that could be mapped to ‘stop’ instead of poweroff?
regards
Nick


(Larry Post) #178

I just send pause as part of the shutdown, but since pause and play behave as toggles it’s not foolproof. An actual stop command would be ideal.


(simon arnold) #179

I just cannot get this to work at all since last update. I have now tried everything I can think of.

Uninstalled it from Roon,QNAP and deleted the images and reinstalled.
Rebooted every thing many times.
Deleted Roon database and restored from backup.
Ran extension on Windows instead.
Removed audio endpoints from Roon.
Reset the audio device in Roon.
Deep Harmony clear settings crashes the extension and it won’t restart until I restart the container.

Nothing works I can set I up the Rokus show up in Harmony, but the External Source controls are absent as is the Deep Harmony option in the Volume Control.

The only choice next would be to try a different core to see if it’s ROCK related.


(Adam Goodfellow) #180

@simon_arnold
Can you do the following: switch logging level to ‘all’ (Settings -> Tools, Log Level, select All, click save).
Restart the container so I can see the following startup, pairing etc, then download the logs and email to me?

I am having no such issue here, which suggests it may down to a difference in setup / environment. Do you have a huge number of playlists or internet radios?

Thanks

Adam


(Adam Goodfellow) #181

Re: re-mapping stop (or other buttons). It is on the plan, just not in yet.

I want to get past these config issues that people are having before making any further changes that affect configuration as I want to be sure the Roon itself can cope with the number of settings (or more to the point, the number of selection in some settings) as I am seeing evidence in some logs that the latest release of Roon may have corrupted a setting, but am not sure yet. I have seen transient evidence before of Roon not always clearing down controls that should not exist any anymore, and I wonder if a combination of that and settings corruption could cause what @simon_arnold is suffering.

There was a recent minor looking change in SDK (and maybe the core too, I don’t know) which I am now wondering if it could be causing problems for people with larger/more complex setups even if I wouldn’t normally expect such a change to cause these kind of issues.

This is complicated for me because I cannot actually reproduce any of these issues here no matter what weird thing I have tried to upset Roon thus far.


(simon arnold) #182

PM’d you a link to logs. I only have 5 internet Radio stations and I dont really use playlists, there are some that got added from Tidal but thats it.