Roon Extension Manager terminates on Mac OS


after some fiddling around I managed to get the Roon Extension Manager and the Alarm Clock running on my iMac. Big thanks to Jan Koudijs and all who helped me in making this work!

I like the fact of having an alarm in Roon very much, as it allows me to ditch all other apps for my various devices. However, the Extension Manager often stops running, and then - obviously - the Alarm is not working anymore. Needless to say that this is very inconvenient when you can’t rely on your Alarm to wake up in the morning…

How can this be resolved? These are the messages I can see in the Terminal screen on my iMac.

-> CONTINUE 1 Changed {“message”:“Started: roon-extension-alarm-clock”,“is_error”:false}

-> CONTINUE 1 Changed {“message”:“Started: roon-extension-alarm-clock”,“is_error”:false}

2020-04-08T17:51:48.069Z - Inf: Terminating process: roon-extension-manager…

-> CONTINUE 1 Changed {“message”:“Terminating process: roon-extension-manager…”,“is_error”:false}

2020-04-08T17:51:48.075Z - Inf: Process terminated: roon-extension-alarm-clock (SIGTERM)

-> CONTINUE 1 Changed {“message”:“Process terminated: roon-extension-alarm-clock (SIGTERM)”,“is_error”:false}

I am running on OS X Catalina.

Any advice would be highly recommended as I am not familiar with the more technical aspects related to this!

I’m having this same issue as well – after a couple hours of running, the Roon Extension Manager quits. Running macOS Catalina.

1 Like

Hi Barry
I couldn’t solve the problem myself. So the Roon Alarm Clock became pointless: there is no value in an Alarm Clock when you are not sure that it will be active at the moment you need it…
I still hope that the Community will be able to help us

The solution on Mac OS should be the use of Automator as described in the Wiki. (Not a Mac user myself so I rely on the input from others here.)

If this doesn’t work then the workaround can be to disable auto update. You do this by clearing the “Check for updates” field in the Global Settings of the Extension Manager.

1 Like

Thank you @Jan_Koudijs, I somehow missed setting up the updater and the Automator login item. Thanks you much for your script.

@Jan_Schotte I’m guessing that what is happening is that the Roon Extension Manager is set to auto-update, yet doesn’t find the updater, so it stops. I missed that part of the installation: – and of course the Automator script for automatically running Roon Extension Manager is crucial to make sure it’s running when you restart.

1 Like

I am new in the business and I need help (I have almost no experiences with the terminal comand line). I am running Catalina 10.15.5 on a Mac Mini!
I set up the extension manager for the installation of the alarm extension (this was all easy)
The alarm function works, but I can not skip the terminal window for that reason.

-> CONTINUE 1 Changed {“message”:“Started: roon-extension-alarm-clock”,“is_error”:false}

-> CONTINUE 1 Changed {“message”:“Started: roon-extension-alarm-clock”,“is_error”:false}

I tried to install the automator und the fix - I think I did something wrong. Any clue for me?

Thanks in advance

Hi Jochen
I am afraid I can’t help you. I am not an expert either, and as you can read in this thread, I couldn’t make the alarm clock function work on an continuous basis. From time to time, the clock stops.
Therefore, - and I find it very unfortunate - I stop using the Alarm clock function