Roon Extension Manager v0.11.9 [Obsolete]

After enabling your iPhone as a zone it might still be a private zone, you can change this in the Device Setup for the zone (Here I am assuming that it works on an iPhone as it works on Android). A non-private zone should appear in the zone pull down.

1 Like


Thank you very much for your reply and your suggestion. This did the trick!

I can choose the iphone now in the extension manager on my laptop and ipad. It remains a pity that it is not possible on the iphone itself :joy: because of the limitation your wrote earlier about.


Using the Alarm extention I noticed another strange behavior which I want to report.

When I fill in as alarm time for example 17:55 and next save the alarm settings, then the extension manager is telling me that the alarm is set on 18:55. Is this intentional or strange behavior?

I suppose this has something to do with the Daylight Savings Time (DST). I live in the Netherlands and on this moment it is ‘wintertime’ here. In the Roon-Extension-Manager container on my Synology I defined a variable TZ with the value Europe/Amsterdam.

Thanks for the report @Alfred_van_Hoorn!

This turned out to be an issue with the Docker image, some critical timezone data was missing.

Please update to the latest (v0.3.2) version of the image and let me know if it solves the problem.

1 Like

Thanks @Jan_Koudijs for the latest update (v0.3.2). The problem with the Alarm extension is solved now.

1 Like

I’m retiring the HP Microserver that is currently running Roon Extension manager.
I will install Roon Extension manager on a new server.
Is there a config file that I can copy from the old installation into the new one so that my extensions and settings will be recovered?

Is v0.1.1 still the latest version?

I get the following errors:

Yes, that’s still the latest Windows installer.

Is this a clean install? Looks like the Extension Manager already exists at the specified location.

I am trying to run the extension manager on my linux roon server (Ubuntu 18.04) but no luck. Keep getting errors when starting. Anyone have an idea what I am doing wrong?

martin@earth:~/.RoonExtensions/lib/node_modules/roon-extension-manager$ node .
RoonApi.prototype.ws_connect = function({ host, port, onclose }) {

SyntaxError: Unexpected token {
at exports.runInThisContext (vm.js:53:16)
at Module._compile (module.js:387:25)
at Object.Module._extensions…js (module.js:422:10)
at Module.load (module.js:357:32)
at Function.Module._load (module.js:314:12)
at Module.require (module.js:367:17)
at require (internal/module.js:20:19)
at Object. (/home/martin/.RoonExtensions/lib/node_modules/roon-extension-manager/manager.js:17:29)
at Module._compile (module.js:413:34)
at Object.Module._extensions…js (module.js:422:10)

Hi @Martin_de_Vries,

Looks like a broken install to me.
What installation method did you use, and were there any errors in the output during installation?

I used the installer script which seems to do everything ok. No errors there.

Is the service running?

You can check the status with:

systemctl status roon-extension-manager

No. it isn’t running:

Feb 01 18:42:59 earth systemd[1]: roon-extension-manager.service: Start request repeated too quickly.

Feb 01 18:42:59 earth systemd[1]: roon-extension-manager.service: Failed with result ‘start-limit-hit’.

Feb 01 18:42:59 earth systemd[1]: Failed to start Roon Extension Manager.

A few more quick checks:

Do you get any errors if you run npm list from the install directory (where you also ran the node . command)?

What are the Node.js and npm version numbers?

node --version
npm --version

martin@earth:~/.RoonExtensions/lib/node_modules/roon-extension-manager$ node --version


martin@earth:~/.RoonExtensions/lib/node_modules/roon-extension-manager$ npm --version


That might be too old, do you have the possibility to replace this with a 6.x or 8.x release?

1 Like

Thank you so much: That was it. Installed version 11 and working great. Didn’t expect that as I run a rather up tpo date Ubuntu server (18.04).

1 Like

I am trying to install Roon Extension Manager on Windows 10. I am getting the following error when I run the

mkdir ~/.RoonExtensions

The syntax of the command is incorrect.

Any advice?

Thank you!!

There is an installer available for Windows. Instructions can be found here.

1 Like

The next version of the installer script will check if at least version 6.x of Node.js is installed, an error will be reported if this is not the case. So future Ubuntu user have a clue of what to do :slight_smile: