Roon Extension Manager v0.8.1


(Jean ) #101

Hello Jan

Thanks a lot for your help and support…
Nothing happened when the start script is run…

Below is the response when the command is launched…

image

After running the command as suggested in your response… the extension manager is working again…

image


(Jan Koudijs) #102

Good.

If the manager.log file in the current directory (slowly) increases in size then logging is active. Now we have to wait and see…


(Jean ) #103

Hi Jan
How can I verify the size of the manager.log …?
Will see again tomorrow and will update you.
Thx


(Jan Koudijs) #104

Type:

ls -l manager.log

In the command window. You should get something like:

-rw-rw-r--. 1 Jan Jan 39315 18 jan 20:23 manager.log

The biggest number is the size of the log file (39315 in this example), if you repeat the command after a few minutes the number should have increased.


(Jean ) #105

hi Jan

Thx a lot for your response…

Something may have gone wrong in my installation…

The extension manager survived last night and still loaded today… So it may be working.

but when I run the command of the manager log… no expected outcomes… as shown below…

image


(Jan Koudijs) #106

I expect that the log file got lost during the update run over night, I forgot about that. If the extensions are still running you can keep them running but in this case there will be no log to analyze in case of failure.

If you want to restart, do the following:

Stop all running extensions

killall node

Run the start script

node start.js inherit_all > ../../manager.log 2>&1

The log file should be found with

ls -l ../../manager.log

(Jean ) #107

Hello Jan

I’m still having the same issue…
Extension work in the night and stop and disapear in the morning…
Then I have have to start Node once again etc…
Any way to help further, please?

image


(Jan Koudijs) #108

At least you do have a log file now :slight_smile:

Can you upload the manager.log file to somewhere online (e.g. dropbox) and send me a link? You can zip it to reduce size.

The log stops at 2:00, this is the default time for the auto update. As a workaround I suggest that you disable auto update and see if it keeps running that way. You do this by clearing the ‘Check for updates’ field in the Extension Manager settings.


(Jean ) #109

hi Jan
thanks , I have cleared the update time… ut don’t know the location of the saved log file… strange…

Thx


(Jean ) #110

Hi Jan

Please to note that The alarm started this morning on time set…
So it look like clearing the update time help for the service to run…
I now guess that the update need to be done manually…
Will monitor the extension in coming days and will update you accordingly.

Thanks a lot for the support…

Cheers

Jean


(Jan Koudijs) #111

OK, we are getting closer.

The log file can help to further pinpoint the issue. Do you only have command line access to your Debian system? Accessing the log file might be easier from a graphical desktop environment.

It might already help if you can provide me the output of the following command:

cat ../../manager.log

The interesting part is at the end of the file, try to provide as many lines as possible by creating a screen capture as you did previously.


(Jean ) #112

hello my friend
below are the outputs of the command
image


(Jean ) #113


(Jean ) #114

image


(Jan Koudijs) #115

Thanks, the error information is in.

The issue is with the self update of the Extension Manager, for which it is known that it doesn’t work on all platforms. The service approach uses a different update mechanism and this might also be the solution for you.

I have created a basic Linux install script to setup the service but I still have to create some documentation for it. When this is available I will let you know.

Indeed, you can update all the other extensions manually using the Settings dialog.


(Jean ) #116

Hi Jan
Thx a lot my friend…
The extension started this morning on Time…
It look like the issue was related to the update…
But great work… I can now sleep with my classic music and be assured that Roon will stop .
Please let me know when the script is available…
Have a great weekend .

Thx a lot
Jean


(Jean ) #117

Hello again Jan

Hope your week was excellent…
Another issue with the alarm clock extension…
set the alarm on the device in the kitchen…and it always starts at a full volume…which is not fair for people still in bed…
Any way to change the volume settings at the start of the service?
Thx
Jean


(Jan Koudijs) #118

Have you set the wake volume for the alarm?

wake-volume


(Jean ) #119

Stupid Me…

Thanks a lot … as my system is showing in decibel. I left it to 0 decibel… ignoring that my amp volume ranges from -40 to 0… with 0 being the full volume…

Thanks a lot my Friend and sorry to bother you once again.

Cheers

Jean


(Jan Koudijs) #120

The script is available!