Roon Extension: Publish to MQTT broker

It worked now. Thanks!

1 Like

Hi, big thanks for creating this extension.
I am using it on a QNAP with the extension manager in a docker container. My mqtt broker is running without any problems or advanced settings (no auth or ssl)
Currently, I must enable it daily (by Settings > Extensions).
Is there any way to keep it enabled?

Does the docker container stay online, or is it restarted daily? If so, maybe the config volume is not mapped/mounted correctly inside the container.

Seems like the extension manager starts update at 1:00 and stuck on (get a few hunderd of these messages)
-> CONTINUE 1 Changed {“message”:“Updating: roon-mqtt-extension…”,“is_error”:false}
until I connect to Roon again manually
Core lost: [CoreName]
I’ve set the logging on debug now, let’s see what tomorrow brings.
Seems like a roon-extension-manager related issue?

I think so, probably related to an issue with the docker volume not mapped to the config directory in the container.
When that is the case and the container is re-created or restarted it will have an empty configuration and will have lost the association with the core.

@Jan_Koudijs Did I miss something in the repository entry for the extension?

Hi @Robbert_N,

Please try the steps listed in this post:

In order to keep the configuration of the installed extensions it is important that you create a Docker volume for the extensions when you create the Extension Manager container.

At the command line this is done with:

-v roon-extensions:/root/.RoonExtensions/lib

If you use the web interface of the QNAP you have to check how to create volumes there.

I’ve de-installed, uninstalled and installed the MQTT extension. Currently it’s on 2.2.0.
Yes, my compose file is as follow:

version: "3"
    image: theappgineer/roon-extension-manager:latest
    container_name: roon-extension-manager
    restart: unless-stopped
      - ./roon-extensions:/root/.RoonExtensions/lib
      - PUID=1000
      - PGID=1000
      - TZ=Europe/Amsterdam
    network_mode: host

    external: true

You specified a relative path in the volume definition (./roon-extensions), I don’t know how that is treated by Docker. Please remove the leading ./ and create a new container.

1 Like

Damn, that must be it! thanks!

1 Like

Hey there,
i just tried this to embed in my openhab3 panel, but i still get only the black “roon” displayed in my frame, no cover. i think the issue is that there is no support. in my chrome-browser its working after activating in roon settings…but i cant activate the display for openhab…
how did you get it working?
Thx fpr help, Hannes

Hi. you must enable/select the display from the “volume menu” (looks like a TV next to the DSP button).
hope you find it :wink:

Hi, yes, i know this Well- That ist exactly the Problem! This Display Icon just doesnt Show Up when ii try to connect via openhab as it usually does with chrome Or Firefox…does it work in your setting with openhab3?

Hi. sorry not tested in OH3.0 but works fine in older… Would be soo nice with a Roon Binding for OH3… HA have one… (not tested)…

Just wanted to say thanks ! I’m controlling roon using a magic cube with this :slight_smile:

1 Like

Hi @eFJee

Can you please point out what I might be doing wrong to get this error?

Here are my (unchanged) settings:

I’m running the extension under Docker on a Synology NAS. In the Docker GUI I enabled auto restart and use the same network as the the Docker host.

In your reply, please bear in mind that my knowledge is limited to configuring items presented in a GUI!

And finally, has volschin taken over updating this fjgalesloot? I found almost identically named images on docker, but the volschin version has been updated more recently. When they’re running, they both appear in Roon as Floris Jan Galesloot.


1 Like

If you are running the docker image, than probably your MQTT broker is not running on You should enter the correct IP adress of your broker.

I’m not aware of a newer docker version. Maybe volschin just wants to create his own docker images. Don’t now. The one at fjgalesloot/roon-extension-mqtt is updated when the github master branch is updated, so should always be up to date.

1 Like

Thanks for the reply. Entering the IP address doesn’t improve matters:

What should I try next?

1 Like

So there is a connection issue between the extension and your MQTT broker. Did you enable the need for encryption, or username/password in your broker config? You could try to connect to the broker with MQTT Explorer and see if that works.

1 Like

Thanks @eFJee . It’s connecting now to the broker (eclipse-mosquitto running in a Docker container on my Synology NAS) with both the broker and extension (also in a Docker container) using localhost.

But I’m still stuck! I’ve installed the MQTT Broker binding and OH3 tells me it’s Online. But when I try to add an Item to OH3 I get told there are no Channels reported, so I’m stumped at this point. Sorry to pose such a noob question, but can you give me a pointer please? Many thanks

Hi @John_Warden. I think the OH3 configuration is not something to discuss here. It can be rather complicated. :wink:
I am using Domoticz with with Node-Red mostly for MQTT and just a little bit of OH in that mix. I think you should add those Channels manually in your MQTT Thing.

See: MQTT Things and Channels - Bindings | openHAB.
But maybe someone at can help you with the setup.