Roon Extension: Rotel Volume/Source Control

In ‘roon - settings - audio - device setup’ of your audio device: did you setup the ‘external source control’ correctly?

2 Likes

Hi Boris,
You’re a genius! I only indicated “Rotel Volume/Source” in the Volume control setting.
Now I also added “Rotel RC-1590 Rotel Volume/Source Control” in the External source controls, and now it works perfectly.
Big thanks for your help, Frank.

Hi Boris,
I downloaded the latest version of RooExtend (3.0.2), in which roon-extension-manager by TheAppigineer (Home · TheAppgineer/roon-extension-manager Wiki · GitHub) is implemented.
But, under the Category “Device Control”, your extension for Rotel “roon-extension-rotel” is not available.
Can you check with @Jan_Koudijs how your Roon-extension can be added in his image?
That would be much appreciated.
By the way, your tool is realy fantastic! Many thanks for all your hard work for this.
Kind regards, Frank.

This is the effect of ARMv8.
Docker images made for ARMv6 seem to be not available yet with ARMv8. :- :cold_sweat:

That is a pitty :sob:.
I hoped to be able to put the Rotel-extension on the same RPI.
Lucky for me, I still have an old separate RPI2 on which runs the Rotel-extension.
I can only hope that @Boris_Schaedler will upgrade his roon-extension-rotel to be used with ARMv8-processors.
Thank you for the explanation, Frank.

I guess this will come sooner or later as ARMv8 ist the current standard.

Hi @Frank_M,

The Rotel extension hasn’t been converted to the format that is used by the 1.x version of the Extension Manager, but you should be able to use it.

In the System category you will find the Extension Snapshots, if you install that one you can open the Settings of it and start the Rotel extension.

1 Like

Hi Frank,

I will add the Rotel extension to Jan’s extension manager v1.x… give me some time… :wink:

Best,
Boris

2 Likes

Your the man!
Thank you so much.
Kind regards, Frank.