Roon fails to detect my PSA bridgeII

As above:
My Surface Pro 3 running Windows 10 64 bit is the core. It sits in a microsoft docking station which gives me ethernet connection and multiple USB 3 connections.
The modem/router is rented from Comcast with a 140Mb/sec speed.
I connect to my PS Audio audio DSD dac thru a Netgear Prosafe GB switch. The connection is ethernet to the PSA BridgeII (which is Roon ready). My other connection is by ethernet to microrendu to USB to the DAC.
I can use Roon to listen to my 2500 albums on the Passport drive and computer, and access my Tidal favorites thru the microrendu going to the DAC’s USB input.
If I want to listen to the same thing thru the bridge, I have to use mControl on my iPad. I would dump the bridge and use the microrendu exclusively but I need the bridge to fully unfold MQA files. In addition, I believe that files played with Roon just sound better.
So, when I set up Roon on my system, the bridge is not listed under settings-audio, and I can’t enable it.
It’s that simple, and I hope you can help.

Make sure no firewall is on on the windows box

I’m running Norton firewall and " Windows Defender." I’ve shut down the Norton firewall and that didn’t help. Where do I find the "Windows box?
Also the “PS Audio USB driver” failed to initialize according to settings-music in the Roon program.
I don’t know what this means.
Thanks very much,

BOX i.e. PC … your core. Windows Defender is for malware IIRC you need to look in settings

I’m frustrated about this problem, and I may resort to uninstalling and then reinstalling the Roon program. Maybe this time around the bridge II will be detected.
What about this for a next step?

Hey @John_Wyant,

As wizardofoz mentioned above, I definitely recommend temporarily disabling the firewall on your Core machine and see if there is any change in behavior.

Are you able to play to this device from the same Core machine outside of Roon?

Just to verify, when using the microRendu things work as expected, correct?

Yes, I can play to the PSA bridge using the mConnect program which is a controller program for the bridge from “Converse Audio”
Yes, playing to the microrendu works just fine. -sounds great.
Please understand that I just want to control all of my music including Tidal MQA with Roon. The bridge input is necessary for the full unfold of MQA.

It doesn’t make sense to me that the Microrendu as well as an Apple tv are detected despite my firewalls, but the Bridge is not.

@John_Wyant I used to have the PSA DS-Junior…and recall that there was a min version of the bridge firmware that needed to be in place.

So perhaps you can detail the version of the bridge firmware and for that matter the DS also. I won’t assume you are on the latest versions.

Have you used mConnect “Device Setup” to make sure you are running the latest Bridge II software? What version does it say you are running now? I am on 3.6.2.

I’m using 3.6.2 bridge firmware. One thing I noticed in the settings-music section of Roon is that the “PSA USB driver failed to initialize” The bridge is on ethernet, so this probably doesn’t matter.
I’m getting very close to removing and reinstalling Roon. -Nuclear option!

Problem solved with the help of Jeremy in PSA support. -No problem with Roon or the Bridge. The problem was with me!

What was the issue if you don’t mind sharing?

Roon setup was confusing to me. I had two zones labeled the same -both PSA DAC, when one was the bridge and the other was the Microrendu. I guess I was clicking on the wrong one to play to the bridge, as I remember.
Simpler instructions for computer dummies would be nice.

This topic was automatically closed after 2 days. New replies are no longer allowed.