Roon fails to launch on Windows 10 after the last update

Roon fails to launch on Windows 10 after the last update. Any feedback is well appreciated.

Moved to Support

1 Like

@GAVRILA_COSMIN, as @Suedkiez has moved your post to the Support category, can you please provide the following information so Roon staff and the Community can assist you:

Roon Server Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

Good morning and thank you for your help!
In the attached pictures you will find the setup details, as follows:

  • roon core runs on a windows 10 desktop computer;
  • router model ZTE;
  • switch ubiquity ES12 F;
  • Weiss 501 network renderer - endpoint;
  • all connections are rj 45 wired;
  • I currently don’t have a local library, I only stream from Tidal and Qobuz.
    The issue is that roon app does not launch anymore, the initial message was that I wasn’t connected to Internet, though I was. Also, the firewall notified me that it had blocked some of the features of roon app. I tried to customize firewall in order to allow roon to work, but with no result.
    Now the message that appeares on my screen is the one attached in the picture.
    The other things I would like to ask/add
    are:
  • I want to relocate my roon core on a Synology Nas 220+;
  • If I reinstall roon on my current core, will I be able to prevent the loss of my playlists, given the current malfunction?
    Thank you!
    Looking forward for your reply!


I would start with another look at the Firewall, there was a Roon update along with a Windows update this week

There should be 2 added lines in the allowed apps

Thank you, I will also try that, though I basically enabled all the items that were related to roon app.

Any sugestion about the 2 extra lines in firewall? I just checked again and I can’t figure out what those would be. Thank you!

See this article. I believe that the new release of Roon is also possibly likely to require a firewall exception for roonappliance.exe as well.

1 Like

Hello again folks! Problem solved! I’m not sure whether the firewall was the “culprit” (though I had previously allowed all the roon related items to work), thing is that I unpluged/repluged both the router and the switch and it worked. Then I was asked to sign in again and that was all. Music is playing again. Many thanks to those of you who bothered to offer some suggestions! I do have to say that I’m really dissapointed about the roon customer service, though, It’s already the second time in less than 2 months when roon app fails to work right after the update, I’m sure that is not what paying customers expect from an update.

1 Like

Part of the install should be a reboot but it’s not.

My system is rebooted daily due a variety of issues, never does any harm and I never see any of these connectivity issues

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.