Roon fails to load after recent preview Windows update [Solved - Firewall Permissions]

Core Machine
Dell XPS 15
Windows 10 Pro x64 (21H1)
Core i7, 32GB RAM, 512GB SSD

Have been using Roon without issue for some time now. A few days ago it just stopped loading. When I try to start it, I see the Roon window open and the animated logo, but it never advances from there.


I am not 100% sure that this is due to the most recent preview update to Windows, but the update was the only thing to change before Roon stopped loading.

Tidal and BlueSound apps are not affected.

I uninstalled Roon and reinstalled it yesterday, but no change. It still would not open.

What further info can I provide to assist you in troubleshooting this?


Updates can go wrong. I often have to undo and then redo an update. I would suggest first that you roll back the update and verify Roon works. Then I’d wait on re-doing the update for a month or two. (fixes may come out).

2 posts were merged into an existing topic: White Screen with Speaker in the middle

Hello @RogerP and welcome to the Roon community :wave:

I’m sorry you’re here because of such an issue :sweat:

As per @Rugby’s advice (thanks :pray:) could you please try reverting to the previous version?

I uninstalled the Preview Update but Roon still won’t start. There was also a Servicing Stack Update installed at the same time as the Preview Update, but there is no option to uninstall that.

I listed the make and model of my previous Roon Core laptop (Dell XPS). The Roon Core is currently installed on a Lenovo ThinkPad T580. The rest of the specs are the same.


I removed all of June’s Windows Updates on both computers and Roon would not start on either (XPS and ThinkPad, both enrolled in Window’s Insider beta program). Please let me know what the next step is in troubleshooting this issue as I have been unable to access Roon for a week now.

Any updates? Roon is still not working.

In another post Roon on Mac had a similar problem as I am facing due to an issue with Tidal. Is this also the case with Roon on Windows? If so, what is the solution?

Is it possible to contact Roon Tech Support directly for assistance? I would like to get Roon working again.

Go to the manufacturers site, not windows update, and get the latest drivers. Windows update often puts terrible driver updates in place.

Agreed. I download Intel drivers directly from Intel and the rest of the device drivers for the laptop I get from Lenovo directly.

It has been two weeks now since I reported the problem I am having with Roon and I have received no useful technical assistance from Roon. Does the annual subscription fee not include technical support for the product? Please provide a method by which I can contact your Tech Support group for further assistance.

I have finally succeeded in getting Roon to work again. Roon and RAATServer both had permission to access both Private and Public networks through the Windows Firewall. I removed access to Public networks from both Roon and RAATS (leaving only access to the Private network) and Roon started right up. Access to Public networks was the problem that prevented Roon from opening, though I am not sure why this would be the case. What if I wanted to use Roon from a hotel which would be a Public network?

I also had to logout of Tidal and then login again to get Tidal to work in Roon though it showed me as already Logged In.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.