Roon fatal (OpenGL) error when launched

I get a “GL_ARB_framebuffer_object OpenGL extension is required. Your OpenGL drivers need an upgrade or video card is not supported.” error message that is not overly helpful.

I am trying to run it on a CAPS v3 Windows 8.1 system that hasn’t had any issues running anything else I’ve tried on it.

This is of course a headless PC which I remote desktop into (from my Win 7 Pro machine) in case that’s relevant.

My understanding is that there is not a headless server version yet, so I suspect it is a graphics issue with your CAPS box, what graphics card do you have?


There are several topic on this if you search on opengl or on server 2012.

Bottom line:

  • you need to run an opengl driver
  • remote desktop does not allow that


  • use splashtop
  • or start roon using a batch job on your headless computer. It logs you off, starts roon and when you connect a little later you can then use remote desktop just fine.

I use the latter option.

the script (from: Install for Roon on Intel NUC + Win2012R2 Essentials - Using Audiophile Optimzer):
tscon.exe %SESSIONNAME% /v /dest:console
timeout 1
Start C:\Users\Administrator\AppData\Local\Roon\Application\Roon.exe

Thanks for the replies.

Using that script (in a batch file) it doesn’t log me out of RD. Do I need to replace SESSIONNAME with something
specific to my setup?

I’ve gotten a bit further: I was getting access denied so I ran the .bat file as an administrator to solve that problem.

Now I’m getting invalid parameters. I’m guessing this is a Windows Server script and it won’t work on Win 8.1 without some sort of modifications…?

Finally got it to work.

I replaced:
tscon.exe %SESSIONNAME% /v /dest:console

tscon.exe 1 /v /dest:console

1 Like