Roon Freezes on Certain Tracks, Repeatedly and Predictably

Core Machine (Operating system/System info/Roon build number)

2012 Mac Mini w/Joule V LPS, running Catalina 10.15.3
2.6 GHz quad-core Intel Core I7
16 GB 1600 MHz DDR3
SSD internal drive, personal music library on external SSD drive.
Roon Core 1.7 (Build 571)

Remotes are any of two iPhones, two iPads, or a MacBook Pro. Results are consistent across all devices.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

  • UBEE modem (ISP provided.)
  • Mac Mini is hardwired ethernet to Linksys Velop mesh network parent node in a remote room. No switch.
  • WiFi to Linksys Velop child node near stereo system.
  • Hardwire ethernet from child node to UpTone EtherRegen B-side
  • Optical ethernet from EtherRegen A-side to Sonore OpticalRendu
  • USB from OpticalRendu to Matrix Audio X S/PDIF converter
  • HDMI/I2S from Matrix to PS Audio Directstream DAC

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

As above: OpticalRendu to Matrix X S/PDIF to PS Audio Direcstream DAC.

No upsampling, no DSP.

Description Of Issue

Playing certain, specific tracks causes Roon to stop playing, and enters a state that I’ll call “churning”. While Roon displays that the track/album will play (cover art, track list, etc.), it never gets started. The time counter stays at 0, and the time scrubber shows a blue light traveling back and forth continually. It stays in this state until intervention (restart of Roon Core).

This behavior is perfectly repeatable on given albums/tracks that I’ve identified, below. I’m pretty certain that it happens on some other albums, but I’ve not been tracking those.

When churning happens, I can search Roon for other material and select, but those choices will not play until intervention. During churning, I can use an iPhone to play Roon to the iPhone’s Audio Zone, as long as it’s not an affected album/track. But, this same behavior happens on the iPhone or iPad: Play the suspect track and Roon on that device will churn.

One such track is Leonard Cohen’s “You Want it Darker”, which is one of my favorite songs. I used to play that track nightly. Now I can’t get it to play via Roon at all. At times, I’ve gotten other tracks on the album to play, but at least two tracks on the album cause churning.

Another problem album/track is the Notting Hillbillies “Missing, Presumed Having a Good Time.” Previously, I could play the first two tracks and the third track would cause churning. This happened repeatedly. Now I can’t get anything on the album to play.

I used to reboot the Mac Mini in order to recover, but I’ve discovered that if I quit and restart Roon Server (Core) on the Mini, I can get back to normal functions much more quickly.

This is an annoying behavior because I never know when a track will cause Roon to hang up, interrupting an otherwise enjoyable listening session. For the most part, though, I could play Roon Radio all day without a hitch, or select albums or playlists that I know will play through. Most of the time things are fine.

Testing Notes:

After giving up while Roon is churning, if I choose another album, that album doesn’t play. No album or track will play. The timeline shows the track’s waveform, but there is no sound and the scrubber never moves. Just frozen in time. Again, I can choose other material, but it won’t play.

Once or twice, if I chose a different track and waited a long time, something might play. No rhyme or reason on that. IF this happens, I often get “This track is not currently available from Qobuz”, although clearly it is available.

I can play both albums/tracks on Qobuz desktop app.

When any iteration of Roon Remote on any device churns, it’s not likely to come back to life. I’ve never seen that happen.

After quitting and then restarting Roon Server, CPU usage spikes up to 200% for about 30-60 seconds, during which the Roon Remote screen stays black with the white Roon logo, and then it comes back to life. Probably normal. When Roon returns, whatever album I had been trying to play plays fine, except for the two albums in question.

Once the churning begins, say, on iPhone, I have to quit Roon Remote and restart. After restart, choosing another album will play fine. “Darker” always fails.

I replaced the OpticalRendu with an UltraRendu. Same results.

Logging out of and in to Qobuz yields the same result.

I’ve run First Aid on all disks.

There are no known network issues; everything else in the house works as expected.

@support, I hope you can help unravel the mystery.

I tried both of the tracks you mentioned, from Qobuz, without any problems.

I have RoonServer on WIN10.

Not disputing your experience, but @support might not be able to recreate either.

“You Want it Darker” plays for me from my local music files. (Roon core on Ubuntu Server NUC, music on internal SSD). I wonder if those files might have become corrupted on your music SSD.

Just to make sure, Were those tracks local or on Qobuz? If local, what format?

I think I would reduce everything first to just the RoonServer and use local output and see if the tracks still lock up.

if so, than this removes the rest of the audio chain for consideration, If not, then you can focus on adding things back into the chain and see where it breaks.

2 Likes

Although, when I tested I just played the tracks without adding them to my library.
Don’t know if that makes a difference.

Gotcha, got confused by other responses and thought I missed something.

Both albums are from Qobuz. I do not own local copies.

Based on the suggestion above, I went through Screen Sharing (the Mini is headless), started Roon Remote on the Mini, enabled System Output.

I started Darker, and it played. I couldn’t hear it, of course, but the scrubber showed progress.

I then went to play the Notting Hillbillies album, and got the churn.

I’d consider that to be a ‘mixed’ result.

Well, belay the above.

I just went back for further testing on the Mini, running both Core and Remote there.

Consistent results: both albums cause the churn. I don’t know how I got Leonard to begin playing that one time. Now, it’s a no-go.

As mentioned, I think there are other culprits out there, but I simply can’t get these two to behave.

Hello @Rob_Hanson, could you reproduce the issue one more time and reply here with a timestamp of when you do and the track you were using so I can enable diagnostics for your account and take a look? Thanks!

I’m ready to go when you are. Where do I get the time stamp? Clock time? Something else?

@nuwriy

@nuwriy

Another question: When I recreate the problem should I leave Roon in that state, or can I go about ‘fixing’ it and playing other music.

Several times, I’ve run Roon Remote and Core on the Mac Mini, playing to system output. The problem still manifests there, so I suspect it’s not related to the audio stack.

Annnnd… today on a whim, I tried playing Cohen’s song and it worked! I was startled. I jumped off of that (I should’ve listened to all of it) and went to the Notting Hillbillies track. It, too, played. I hit a track that caused the ‘churning’ problem, and now I’m back to a consistent problem.

Thanks

@nuwriy

Okay, I have some time stamps for you to look at, along with some other observations.

All times are Eastern U.S.

At 9:13AM, I tried to play Leonard Cohen “You Want it Darker” Qobuz version from a Roon Platlist (my only version). It ‘churned’ on the track and after about 3 minutes Roon jumped over it to the next track in line, playing well.

9:16AM Repeated the above. Same results.

After that, I tried cueing up The Notting Hillbillies “Missing, Presumed Having a Good Time” from Qobuz (my only version). ‘Churning’ happened on the first track for about 3 minutes. Roon then jumped to the second track with “This title is not available on Qobuz”, churned for about 3 minutes, then jumped to the next track, etc., etc.

At 9:27AM, I tried to play Cohen’s track again, and it sat and churned.

At 9:42AM, I’m leaving the system in this state for you to have a look. Leonard is not playing… just churning.

Okay, here’s the kicker: Last night, I got “You Want it Darker” to play! It seemed that if I played a couple of tracks in the playlist ahead of it, Darker would load correctly. But then, if I moved the track down the list to have it come up again, it wouldn’t always work. It made me think of some sort of buffering issue (it is a “large”, dynamic song). Problem is, this is not repeatable.

At 9:44AM, the system is no longer churning, i.e., no blue light traversing the scrubber bar, but neither is the album playing. Just tried jumping to the next track, but it’s churning.

I will leave the system in this state as I go about my day. My only known fix to this is to restart Roon Core. The interesting thing is that “Darker” and “Notting Hillbillies” and possibly Margo Price “That’s How Rumors Get Started” have chronic issues playing, but that I can access and play almost anything else that occurs to me to queue.

I am also having a very similar experience with Qobuz playlists. It doesn’t seem to be speccific to any particular playlist or track.

I am getting relatively frequentt skips. Sometimes a single track, sometimes 2/3 tracks. Sometimes I can drag the skiped track(s) back on to the queue and sometimes it will work. Sometimes, not, or I wlll have to try several times.

We are temporarily away from home whilst renovating. So I am using a regular chromecast over wifi as an endpoint. At first I thought it was just something to do with the network, over which I have little control. Maybe, it still is. But then I saw this post.

That doesn’t sound exactly like my issue, but close.

I don’t get skipping of tracks, usually. When I hit this issue, I’m dead in the water until I restart Roon Core. Even though the offending tracks are from Qobuz, nothing, even library tracks, will play until the restart.

Hello @Rob_Hanson, those timestamps are exactly what I wanted, thanks! I’m going to enable diagnostics for your account so I can deliver a report to the team on this.

1 Like

@nuwriy

Thanks for having a look.

Since that time, weird things have been happening. Once during a playlist, “Darker” came up and played through. Whaaa?

Other times I would set Roon up to stall/churn, and some minutes later it would begin playing.

I’ll test more later. I may set one up now, in fact, in case you want a look.

1:07 PM eastern

1:08 PM Monday eastern

Darker started playing through, but I’m churning on The Notting Hillbillies.

On that album, the track will churn for a few minutes, then jump to the next track and churn. And so on.

It is happening now.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.