Roon Freezing Between Tracks

@support

Everything has been working fine for the past couple of months since I started using Roon.

A couple of days ago, I began experiencing a problem where Roon is freezing when changing tracks. It seems to only be happening while in Radio mode. If I manually select an album or multiple albums or tracks, playback seems to run fine.

In Radio mode, it may play a few tracks and then stop as the next track is about to play or it may play for an hour before the problem returns. When playback freezes, I can click the Pause icon and then the Play icon and playback will proceed for a while, but the problem keeps recurring – always at the beginning of a new track.

I have tried rebooting all related hardware and software through the web interface as well as the physical hardware without successfully resolving the problem. It has become clear that I will need some guidance to resolve this issue.

Roon is running on my Macbook Pro with an i7 Quad Core processor.
Music files are stored on an external Thunderbolt hard drive.
Ethernet connectivity is provided by Netgear 1200 Powerline Adapters.
Roon endpoint is a Sonore ultraRendu connected to the USB DAC input of an Oppo BDP-105D.
All tracks are being upsampled to DSD128 through HQplayer.

Any troubleshooting suggestions would be appreciated.

– Kevin

Hi @Kevin_Schonhaut ----- Thank you for the report and sharing your feedback with us, the insight is appreciated!

Moving forward, to help us better understand what could be going with your setup, may I very kindly ask you to please provide the following information:

  • Screenshots of…

    • The playback settings being used in Roon for the mentioned endpoint (i.e Sonore ultraRendu connected to the USB DAC input of an Oppo BDP-105D).

    • Your signal path leaving Roon.

    • The settings being used on the ultraRendu.

  • Since noticing this freezing behavior have you tried bypassing the ultraRendu + BDP-105D enpoint, temporarily, and confirming if there are still stops between tracks?

-Eric

@eric

I found that when I take HQPlayer out of the equation and switch the ultraRendu to Roon Ready mode, the Roon Radio feature works perfectly and does not freeze between tracks.

I don’t know whether that means my issue is with HQPlayer or the ultraRendu or Roon/ultraRendu/HQPlayer synergy or upsampling in general.

Here are some screen captures. Any advice would be appreciated.

Your signal path shows that you’re upsampling to DSD128 in Roon before the stream goes to HQP. How does it work if you just send a bitperfect stream to HQP and do all your DSP there?

David,

Thanks, I see your point. In this scenario, apparently HQPlayer would only be applying the selected filter.

But, when I’m using HQPlayer and I disable the DSP Engine in Roon’s Audio settings for my HQP zone all I get is stuttering.

When I close HQPlayer and set up the ultraRendu in Roon Ready mode, this is my signal path:

But, this way I lose the ability to use the HQPlayer filters.

Kevin

The symptoms you’re describing sound like what happens when available computing resources are exhausted or nearly so. This seems strange to me, since your quad-core i7 MBP ought to be able to handle what you’re trying to do in the way of DSP, IMO. Are there other applications running on the MBP? Also, what happens if you upsample to DSD128 and use a poly-sinc filter with HQP only (i.e., with Roon not running)?

David,

I turned off the DSP processing within Roon and set HQPlayer to perform the DSD128 upsampling chores with the poly-sync filter.

Roon’s Radio feature has been running without freezing between tracks for a couple of hours.

I have been monitoring CPU usage and note that the poly-sinc filter puts about 30 percent less load on the system compared to poly-sinc-xtr filter I have been using.

When Roon’s DSP handled the upsampling, I could select multiple albums or tracks (16/44, 24/92, 24/192) and they would play perfectly with the xtr filter.

Using HQPlayer to handle the upsampling with the xtr filter, every track would stutter. DSD64 and DSD128 files which didn’t require upsampling played perfectly.

So, thank you for your suggestions. Using the poly-sinc filter is good solution for times when I want to make use of the Roon Radio feature.

Kevin