Roon Frustration “audio track loading slowly. This could be a performance or hardware problem“

Roon Core Machine

Roon Core is Nucleus

Networking Gear & Setup Details

Telus modem, Asus Routers (x2)

Connected Audio Devices

Naim ND 5XS (as DAC), Naim UnitiServe, Bryston B100 Amp, Limetree Bridge (Roon Device)

Number of Tracks in Library


Description of Issue

The problem started while listening to internet radio through Roon. The broadcast stopped abruptly. Now when I try to listen to Tidal or music on my Naim server the track stops playing and I get a message saying “audio track loading slowly. This could be a performance or hardware problem.” When the track stops playing it sometimes jumps to the next one but the problem repeats itself. I have rebooted everything on my network but it’s not helping.

Hey @Laurie_Long,

Ben here with the support team, thanks for taking the time to write in! I’m sorry to hear you’re running into playback issues with your Roon account.

An important question for you: how is your core connected to your network? In general, hardwiring your core to your network will provide the best and most stable connection overall.

The first step to test here would be to give your core and router both a hard reboot.

  1. Power down both
  2. Unplug devices
  3. Wait 2-3 minutes
  4. Plug devices back in
  5. Power devices back on

Here is a great article on networking best practices that may be helpful as well. Do any of the suggestions here apply to your system?

I’ll be monitoring this thread for your reply :+1:

Thanks Benjamin. Before receiving your suggestion I tried another complete reboot and it worked. If I may make a general comment. I find I have to do these reboots at least a half-a-dozen times a year. It’s a very frustrating experience involving what is supposed to be a premium audio service.


1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.