Roon funkiness when albums are added

I recently got a server from Mojo Audio with the Linux OS. Sound quality vs. the same hardware with Windows 10 is vastly better. However, something funky goes on in Roon when I add albums, as I have on a couple of occasions, Roon seems to launch itself on a re-indexing binge. What’s weird is for a time, it doubles the album count, and everything slows down, and albums are visibly duplicated (2 cover icons instead of one, and twice the files). After about 10 or 20 minutes, things settle down and the album count returns to near normal. I say near normal, because the second time around I added albums, I had 11 fewer albums (1298 vs 1309) than prior to adding. Weird stuff that I never experienced in the Windows version. Files are stored in 2 folders, in separate partitions on a local SSD. There’s no duplicate content in the folders. Any ideas? Thanks. – David

Thanks. – David

Not really having a clue but what you describe let’s me think Roon might get tricked into assuming the storage location(s) have changed. At least the behaviour you see points to it. Are those partitions somehow dynamic / have been changing in size? Or is the SSD doing something (like marking cells as unusable and thereby changing the actual volume size)?

Interesting…pretty sure the partitions are fixed. Not sure at all about your other idea…I’m brand new to Linux. Thanks.

Perhaps, look at settings > library > clean up library, you may have hundreds of orphans to clean out. And maybe, unwatch, remove, and then re-add your storage folder.

Hi @David_Zigas,

Can you please post a screenshot of your Roon Settings -> Storage tab? It should look something like this:

Also, I would not follow @mikeb’s advise if you have made edits to your library as it can cause issues with tracking edits (see this thread)


I stand corrected, good point about any edits.

Noris – Thanks, I will follow up tonight when I get home. – David

1 Like

MIke – No harm done… thanks for pitching in. – David

Noris – Here u go, thanks. – David

Looks like the one folder (Music2) is part of the folder structure of the other. This will cause trouble I’m sure. :face_with_raised_eyebrow:

Hi @David_Zigas,

@anon47919701 nailed it here, you have the Music folder listed twice. I find it a bit strange that the second one is the parent folder but it has less tracks than the subfolder though…

I would advise that you perform a backup of your database using these instructions and remove the subfolder (the first entry from that list) and perform a rescan on the second entry to get all the tracks back. Let us know if that helps!

– Noris

Noris – I changed the directory structure so that one folder wasn’t the “child” of the other, and that solved the problem… thanks to you and u_gee for your help. While I’m here, maybe you could ask Mike about the art display issue from last week… I sent some files up, and Mike said they could be seen at Roon, but haven’t heard a fix for my end. Thanks. – David

Hello @David_Zigas,

Glad to hear that changing the directory structure and removing the file has resolved the issue! I’m going to ping Mike to follow up with the other thread and I’m going to go ahead and mark this one as [Solved]


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.