Roon gets permanently stuck at launch screen on Windows 10

Core Machine (Windows 10/64 bits/Roon 1.8)

I have a Dell Inspiron 13–5378 laptop running Windows 10 (Intel Core i5-7200U CPU @ 2.50GHz, 8.00 GB RAM), and I use this laptop as core and audio player device.

Since 2 days ago, every time I click to launch Roon, it gets permanently stuck on the launch (loading) icon screen, so I’m not being able to use Roon at all. If I open the iOS app, I get the same “loading icon” screen without really launching the app.

I tried uninstalling Roon and reinstalling, but I still get the same problem. Please help me fix this. I can’t use Roon at all.

Network Details (WiFi)

Audio Devices (Audioquest Dragonfly Cobalt, USB)

Have you tried updating the graphics drivers at the Dell site, not windows update.

Thanks for the suggestion. I just tried that. First, through Dell’s pre-installed Software Update app, and then at the Dell site. I installed the most recent graphics drivers and the problem was still there. Then I installed the second most recent drivers on the Dell site, and nothing yet. I also tried other updates suggested on the Dell site, but I still get the same: an eternal Roon launch screen with the animated Roon logo.

There was indeed a recent Windows update a few days ago that might be related with the appearance of this problem, but updating or changing Graphics drivers doesn’t seem to fix it.

The other thing to try to see if it is graphics related is to install the 32 bit version from the roon download site.

check “appliaction firewall” for roon/raat and enable private and/or public network. I did that twice :slight_smile:

I’ve had this same trouble since last week. NO RESPONSE at all from anyone. It was not the firewall, at least for me, as that was the first thing I checked and it was all OK. It appears that the remotes cannot talk to the core (though they do see that Core exists) which suggests some sort of server (core) side issue and/or a library problem. If I get any response at all from Roon Support (I use this term loosely) I will add a note here for you to try as well if you like.

I managed to get back up and running from the Spinning Roon Icon at Launch screen by reinstalling Roon and restoring a backup of the database. For me, at least, it appears to have been a somehow corrupted database. Whether or not that would work for you I, of course, cannot say. I never did hear from Roon support (in over 6 days.)

Hey @Alejandro_Arrangoiz,

Thanks for bringing this up - we’d love to help. Before we even stepped in, it looks like our subscribers have already made some very good suggestions (thanks for already trying some of them). The ones that are left are:

Thanks in advance :slightly_smiling_face:

@Christian_Schock thanks for joining in on this conversation. I’m very sorry for the way things turned out with your request. Just now, I have made a post on the thread you created. I’m hoping we’ll do a lot better next time!

I am having the exact same problem and was going to start a new thread. Since someone has already started a thread, I am going to just pile on.

I have a DELL Windows 10. This has just started today when I reacted to the prompt to update roon to the latest version. Since then, Roon stucks in the startup with a blank screen (Windows say roon not responding). I have restarted the PC and roon several times and the result is the same.

One additional piece of information is that from my remote (ipad), It sees Roon without any problems and is able to play to the PC’s system output. So, there doesn’t seem to be a problem with the database.

Can someone from Roon jump in quickly to help us with this? Thanks!


Thanks Rebeka. Firewall settings enabled any network for roon/rat, so that was not it.

I tried installing the 32 bit version and the problem was still there. However, I then uninstalled Roon again (to reinstall the 64 bit version), but this time I unistalled also the databases and settings, and now Roon is back to normal. So far it is running without a problem, although I had to set it up again from scratch.

The question now is whether this is going to keep happening from time to time, perhaps due to corrupted databases, requiring annoying uninstall/reinstall measures every now and then, as some users pointed out in another discussion.

I assume you reboot after driver install

Hi @Alejandro_Arrangoiz,

Thanks for spending some time to try all these solutions and in combination too! I’m very happy to hear that removing the Roon database as well helped. Great insight - thanks! While we are hoping this won’t be a recurring issue for you, please do let us know it it returns.

@Raymond_Lee, thanks for joining in. Sorry about the trouble! Did you get any chance to try any of the three solutions suggested on this thread?

Uninstalling everything, reinstall and restoring from backup worked. Thanks to everyone here!


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.