Roon hang on Windows 10

Thank you for the notice on Build 528. it did solve the text problem on my older ATI graphics machine running Windows 10. It did NOT solve the application hang on my other Windows 10 machine so we still have to work on that.

This happened to me as well and I have a ticket open. Roon 521 would just freeze on launch. The graphics chip is an Nvidia 320m for whatever it’s worth.

Hi @Sevenfeet,

I have split your posts into a separate thread so that take a closer look at your Windows 10 issue, can you please provide some more information regarding this behavior?

Have you made sure to update your intel drivers?

Hi Noris,

Sorry for the radio silence on this. I finally have some time and I went ahead and deployed the 536 release that just dropped today. I did a manual install of 536 on the troubled Windows environment to no avail.

One thing I’ve noticed with this is that in the list of things that do happen before the application freezes are this:

Launch main window
Main text and layout
If it’s a new release that requires Tidal to be re-linked, I see that pink dialog box
Frames for album art graphics
Attention circles for application features (I did a fresh install so you would see them)

And then the application freezes before you see the album artwork (but you do see the gray picture frames for them). The application bar says “Roon (application not responding)”

I’m running Windows 10 with current patches as of a couple of days ago. Hardware is a 2010 Mac Mini (4GB of RAM, 320 GB HD split between partitions) running Boot Camp that had been running Roon reliably up until a couple of Roon releases ago. The main reason I am like running this in Windows mode is to handle DSD to my Oppo 205 in my home theater which this machine serves. Roon on MacOS runs just fine.

I used to have the ATI text problem on this machine but no longer…of course, I can’t do anything now!

Hi @Sevenfeet

Could you please record a short video of this behavior? You can use Windows built-in Game Bar feature or another preferred video-recording application to do this.

Here is the Dropbox link to the video I made of the symptoms. At the end, the screen turns opaque since I’m just clicking on a unresponsive interface before I kill the application. I’m also including the log file folder as well, in a zip archive.

Hi @Sevenfeet,

Thanks for sending the logs + video over. It looks like this is not the Core, but the Mac with Bootcamp is connecting to another Core, is that correct?

I would try performing a reinstall of the Roon app on device with the issues:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location on the affected PC
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App to generate a new Roon folder

Yes, the core is sitting on a Mac Pro running 10.13.6. You’re asking me to rebuild the Roon database on the core? Why would that work when every other Roon client in the house (five Macs including two other Macs running Windows 10 via Bootcamp) don’t have this problem?

Hi @Sevenfeet,

The logs you sent me suggest that the Windows partition is not acting as the Core, but rather as a Roon client that connects to the Core. My suggestion is to reinstall the Roon app that’s acting as the Client on the bootcamp partition.

Roon is installed in the same directory as a usual Core even if it’s only in client mode, so I suggest you open up Windows Explorer (the folder-looking app you usually use to navigate to C: or D:), type in %localappdata% into the header bar, locate the Roon folder and rename to Roon_old and reinstall the client app.

OK, I ripped out Roon client from the Windows 10 client machine including the Roon and RaatServer folders in %localapdata%. I uninstalled Roon and reinstalled the 537 build. The result was the same although I did see the first screens to accept the app and connect to the Roon Core. Then we saw the pink Tidal connection issue, and finally the lockup. I’ve included a new video. Everything this time is labeled 537. And I also included the RoonServer logs this time, as well as the client logs.

Hi @Sevenfeet,

Thanks for giving the reinstall a try. I’m not seeing anything jump out to me in the logs, so it looks like this is one for QA review. I have created a ticket for you for QA review and once it reached the queue, I will let you know what QA suggests. Thanks for your patience while this reaches the top of their queue!

Thank you. Let me know if there is any more I can contribute on my end.

1 Like

Hi @Sevenfeet,

I spoke to QA regarding your case and there doesn’t look to be much information in the Roon logs. Could you please try accessing your Windows Event Viewer logs and send me an archive of this?

  1. Press Win + R and type eventvwr.msc
  2. Press OK – this should open Event Viewer window
  3. From the left sidebar go to Windows Logs > Application
  4. Right click on the Application subsection and pick Filter Current Log... from the context menu
  5. On the Filter tab for the Logged section pick a parameter Last 30 days and press OK
  6. Right click on the Application subsection again and pick Save filtered log file as.. from the context menu
  7. Enter the log file name, for e.g. Roon_USERNAME , and press Save
  8. Upload this file to Dropbox and post a link

OK, the event log file is named “ROON_SEVENFEET.evtx”. I ran Roon twice before generated the log, one at 9:11 AM and the other at 9:20 AM today. Both events should be front and center. I checked the security and maintenance control panel as Windows suggested. No events there.

Hi @Sevenfeet,

Thanks for sending those logs over. I am looking through the Application Hang report and it looks like there are a few files which might provide some more details, can you please see if you are able to locate these on your PC and send them over?

C:\Users\Rick Ewing\AppData\Local\Temp\WER540E.tmp.appcompat.txt

C:\Users\Rick Ewing\AppData\Local\Temp\WER7AEF.tmp.appcompat.txt

I also have a few other ideas other than just these files:

  1. Have you confirmed that you have the latest version of .NET framework installed?

  2. Reading other forums seems to indicate that the 101 application hang might be related to a corrupted Windows profile. If you try to create a new user profile in Windows, does that stop the hangs?


None of the files you asked for exist on the system in question. In fact, the C:\ProgramData\Microsoft\Windows\WER\Temp folder is completely empty. I compared it to another ancient Mac (2008 iMac) I use as a Roon kiosk (also running Windows 10). I couldn’t find any of those files on that machine either and that machine runs Roon without problems.

As to your other questions, I am running the latest version of .NET. The installer that you pointed to in the link said so and I regularly take the latest Windows 10 updates for these machines (they should be fully patched right now).

I did try creating a new user on the affected system to see if something was corrupt with the main user. I had to reinstall Roon since the installation seems to be user specific and not applicable to all users. Roon froze on that user as well, in the same spot while trying to display album artwork.

Hi @Sevenfeet,

Thanks for checking the .NET version and the new user. I spoke with the QA team today regarding your case, and they believe that this issue could very likely be due to this PC not meeting our Minimum Requirements.

Unfortunately, not much more can be done here to use the Roon interface. However, if you just wish to use this PC for the devices connected to it, you can opt to use RoonBridge instead, and that should allow access to your connected devices from the Core and other Roon remotes.


This is a lousy suggestion. First, the minimum requirements page is a link to a support article that pretty much says that Roon will run on anything with a minimum of Open GL 3.0 and 4 gigs of RAM. Everything else is going to be a consideration on how much performance you want or lack of performance you are willing to tolerate. Sure, recommended requirements are an Intel i3, SSD and at least a 1440p display, but I have two other elderly Macs in my house older than this one running Roon client happily. Why did I choose them? Because they were available (no cost to me) and could be coaxed to either run Windows 10 or Catalina. Their role is pretty simple…a music kiosk. It doesn’t take a lot of horsepower to do that.

The Roon client doesn’t require the horsepower of my Mac Pro server to handle my library and even that machine is more than a decade old (but still with 8 Xeon cores and 16 GB of RAM). Would all of them run better on modern hardware? Sure! My main server is long due for an upgrade but I put that off with the impending recession. But they still all should run given their resources and up until recently, all of them have. And of course, this machine still runs Roon happily on Mac OS. I’d do that except for the restrictions of DSD music on than OS.

I was going to try to install an older copy of Roon from last year to see if I can at least get past the problem I’ve been seeing. That would likely eliminate Windows 10 as a possibility. I had intended on rebuilding the machine anyway since I wanted to replace the old HDD with an SSD and it should arrive this weekend. But I would really appreciate it if you guys wouldn’t abandon the ticket and just recommend running the Roon Bridge. Yes I could do that, but part of the point of running the Roon client on this machine is that it’s hooked up to the 65" TV in my home theater. So anyone walking into the room would see what was being listened to, including lyrics or anything else.

Can you try with another default browser for your Windows 10 installation on MacOS or have already tried that?

Thanks for the tip. Edge was the default browser, but changing to Chrome (which was also on the machine) had no effect to Roon freezing when trying to display album artwork. I tried to install an old version of Roon but forgot that Roon is setup in my network to force upgrades so I ended up back on the latest version, which ended up freezing again.

So I’m back to where I began. RoonBridge does work since it doesn’t rely on an interface. But the interface was kinda the point, especially on this machine in my house.