Roon hanging at startup screen Mac Mini M1

Roon Core Machine

Mac Mini M1 - latest Big Sure

Networking Gear & Setup Details

Connected Audio Devices

Stream to Matrix Mini i-pro 3 (worked fantastic for months, still works fine over Airplay).

Number of Tracks in Library

Description of Issue

Since Sunday my Roon is not starting anymore. it hangs at the start up screen.
Beforehand, starting last Thursday it started to work strangely until Sunday it stopped completely.
I tried to reinstall and restart everything.

Hey @Jean_Pierre_Lang,

We’re so sorry to hear! Thanks for letting us know right away of the behavior you’re experiencing… :sweat:

I was wondering if, since this happened, you had a chance to reboot your Roon Core (Mac Mini)? By this, I mean quitting Roon, shutting down the Mac Mini, unplugging it for a few minutes and then plugging it back in, turning it on and launching Roon.

Does it help?

Sure I did that.
I as well updated.
nothing helps. that why I open a ticket.

its no days. do have any advice?

Hey @Jean_Pierre_Lang,

Thanks a lot for your quick reply and for your efforts to resolve this. I believe the steps below should help. Could you please:

  • Stop RoonServer
  • Navigate to your RoonServer’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Reinstall the RoonServer App from our Downloads Page to generate a new RoonServer folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database
  • Restore a backup

Thanks a million :pray:

Hey Rebekka
I found that library, but I have no Roon server folder?

Screenshot 2021-09-14 at 07.24.13

Hey Rebekka
I figured it out. you need to adapt the guide on your help page.
in Mac big sure - this folder is not called, roon server or has in the roon folder in the library anything like server.
it’s simply called “roon”.

I simple took that roon folder in library and renamed in to “roon_old”, I installed the app over application (moved it to bin), did a new install.

with the new install I have installed a new core, and all my library was back automatically with the new install.

I found the guides very confusing. its as simple as I describe above.