Roon hangs after logging in on OS X Yosemite [Solved]

I just had to re-install Roon and rename my Roon folders as one had apparently become corrupt. That fixed the hanging at start up but now Roon hangs at log in.

I have confirmed I have network connectivity. I enter username and password (which I’ve independently verified as correct) and the system hangs.

Running MacBook Pro late 2011 with OSX Yosemite 10.10


If you’ve a backup of your database restore it, otherwise delete it (or move the folders elsewhere) to see what a fresh install does.

I have deleted folders and was able to get Roon running. Then I was prompted to update to Build 88 which I did. Now back to square One with Roon hanging at launch. I have about 4 hours into fooling around with this and am about ready to give up.

I think I need some interactive Roon tech support

Hi Frank,

Let’s drop a flag for @mike and @vova to provide that support !

Hey @spencer43023 – can you confirm you’re deleting (or renaming) the Roon database folder, as described here, followed by a reinstall from the website?

I would be extremely surprised if a fresh database was having issues after 4 hours, but let me know a little more about the steps here, and we’ll figure this out. Thanks!

Still stuck.

Thanks for the help Mike. Yes, I have done what you’ve suggested. Both deleted the database file as well as the entire “Roon” file. Reinstalled from the website (unpacked the same .dmg file a few times).

I accept terms, am asked if I’m using the Mac to manage the library, get to the screen to log in to Roon and that’s where the system freezes.

I still have two old Roon folders renamed roon_old and roon_2 or something but doubt that could be the problem.


Thanks Frank – I just sent you some information about how to get your logs via PM. Take a look and we’ll figure this out.

Uploaded the file with a note – do not see that in my sent file – did you get it?

Other details:

Roon 1.1 Build 88
MacBook Pro late 2011
OSX 10.10
External HD for music storage

Yes, we’ll be looking at it in the next 24 hours and we’ll follow up with you about next steps. Thanks for your patience @spencer43023.

I’d be curious about a solution for this as well. Happened to me today. I backed up my OSX Yosemite drive where I have been using Roon. I then copied the Roon directories and databases to another drive that is running ElCapitan. Roon just hangs on the login screen.

When I renamed the copied Roon directory to Roon-old, I was able to restart Roon just fine, but without any of my data from the Yosemite drive.

1 Like

Can you let me know how you were backing up?

Can you let me know how you were backing up?

I cloned my drive using Carbon Copy Cloner. I was then able to copy the Roon directory over from the backup to the new drive.

Hello @tubeman, apologize for troubles, but i think your problem is slightly different, would you mind to share your Roon logs with us, so we can re-confirm this. I’ll PM you shortly with detailed instructions.


Just a quick follow up about @spencer43023’s problem. It turns out that machine could not successfully visit any HTTPS site using Safari or curl. It would just hang after the connection was made.

There were many ideas about how to fix this on the Apple support forums, but nothing we tried worked (wipe keychain, delete expired certs, cache cleanings, checking proxies, firewalls, etc…).

Safari/curl/Roon worked fine with normal http.

Chrome worked fine with https, but they use their own HTTPS stack and do not use the system stack. This led us to believe that this OS X Yosemite install was corrupted in a manner that made HTTPS connections hang.

Yosemite is known to have HTTPS issues as well, so those could be avoided by the upgrade. A upgrade to El Capitan was suggested, and if possible, a clean reinstall of El Capitan. This would avoid any cruft being carried over.

@tubeman, if you think you are having this exact same issue, you might want to consider trying to visit in Safari. If it works, you are not having the same issue. If it doesn’t, you might have the same issue as was originally posted in this thread, and your operating system is corrupted. An upgrade/reinstall may be your easiest solution.

@danny Post script:

I had a new OS installed at the Apple Store (could not download anything from the App Store as the same problem that prevented me from connecting through Safari was present when trying to access he App Store).

Problem solved! Roon runs just fine now.

I’d like to commend the Roon software team with their help, patience, and responsiveness in resolving an issue for which they had no responsibility. I’m sure they have three hours of support time into helping me get my machine running.

Thank you.