Roon hangs after playing music for 1-2 days on InnuOS Zen Mk3

@support @dylan
And now it’s crashed again. Been playing for maybe 3 hours.
Same thing, hung, can’t do anything, the “time bar” just goes back and forth.
I need this fixed please, it’s very annyoing.

Hi @Andreas_Lindmark,

Thanks, now that I have the timestamp I’ve enabled diagnostics on your account. The diagnostics report will be uploaded the next time your Core is active. Once that’s been received I’ll pass it over to the technical team for analysis.

You mentioned previously that the same behavior occurred when using a PC as your Core. Can you give some details on that machine?

Also can you confirm how many tracks total are in your library?

Is the Zen connected to the primary router or one of the APs?

Hi @dylan

Sure, it’s a Win10 x64 machine with 32GB RAM, Intel Core i7 7700k.

Then Zen is connected via the router (switch in between).

The library in the Zen (Roon core) is 6394 tracks imported.


Thanks, @Andreas_Lindmark.

I can confirm that the diagnostics report has reached our servers and the they’re with the team for analysis.

When you moved from the PC to the Zen, did you restore a backup and migrate over or did you start fresh?

I started fresh :slight_smile:

Hi @Andreas_Lindmark,

I just spoke with their team about their analysis of the logs and wanted to follow up with their feedback. They’re still looking into things here and are hoping to get a bit more information.

You mentioned that this same exact behavior also occurred on Windows before using the Zen. Do you still have this Windows device? Could you temporarily switch back to the Windows Core and reproduce the same behavior and provide a timestamp for when this occurs?

Since this is occurring on two different databases on two different Cores it would be good to compare diagnostics reports from both. We have a bit more insight into the Windows OS than the Innuos OS, so diagnostics from the Windows device would be a great data point for our team.

Yeah I can install the core on that one again, sure. I’ll get back to you.

Edit: I’m now back on the windows core

1 Like

Starting to wonder if this is because of the database backups?
I’l set a time during the day and try to monitor the behaviour.

1 Like

Not managed to crash Roon as if yet.
Running Core on my win10 pc and the InnuOS as a player only.
Will keep trying to get it to crash.
Edit: It’s been stable when using the Win10 machine as Core, however, that’s now how I want it :wink:
I enabled the Core on the InnuOS again now to see if it hangs.

1 Like

Now running at the InnuOS again, turned off DSP just in case. Changed backups to every 14th day, just in case. I’ll report back in a few days, or earlier if it hangs.

1 Like

@dylan @support
Did the team find anything in the logs?
InnuOS just sent out a software update so that I can easily download the logs from the Zen if that helps?
It’s been stable now!
Not sure why, I only updated the InnuOS today so it’s not that.

Hi @Andreas_Lindmark,

Glad to hear that things have been remaining stable for you. If you do see this issue return please let us know and we’d be happy to continue investigating this.

It’s started again. Last two days it’s hung twice. Once after like a few hours, and now after sitting paused over the night.

Hi @Andreas_Lindmark,

It sounds like things were stable for quite a while here — Was there any change in your setup in the last couple days, or anything specific that you were doing that you hadn’t done previously? Does a reboot of the Zen restore things to normal?

The only thing we’ve done is too move around furniture, so everything turned off for a while. That’s it.
If I disable/enable Roon, it’s fine.

Thanks, @Andreas_Lindmark — We’d like to take another look at what’s occurring here so we can confirm whether or not we see any changes in the diagnostics report. The next time this occurs please provide a timestamp and we’ll enable diagnostics and take a look.

Hung again, between 6.45 and 7.15 somewhere.
Tried to find a way to upload the logs but can only upload images?

Here are the logs:

The backup ran last night. I still think it’s related to the backups.
I’m turning that off now.

Hi @Andreas_Lindmark,

Definitely let us know if this is resolved without the backups. Can you verify where you are backing Roon up to?

Yeah, it’s to my NAS on the LAN.
I set it to only backup every 14th day a while after I ran into this issue.