Roon hangs at launch [resolved: reinstalling fixed it]

Core Machine (Operating system/System info/Roon build number)
Windows 10 Pro 64bit / Intel Core i7-6950x CPU @ 3Ghz (10 core), 64 GB RAM
Roon 1.8, Build 790
Library, stored on SSD.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
NBN connection box CM9200B/ Sagemcom F@ ST 3864V3 HP Modem/Ethernet.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Hi there,

Roon will not load up. I get the initial animated roon logo and it hangs there indefinitely. Please help.



To be clear, this is the sixth time I’ve had to come onto this forum due to Roon creating some kind of major instability on my system. I don’t have problems with ANY of my other media playing software. If I hadn’t bought a lifetime subscription, I would have abandoned this platform a long time ago: it’s wasted so much of my time. Please do better by your subscribers: Roon 1.8 is not stable for so many and this is not good enough for someone who forked out significant cash to be a subscriber.

Have you tried installing the native GUI driver for your video card, there was a Windows update last week , it often overwrites drivers,

Change to manufacturer driver an reboot everything . Start at the router and move forward allowing each link to stabilise before moving on

Worth a try …

1 Like

Thanks, @Mike_O_Neill - nope: didn’t help.

Just a quick fyi: I’ve been able to get Roon to occasionally open (maybe 1/10 times) and it comes up with ‘no audio devices found’. Again, my audio device is stable in windows and works on any other audio playing software on my computer.

Just a question, does the problem only occur in Windows, or do you also have Linux in use?

With Windows I would also look for the latest drivers from the manufacturer. With Linux there are still these hints:

and known problems with hybrid graphics (2 graphics cards in the system) can be found in large quantity on the Internet.

The latest and greatest hardware with old drivers and software is a common problem, which Microsoft also does not have under control with their updates. Manual reworking is required here.

Roon 1.8 (Build 816) ist live! (for Android only)
Roon 1.8 (Build 814) ist live! → new Version
Roon 1.8 (Build 806) ist live!
Roon 1.8 (Build 795) ist live!
Roon 1.8 (Build 790) ist live! → old Version!

The best product from RME so far. RME’s HDSPe MADI FX PCIe card is one of the best multi-channel audio interfaces on the market.

With 390 audio channels distributed over two optical inputs and one coaxial MADI I/O, the HDSPe also offers support for up to four MIDI channels.

Brand RME Type Internal Sound output Stereo Maximum sampling rate 192 kHz Function MIDI, Audio Interface

Were there drivers to this card, perhaps Microsoft also shot them up during the last update so that only trivial audio programs run.

Translated with (free version)

Sorry, @Uwe_Albrecht - I don’t speak German.

Apologies: I have build 814 - as I couldn’t initially access roon at all, I wasn’t sure.

Ok: rather than wait for some support, I decided to uninstall Roon (including all local data) and complete a fresh install. It worked: Roon loaded up normally and can see my audio device again. However, the program crashes after about 10 seconds of being open. I’ve tried restarting the computer a few times, and, the same thing happens: it crashes shortly after opening.

Are you sporting any AntiVir/AntiMalware applications?
Library size and any streaming services?

HI @Adam_Casey, sorry for the trouble here!

Please try each of these steps, and try to launch Roon after each.

  1. Reboot the Windows machine
  2. Disable the device’s firewall and any AV
    1. If this helps, please enter an exception in the firewall for Roon and RAATServer
  3. Download .NET Framework and reinstall it

Next Steps

If none of the above helps, please use these instructions to send us Roon logs from the device.

We’ll also want to take a look at Event Viewer logs, which give some insight into errors being reported by the OS — Please send those as well:

  1. Press Win + R and type eventvwr.msc
  2. Press OK – this should open Event Viewer window
  3. From the left sidebar go to Windows Logs > Application
  4. Right click on the Application subsection and pick Filter Current Log… from the context menu
  5. image
  6. On the Filter tab for the Logged section pick a parameter Last 30 days and press OK
  7. image
  8. Right click on the Application subsection again and pick Save filtered log file as… from the context menu
  9. Enter the log file name, for e.g. Roon_USERNAME , and press Save
1 Like

Thanks, @dylan

After freshly reinstalling everything and restoring my backup, I got the same ‘no audio devices’ issue. I did ANOTHER fresh install, and this time, restored from a backup in July, and, everything is back to normal again. It was really quite the ordeal! Took my whole day yesterday to deal with! Crazy!

I also tried reinstalling the .NET framework, as suggested, and, it wouldn’t allow it (said it was already installed: I couldn’t figure out how to uninstall it). Also, all Roon applications are already exceptions in my firewall.

Anyway, I’ve managed to fix this issue, so, you can mark it as solved now if you like.



2 posts were split to a new topic: Running ROCK on a NUC and suddenly none of my remotes can connect