Roon hangs on launch

Core Machine (Operating system/System info/Roon build number)

Sonic Transporter V. 2.7 / Roon Build 1.7 (build 610)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear Orbi Connected via ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

BluOS

Description Of Issue

On my Windows 10 desktop, Roon remote will not relaunch. I must delete the Roon Database folder to relaunch it after it is shutdown. I have isolated the problem to the one file which is created at when I select my core:

C:\Users\ME\AppData\Local\Roon\Database\Registry\Client\brokerchoice_lastchoice

which contains the following data:

bc276b39-66a6-43e8-ad60-f9cf8a126453

If I delete brokerchoice_lastchoice it starts up normally, and asks me to select the core. But if I close Roon Remote, it will not reopen until I delete that file again.

Interestingly, I used to have a core setup on a Synology server. I have removed that, and I have even tried disconnecting the server from the network, but it always comes up as a choice to connect to when Roon starts (after brokerchoice… is deleted). Since I have deleted all the files in the Roon Local folder and have uninstalled and reinstalled Roon several times since I removed that core, I suspect there is some file or registry entry that is not getting removed.

Anyway, any help would be greatly appreciated.

-Steve

Thanks for reaching out on this, @Steven_Kramer, and apologies for the delay. I just wanted to let you know that I have a meeting scheduled with our QA team to discuss your report shortly and I will follow up as soon as I have their feedback.

Thanks!

Hello @Steven_Kramer,

Apologies for the delay in getting back to you here and thank you for your patience while we have had a chance to discuss your case with our QA team. We would like to look into this further, and we kindly request the following information:

  1. Can you please open Windows Start menu and type in “System Information”. Then, share a screenshot of System Summary and Components -> Display?

  2. On the Windows PC, can you please reproduce the issue, then open Windows Explorer (the app you use to navigate C: drive) and type in %localappdata%/Roon/Logs in the header. Please send a .zip archive of the logs you have there (only after reproducing issue).

Any questions, just let me know, thanks!

Noris,

Tried to respond directly to your email, but it bounced with the following message:

We’re writing to let you know that the group you tried to contact (community) may not exist, or you may not have permission to post messages to the group. A few more details on why you weren’t able to post:

  • You might have spelled or formatted the group name incorrectly.

  • The owner of the group may have removed this group.

  • You may need to join the group before receiving permission to post.

  • This group may not be open to posting

I tried to do through the community site, but this form does not accept zip files, only jpegs and other graphic files. How do I get you the information you want?

-Steve

FWIW, you need to communicate with Roon support via this forum.

To get the attention of noris or anyone in support, preface ‘noris’ or ‘support’ with an @ when posting in this thread.

Thanks, Slim. I tried, but this form will not allow me to attach the logs.zip that was requested.

-Steve

Try the info here -

You have to drill down a bit, but eventually there is info on how to send via Dropbox or Google, etc.

@support?

Thanks, Slim. Noris, the info you asked for is below. Thanks.

My log files can be found here:

And the screenshot is below:

1 Like

Hi @Steven_Kramer,

Thanks for sending those logs over, I have forwarded them to our QA team for closer inspection!
Once I have the completed report from QA, I will reach out again, thanks in advance for your patience.

Hi @Steven_Kramer,

Thanks for your patience here while I had a chance to discuss your case further with our QA team.

It appears that Roon is crashing for you on the home screen, so what you are doing here is avoiding the crash, but not addressing the root cause.

As for next steps, can please ask you to send me a set of your Windows Event Viewer logs for QA review? Instructions on how to send below:

  1. Press Win + R and type eventvwr.msc
  2. Press OK – this should open Event Viewer window
  3. From the left sidebar go to Windows Logs > Application
  4. Right click on the Application subsection and pick Filter Current Log... from the context menu
  5. On the Filter tab for the Logged section pick a parameter Last 30 days and press OK
  6. Right click on the Application subsection again and pick Save filtered log file as.. from the context menu
  7. Enter the log file name, for e.g. Roon_USERNAME , and press Save
  8. Upload the Event Viewer logs to Dropbox / Google Drive and post a link on thread or send via private message

Thanks again for the help. Here us the event file you requsted:

1 Like

Thanks @Steven_Kramer, let me get this over to the team for closer review!

Hi @Steven_Kramer,

Thanks again for the logs and for your patience while your ticket has made it’s way through the queue.

We have reviewed the event viewer logs, but unfortunately they were inconclusive, is this same behavior still occurring even on the latest Roon build?

If so, can you please let me know the following?

  1. Does this issue impact any other remotes except for the Windows 10 one?

  2. What happens if you try to temporarily host the Core on the Windows 10 machine? You can use these instructions to do so:

  • Create a Backup of your Roon database
  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Noris, sorry I have not got back to this for a while - I’ve been busy with other things and just kludged the whole thing with a little script that deletes the offending file before starting Roon.

Anyway, I have a new clue. I have always run Roon on my secondary monitor. I discovered that if I let Roon start in my primary monitor, it starts just fine. But if I close it in my secondary monitor, it try to start in the screen it was on and it hangs. At first I thought it might be Display Fusion which I have always used to manage my monitor screens. But I turned Display Fusion off and the same thing happens with the default Windows monitor. So, it seems to get hung up when the program is starting and being moved to a new monitor at the same time. I hope that is helpful

-Steve

For what it is worth, I just reinstalled Windows and this problem seems to have gone away. I guess there was some gremlin in my system that was causing issues. Thanks again for the help.

-Steve

1 Like

Hi @Steven_Kramer,

Thanks for letting us know that the Windows reinstall resolved the issue here, that’s fantastic news!
If you have any further difficulties with Roon, please don’t hesitate to let us know!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.