Roon hangs when starting on MacOS - out of the blue / nothing changed (I think)

I can’t get the Roon app on MacOS to launch any longer. It happened the first time yesterday, and persisted, so I removed the Roon app and downloaded the current version from the Roon site. Installed this but no change. Today it mentioned an update when it started (although it still hung) which it turns out was for ROCK. Did that, still hangs. Reinstalled the Mac app again from another fresh download, still hangs.

MacBook Pro - current model Intel processor on Big Sur 11.4, I haven’t ran any OS updates for a little while and nothing else changed as far as I can tell
ROCK is Build 814, just updated
I have no problems on my current iPhone (Build 806) and iPad versions of Roon, just the MacBook

Any help much appreciated, as I use it a lot on the Mac!

Pic attached.


I would go to the web GUI for rock http://rock.local unless you changed the core name and restart the the roon server or optionally reboot the ROCK completely

Grab 2021-07-30 at  12.52.19

Thanks… rebooted it completed… no change on MacOS. Hangs on launch.

(Still working fine on iOS)

Anything else I can try?

Anybody from Roon?!

A post was split to a new topic: macOS loading animation forever

Hi @s-t-e-v-o

Can you please use the directions found here and send us over a set of logs from the Mac using a shared Dropbox link (or any other file sharing service)? Thanks!

Many thanks, Dylan.

I’ve sent you a message with the link to my log files.



Hi @s-t-e-v-o ,

I had the same problem but fixed it by using AppCleaner to uninstall Roon. I originally tried using the Uninstall Apps tool that comes with Parallels but with no joy. On a hunch I tried AppCleaner and noticed that it deleted ~/Library/Roon, which the Parallels tool didn’t. When I reinstalled Roon I selected my Core and was up and running.