Roon has dissapeared from Mac

Roon Core Machine

Big Sur 11.6.1
3.4 GHz Quad-Core Intel Core i5
8GB Ram

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Roon has dissapearded from mac computer. Left with name and arrow but nothing launches. Never had this with any other app ever. Spent many hours yesterday setting DSP which is the only reason i am trying it out. No back up.

Odd. This is in your /applications folder?
You could just try reinstalling roon…

Did it disappear during use? Or did you switch off the Mac?

I have been in the habit of quitting the application at the end of the day. Last night I shut the machine down in the proper way. I have found that on reopening the application on previous occasions sometimes it worked simply and other times I went via that launching arrow thing.

I guess I can reinstall the application but will all my data and settings be there? I have not backed up because I do not understand what it is I am expected to back up and since most things are reliable I do not routinely back them up

The setting will most likely be gone.

As the same happened with the REW Installer – could it be that you have created an alias from the install DMG when dragging the app to the Applications folder, instead of copying the app itself?

As for Roon – settings are saved in the Library folder on your Mac. I’m pretty sure they will be there once you have replaced the app.

Quite possibly I created an alias.
It’s not really clear to me how you should install new programs. As I understand it normally you drag an icon into the apps folder which is what I would have done I should think. Maybe you could explain if I should do something different. But it’s odd because it has worked for some time

Have rebooted the machine and the program has now launched from the bar at the bottom of the screen icon which previously displayed a? When I hit it. My data seems to be there including the DSP. However on other occasions I have found it difficult to launch so is there something I am doing wrong or should check to ensure the program is correctly installed. I will do a backup but would like to know what I am backing up and where to. Thanks for your help.

I stil think you are launching an alias (that auto mounts the disk image your downloaded and launches Roon from there).

Can you supply a new screenshot of your Applications folder in its current state?

Another thought: did you drag the Roon app directly from the disk image to the Dock (the ‘strip at the bottom of your screen’) instead of copying it to the Applications folder first?

If so: close the app and remove the icon from your dock. Then, open the disk image by double clicking it. After that, drag the Roon app into the Applications folder of your Mac. Eject the disk image (from a Finder window or by right-clicking the its icon on your desktop). Finally, drag the Roon app from your Applications folder into your Dock.

As you can see there are a number of other aliases so maybe I am in the habit of doing something wrong.

There is now a silver Roon icon on the desktop that looks a bit like a portable hard drive but that had disappeared. I am pretty sure I dragged the icon into the apps folder initially since that is what I understand I am supposed to do.

Since I am using my general computer rather than a dedicated thing to run Roon Core, I tend to shut the app down when I am not using it but surely this should not present a problem?

Also when the room application is running I can see this in Finder which is what I normally see when I plug in an external drive for instance so what is this indicating?
Screenshot 2022-01-07 at 17.13.42

Hey @John_Carlyle

This explains it all pretty well:

Thank you that is helpful. Be nice if those distributing apps this way explained what to do.

Roon is now installed and I have deleted the icon from my desktop.

Can I now delete the Roon folder with an arrow on in apps
Screenshot 2022-01-07 at 17.53.21
by dragging it to the trash.

Yes, please do – it’s an alias as well.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.