"Roon has stopped working" driving me crazy

Core Machine

Windows surface pro 4, Win 10, i7-6650U @2.2 GHZ, 8GB RAM, 64 bit
(have also tried on surface pro 5 and dell laptop with better specs and the issue continues)

Network Details
Core machine on wi-fi, directly connected to QNAP RAID array via USB

Audio Devices
Schitt modi multibit via USB


Library Size
Extremely large (>50K albums) but can’t tell you precisely as roon crashes constantly

Description of Issue
Up until a couple of days ago everything has been perfect with Roon for the 18 months that I’ve had a license. Now, no matter what I try, whenever I open roon it a) takes >3 minutes to start up (checking the libraries I guess) and b) as soon as you get to the main screen, windows flashes up an error message with no information other than “Roon has stopped working”. This error replicates over 20 times in the last few days. I have 1) checked the graphics drivers using the intel tool you have recommended; 2) ensured that all windows updates have been applied; 3) uninstalled and reinstalled Roon on this core; 4) tried the same thing on entirely different computers; 5) checked that the QNAP raid array is healthy and replaced a noisy but healthy drive.

The only thing that has worked has been to remove the RAID array and just use tidal, but that kinda undermines the whole point of roon. I have spent a LOT of time trying to get things running again, and it is driving me crazy. I’d appreciate any suggestions. Next thing I’m going to try is to just try with a smaller library but this likely isn’t going to work either as the same error appears when I’m trying to build the library fresh. AAAAAAAARRRRRRRGGGGGGGGHHHHHHHHH

Fair enough but there’s got to be something else going on as the same error occurs with multiple machines (the laptop, for example, has double the ram) and the fact that the same system has been working AOK for 18 months!

I’d strongly suggest to test with a wired connection, as that’s known to ask for trouble, no matter how stable it used to be before.
Other than that I wish you good luck in getting things ironed out…

thanks for the suggestions!
I’ve now tried it using a wired connection and a new install on a laptop with twice the ram (with latest drivers and latest roon etc) and keep getting the ‘roon has stopped working’ issue. So it’s neither of those!

Sounds like a library corruption if it runs without and crashes when trying to build.
Have you done a roon restore each time you do a rebuild?

yup! I am beginning to suspect that there may be something that is going wrong with the RAID array. I have rebuilt the library pointing roon to the files on my nas (I had a copy on the external RAID array that was a backup of these files) and it seems to be not crashing, although I’ve now got issues with the cover art (but that I can cope with).

Apologies for the delay, @Raimondo_Bruno! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

Are you still seeing issues here? If so, please use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service).


This topic was automatically closed after 19 hours. New replies are no longer allowed.