Roon Hifiberry Player Volume turns up on its own

Core Machine (Operating system/System info/Roon build number)

Linux roonserver 5.4.65-1-pve #1 SMP PVE 5.4.65-1 (Mon, 21 Sep 2020 15:40:22 +0200) x86_64 GNU/Linux
Roon 1.7 (Build 667)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Subnet on pfSense Router. Proxmox Server connected via 10 GBe Glasfibre. LXC Container on Linux Bridge VLAN 50.
Roon Ready Hifiberry OS Players are connected via AC Wifi. Wifi AP is from Ubiquity with OpenWRT flashed.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Hifiberry OS with Hifiberry DAC+ on Raspberry Pi 4. Connected to Pioneer A-339 with analogue 3,5 Cinch.

Description Of Issue

The Volume turns up sporadically on its own. It only turns up by 2-3 percentage points but does so frequently. This is very annoying. It also happens when audio is activated on multiple devices and does so on both devices.

Log entry of volume turned up by its own.
10/26 12:51:44 Trace: [HiFiBerry DAC+ @] [raatclient] GOT [5] {“status”:“Success”,“action”:“Changed”,“controls”:{“volume”:{“step”:1.0,“info”:{“config”:{“optional”:“false”,“mode”:“db”,“db_step”:0.5,“db_min”:-100,“db_max”:10,“device”:“default”,“index”:0,“name”:“Softvol”,“type”:“alsa”}},“max”:100.0,“min”:0.0,“type”:“number”,“mute”:false,“value”:93}}}

Log entry when I corrected the volume:
10/26 12:51:53 Trace: [HiFiBerry DAC+ @] [raatclient] GOT [5] {“status”:“Success”,“action”:“Changed”,“controls”:{“volume”:{“step”:1.0,“info”:{“config”:{“optional”:“false”,“mode”:“db”,“db_step”:0.5,“db_min”:-100,“db_max”:10,“device”:“default”,“index”:0,“name”:“Softvol”,“type”:“alsa”}},“max”:100.0,“min”:0.0,“type”:“number”,“mute”:false,“value”:90}}}

Hello @Jan_Kuhnemund, and thanks for your report! I’d like to collect the full log file for this. Could you please reproduce the issue one more time and reply here with a timestamp (in your local time) when you do? From there, I’ll enable diagnostics for your account.

Sorry, I thought I needed to upload the logs so I waited until I noticed and and also had the time to save the logs. Oct 30th at 22:16 (GMT+1) the Volume in “Wohnzimmer” turned up on its own

It happened multiple times in the last few minutes. Oct 31st 19:25-19:35

Hello @Jan_Kuhnemund,

I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

Thanks. Does that mean I should reboot the Core?

Hello @Jan_Kuhnemund, I got the log files in and will send them over to the QA team now. So all good on our end!

Hi @Jan_Kuhnemund, We are looking into this and our team was hoping for a bit more context about this issue:

  • How often are you seeing this occur?
  • Have you seen this happen for a different endpoint?
  • When this occurs, is it while actively using the Roon UI, or can it happen even when you’re not actively using Roon and playback is just going in the background?

Hello @nuwriy
It happens almost every day.
If I recall correctly I’ve only seen it happen on the “Wohnzimmer” endpoint.
It also happens when only using roon in the background. I then have to actively use roon to correct it.

Hello @Jan_Kuhnemund, and thanks for the info! I have updated the team and will return with their feedback.

Hello @Jan_Kuhnemund, if I’m correct, so far we’ve noticed this when operating with an Android remote. Have you tried an iOS or Windows remote to see if this occurs?

This is not correct, I first noticed it when using my iPad as a remote (first remote I ever installed). However I never actually proactively shut down the android app. Does the android remote cause these issues?

Should I uninstall it to see if the issue persists?

Hello @Jan_Kuhnemund, and thanks for the clarification, I’ll update the team. It would be a good thing to check if you could make sure the android remotes aren’t connected at the time, thanks!

I’d also like to collect diagnostics from the iPad and compare the results, could you please let me know when you’re able to reproduce this with the iPad?

Hello @nuwriy, I tried since friday to replicate the results. However I’ve not been able to replicate them anymore, regardless of which combination of remotes used.
I’m not really sure what changed, but my problem has been solved. Should it reappear again, should I post it under this thread?

1 Like

Hello @Jan_Kuhnemund, yes if the issue returns please do return to this thread and we’ll take another look!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.