Roon + HQP error - "Transport: Roon has lost control of the audio device"


(tboooe) #1

I use Roon server and HQ Player on a Server R2 Essentials PC. Every once in a while I get the following error in Roon and the music either stops or cannot start:

Transport: Roon has lost control of the audio device.

I can resolve this issue 100% of the time by simply going into HQ Player and pressing any menu item like Settings. I dont actually have to make any changes to any settings. I just have to engage with HQ Player in some way.

Has anyone seen this issue?


(Jan Renes) #2

Same problem here, although on macmini mid 2011 16GB i5.
After some time idling or after restart from sleep state Roon loses control of the audio device.
Restarting the mac or just restarting HQPlayer does help. Mac is run headless with ROON server.
Although restarting is no big issue, it is a nuissance.


(John Culver) #3

I am having the same issue. Annoying.

I am new to HQP. Took me awhile to get it to work. Once I did, the SQ is truly fantastic. Giant improvement, like a new and improved dac in my system. The UI, however, is absolutely horrendous. But, you already knew that.


(Jan Renes) #4

I think it would be nice if there was a possibility from within ROON to restart HQPlayer.


(John Culver) #5

@support
That would be so awesome. Seems like the “integration” could be more integrated. It needs that function (restart HQP from Roon) and the ability to choose between more than one device from Roon (I will eventually be playing music from HQP to tow devices/players).


(John Culver) #6

So, I just got HQP to work on Sunday. I was amazed by the improvement in sq. Mostly made up for how long it took to ge it up and running.

Last night, when i turned my Sonicorbiter and dac back on, HQP would not connect. i got the “Roon has lost control…” message. I had assumed that to get it running, I just had to pull up the HQP settings screen and hit ok for NAA (set to default to SOSE and my dac). Mildly annoying, but ultimately not that big a deal. However, that is not working. I fiddled around with some settings, but still no connection.

Any ideas?


(tboooe) #7

I notice sometimes I have to restart the Naa as well. Then go into HQP settings and toggle the different options for playback device.


(John Culver) #8

I rebooted the SOSE. Then, went to setting and under device there is nothing. A blank. And, that is how it was even after I set it up originally and it worked. When I run search for NAA now, nothing comes up. That is also how things looked once I first connects my SOSE. I assumed that was because I had set it as a default.


(tboooe) #9

In HQP, in Tools menu, Network Naming is the IP address of the SOSE shown?

How is your SOSE connected to your network?


(John Culver) #10

So, on Sunday I set this thing up. Under network naming, my sose came up (or at least its ip did)and I selected it as my default. then, it showed my dac and I also set that up as the default. After I did that, under settings, NAA, device, no device was shown. I thought that was because I had set the default. I then set up hqp on Roon and it played. And, it actuallu sounded amazing which is the only reason I am willing to keep messing with this.

The next day, it would not play and after fiddling with hqp it still did not play.

The sose is connected by Ethernet to a Sonictransporter for HQP (i7 blah) that runs nothing but Roon and HQP.

Should I disable SOSE from Roon>

Any thoughts?


(tboooe) #11

I think this is the issue. So let me make sure I understand your setup.

Sonictransporter is running HQP and Roon
The SOSE is wired to the Sonictransporter via ethernet
How is the Sonictransporter connected to the rest of your network? Is there a second network port or are you using wireless?

I would definitely disable SOSE in Roon and only have HQP set as an output device.

For testing purposes, can you connect the SOSE to our home switch or router?


(John Culver) #12

The ST is connected by Ethernet to my internet router and Ethernet switch. Everyhting works fine when I am just using Roon.


(tboooe) #13

The normal configuration for HQP is to have the NAA (SOSE) connected to your switch/router. Many people including myself use a direct connection from the pc running HQP (and Roon) to the NAA device. People have reported an improvement or change in sound when bypassing the switch/router. That being said, doing this direct connection is a bit more fickle in some cases though for me it works fine. I use a small i3 pc as my NAA though.

Can you ping the IP address of the SOSE?

Can you please try to connect the SOSE to your switch/router to see if HQP sees it?


(John Culver) #14

I guess I have not been clear. My sose is connected by ethernet to my gigabit switch which is also connected to my ST by another Ethernet cable. .


(John Culver) #15

And, HQP originally saw the SOSE when I opened naming NAA. It found the ip, then found my dac. I selected the dac as my default. Then, under settings, it showed NAA but no device. I assumed that was because I had selected the NAA device already as the default. It then played successfully though Roon/HQP integration. It was only after I turned the stero off and then later tried to use HQp that I ran into problem. Still nothing under device, but now when I search for NAA nothing.


(Jussi Laako (Signalyst)) #16

Is the SOSE configured as NAA? It can be either Roon endpoint or NAA, but it cannot be both at the same time…


(John Culver) #17

Good question. I hit that road black initially and then remembered that it had to be set separately as NAA. Perhaps that is what happened after I turned off my dac for the night. I will see if reconfiguring as NAA will help. Thanks.

BTW, the sq from your product is amazing. I do wish it was a bit more user friendly, however.

Thanks again.


(John Culver) #18

OK, officially frustrated now. I disabled the SOSE from Roon. I restarted NAA on the SOSE. I reset the device on HQP to my dac. I have repeated those steps several times. I have rebooted the SOSE and dac several times. Nothing. I still get the “Roon has lost control…” message.

Help???


(John Culver) #19

I even just disabled HQP on Roon and then reenabled. I discovered that the DSP engine was enabled (not necessary when using HQP).and disabled that. Still nothing.

@jussi_laako


(tboooe) #20

John, any chance you can post a screenshot of your HQP settings page and the main screen with the 4 drop down menus?