Roon Icon for Ayre QX-5 Twenty

What is your current firmware number on your Ayre QX-5?

Here is mine, check picture.

Just got my QX-5 today brand new.

@eric thoughts?

To clarify for @Robert_Schaub @eric and @support I am having the same issues, icon wrong, and NOT Roon Certified

I’m sure mine is outdated although I don’t remember the exact number. I just literally found two thumb drives five minutes ago so will do the firmware update and reset my network this weekend, then report. Thanks.

Funny part is Ayre website shows H.03.05.07 as current version, and mine has H.03.05.10. So from number sequence I should be ahead?!

Seems so. I’ll likely do the firmware update and network reset later this afternoon.

What format are you using for your USB flash drive? I have a Mac and would normally pick FAT32 in this case, but that doesn’t appear to be an option (anymore) in the Disk Utility. I’m sure MS-DOS[FAT] won’t do it and ExFAT doesn’t appear to work in the Ayre. I doubt the Mac’s proprietary file formats will be readable either. Any suggestions? Thanks.

OK, I did some research and there appears to be a bug under macOS High Sierra that won’t let you read or properly erase any drive, including a USB thumb drive, using the FAT32 (now called “MS-DOS[FAT]”) format, which I’m almost 100% sure is what the Ayre wants to see. So I either have to wait for Apple to fix it or, maybe, buy a third-party disk utility for macOS, which I’m not inclined to do at the moment (and I’m certainly not going to buy a Windows machine just to format a thumb drive). I can forgive Ayre for adopting (presumably) FAT32 as a standard although I don’t see why they can’t offer complete firmware updates over the 'net just like Simaudio does instead of splitting it between a thumb drive AND a 'net-based update. However, I’m profoundly disappointed with Apple for letting a bug like this into High Sierra and, apparently, not yet fixing it even though they’re already up to the .4 release of High Sierra.

What does this have to do with Roon not displaying the correct QX-5 icon, and for being shown as Uncertified?

I highly doubt it

Hello @thyname,

We’re investigating some issues with identification on Roon Ready Ayre devices. In the interim, although your device is showing as “uncertified”, it shouldn’t have an effect on its playback capabilities or functionality.


Thanks so much for looking into this @john!

Please keep us updated with your findings and potential solutions.

And I agree, everything looks and sounds fine, including the signal path.

For your reference, and just in case, here is the additional info on my QX-5 on Roon when pressing the “i” button:

There was another thread where someone’s QX-5 kept showing up as uncertified until he did a firmware update and restarted his network, so I’m just following his lead. If Roon Server thinks it’s uncertified, it’s very unlikely that it knows it’s a QX-5, so then would make sense that the custom icon would go away.

Well, I went into a High Sierra terminal window and used the command-line version of the disk utility as well as the UNIX cp command so I’m sure that my thumb drive is FAT32 formatted and that the unzipped firmware update directory is in the right place on it, but, even when I follow Ayre’s instructions, the QX-5 won’t recognize the thumb drive and update from it. There’s one trick left I can try (maybe later) but I’m feeling inclined to call Ayre on Monday and request some assistance.

Well, read the reply from @john above. But do you actually have the QX-5? You keep talking about it for a week, and have yet to check the firmware version. It is easy to do so.

And also, what does the disk formatting have to do with this?

I’ve been sick and am only getting to the firmware update today.

Yes, of course I have the QX-5, how else would I be inserting the USB drive (which can be formatted in many different ways) into the firmware update slot on the back of the QX-5 after I’ve switched it off, then switched it back on and watched it not indicate that it’s updating to the current firmware version?

I’m talking about the “general firmware version”, which has to be updated with a USB flash drive, not the “network firmware version”, which the QX-5 automatically prompts you about:

General Firmware Version: H
Network Firmware Version: 03.05.07


Did not mean to offend you by any mean. Sorry.

What I was trying to say, first step is to check your General firmware on your unit. If it is “H” (mine is), then you would have nothing to update.

I am totally aware of the General vs. Network updates.

As I mentioned above my General version is H, and network version is 03.05.10. Ayre website says H.03.05.07

As John from Roon mentioned above, this issue may have nothing to do with Ayre firmware version.

Yes, sorry. It is “E”, so quite outdated assuming the E precedes F, G, H, etc.

1 Like

Hello @thyname & @Robert_Schaub,

We have received notifcation from Ayre that firmware 03.05.07 is the most up to date firmware for their device. You can find a link to the firmware as well as download and installation instructions here

If you run into issues getting your firmware updated, I recommend reaching out to Ayre support. They are aware of the issue and may have better insight into the particulars of the upgrade process.


1 Like

I fixed it!

Mine was a brand new that came with most recent firmware installed.

It is actually H.03.05.10

H is the General firmware that requires the thumb drive download, and the numbers are the over the network firmware.

If you have the latest firmware, you just need the network reset.

Get into the menu – hold right button for three seconds then left button for three seconds.

Toggle right with the control ring to network then hit green button. Toggle right again to reset and hit green button. It will say No – toggle right once to yes and hit green button.

Then restart your Roon server, and that’s it! The QX-5 is no longer “not certified “ and the correct logo appears on Roon.

See screenshot

Thanks for these instructions—I had the same issues with my QX-5 being “uncertified” after the recent Ayre network update. But I had no idea there was also a firmware update available by USB stick. My firmware was version C so it was quite outdated, I had no idea. I had some issues copying the downloaded update in the right format to my USB stick because like a previous poster I have a Mac. I finally got the QX-5 to update by formatting the USB stick to “MS-DOS (FAT)” and selecting “Master Boot Record” instead of the default “GUID Partition Map.” I discovered that trick by googling how to format FAT32 on a Mac. I called Ayre and they did not know that trick either, the guy at Ayre was going to mail me his USB stick with the download, but I was able to get the QX-5 to read the USB once I used “Master Boot Record.” Now I am running version H as well as the latest Network update. Nothing sounds any different but I am satisfied anyway.

OK, I finally have it all sorted out. It took a while because I’ve been a bit sick, just started a new job, and needed to have a thumb drive sent to me from Ayre since nothing that I tried with my MacBook Pro running High Sierra would seem to work, and–trust me–I tried everything that I read about and then some apart from buying a third-party disk utility program for formatting the thumb drive and possibly copying the downloaded and unzipped general firmware update directory to the root of the thumb drive (and did all of that with two different brands of thumb drives). In any case, the thumb drive from Ayre worked, so I have general firmware version H and network firmware version 03.05.10. A number of people have suggested a network reset, but–out of context–that implies resetting my home network and nothing in particular on the QX-5 Twenty itself; however, I read your instructions and assumed that they referred to the QX-5 Twenty because nothing else I have has a left and right button and a control ring. The QX-5 Twenty didn’t indicate anything had happened after I hit “YES” so I did it twice just to make sure. Then, yes, indeed Roon recognized the QX-5 Twenty as certified, the custom icon appeared in the remote Apps again, and everything seems to work just fine. Thanks very much for the suggestions and assistance.

1 Like