Roon ignores files to import [Resolved: WMA files not supported in Roon]

Version 1.3 Build 269 64Bit, work done on main computer running Roon Core:

Wanted to play a few selected tracks from a visitors CD’s (fine tuning/eval of my system) but was unable to get Roon to see the new content. I disabled existing storage locations and created a new one (local drive D:\T) to put the temporary tracks. The tracks would be deleted and the storage location removed after our listen. I copied tracks from the a CD to this Directory and also used a CD Ripper to put rips with the correct tracks and metadata into this directory (have used this before without any problems to import and work with CD’s).

Roon showed the new storage directory correctly but would never show any tracks imported and the “skip” history showed no track imports were attempted/failed. I modified the storage location to clear out (eliminate) paths to ignore, but this did not help. When I have someone who wants to evaluated my system come over, they usually bring their own music and only want to listen to a small number of tracks, they do not want to sit around while we import full CD’s just to listen to a single track.

My immediate issue was “mostly” solved with by using TIDAL, to play the desired content (it had 80% of what was wanted), but I am at a loss about why I could not get Roon to see and play any of these tracks from the storage directory. My issue is NOT urgent unless this issue ends up effecting my other existing storage locations.

IMHO, this is an ongoing Roon problem.

You can force a rescan at Settings–>Storage–>the right 3 dots–>Force Rescan

I did a forced rescan several times but it didn’t do anything. My only though was maybe there is something in the directory name that Roon didn’t like. I have not had a problem with Roon picking up new content in my other defined storage locatons and in the past I have created a temporary storage location and used it without issue. I even shutdown and restarted Roon/Core to see it that would help but again couldn’t get it to see the content. I recently (last week) created a new storage directory for HDtracks content and Roon has picked this up instantly as content was added to it.

There are special characters that gives Roon fits, but if your directory contains only letters and numbers then it shouldn’t be a problem. Somewhere in the KB there is a list of characters that are a problem.

Here’s the KB article on special characters and names

1 Like

Thanks, will remember this. Isn’t relavent to my issue since the drive and directory for the source is “D:\T” is about as simple as it gets–)) and was picked by browsing and picking with Roon. I didn’t actually enter anything myself. Put some new content in one of my other storage locations today just to make sure everything was working and it picked the new content up fine.

It’s not just the watched folder path … there’s also the album folder and track file names within it to consider, could you give us some examples of the full path including file name.

  • Where does D:\T reside? (e.g. local Windows disk, mapped to NAS share, …)
  • Have you tried putting some other files into that Watched folder.
  • How where the files ripped?
  • What format are they?
  • Do they play using a different media player?

I’m assuming that D:\T is a temporary folder, that only contains a few files.
Did you try using FOCUS so that Roon only show albums from that location?

Can you post a screen shot of Roon’s Settings --> Storage screen.

Not sure if this is remotely relevant, but I had a similar frustration… Ripped music to flacs but Roon simply wouldn’t see them. Banged my head on the wall for awhile thinking it was a Roon issue. Turned out that I had screwed up the rip so even though the files were sitting there and properly named .flac files, they could not be played.

Have you tried simply playing those ripped files outside of Roon just to verify that they are proper music files?

I have had a similar issue with importing multichannel tracks for albums I already had in stereo. They didn’t show up as recently added, but they were there as the non-primary versions of the albums once I thought to look there. Still, not a good Roon experience; should not have to dig to find the content you want to play and sit there and troubleshoot with friends over.

Roon’s desire to be a different kind of media player is really the cause of this problem. It won’t just play a track without being imported into the database, nor will it allow an explorer/folder type of navigation. Roon ought to either let you drag and drop just to play – don’t add to the database – or allow navigation by folder organization to play tracks.

One of the Roon faithful may chime in and explain why folder navigation is “harmful” and provide workarounds that include adding and then deleting from the database, and how to dig deep to find these tracks. But…any other media player will just take a drag and drop from Explorer or help you find a track by WHERE YOU PUT IT.

I add my multichannel files to a folder called Multichannel then I can use focus and inspector to filter by storage location, would that work?

For something like multichannel, yes, once you configure it to show duplicates, there are a number of ways to find that content and then tag it.

My comment is more general - it should not be an easter egg hunt to find a media file just to play it once.

Roon works great to help people avoid having to organize their collections, but it is not particularly good at helping users leverage the organization they’ve already put into their collections.

Let’s not get side tracked on “missing” functionality, there are existing feature request topics for that.


Track view, filter on path with do this.

1 Like

Yes, Windows played them by point & click. Would be nice if you could specifiy a “storage” as a CD drive, but Roon doesn’t display CD/DVD drives. Understand why since they are not suitable for permanate reference - but would have been nice for demo purposes

Can you expand a little on this? If it’s a CD, I’m not sure how you can “copy (audio) tracks from it to a directory”… Ripping a CD to a directory, yes, that I understand, but copying audio tracks from a CD as well - that I don’t grasp.

And when you say (in a later post) “Windows played them by point and click”- what program did Windows use to play them? I’m just trying to understand what is going on here. Thanks.

The files on a CD are just files, you can copy them like anything else but you do not get the hidden metadata that is on the CD unless you use a ripper (which I normally use). Tried just copying the track I want to play first, and when that did not work, used my ripper to copy the single track to the temp directory (local drive, SSD, on local PC running Roon Core).

Double clicking on a file on the CD or in the d:\t directory causes Windows Media Player to play the file through my PC speakers, so it plays (not an issue with the file).

I deleted the storage location in Roon but not the temp directory, so when I have a chance I will re-do this and if it again fail to work will post snapshots of the info that was requested. This is all going on while I had a guest present and I was just trying to get content to play, not troubleshoot Roon.

Well, they are “not just files” on a CD, unfortunately. They are placeholders - and the audio tracks themselves won’t get copied across.

I’ve just done a test - I’ve created a folder “T” on a Windows PC, on the "G: " HDD. So the path is “G:\T”. I “copied” the CD across to this directory, and I also ripped the CD to a staging directory (using dBpoweramp), and copied the resulting FLAC files to the T directory as well. The result (shown as a network shared folder, because I’m viewing it from another PC) is thus:

You can see the FLAC files, and the CD placeholder files.

If I double click a placeholder file, Windows Media Player will open, and try and play the track, but nothing will happen, because the placeholder is now divorced from the audio (on the CD). If I double click the placeholder file on the CD, then of course the audio will play in Windows Media Player.

The FLAC files are just FLAC files, and they will play with whatever the default media player is in Windows (in my case, that’s Groove).

Now there’s a Roon Core on the Windows PC with this G:\T directory, and I’ve just added it as a watched folder. And Roon has found the album instantly…

So I’m not sure what’s going on on your system, but it all seems to be working as expected on mine… Sorry.

Will try and give you more info later. My comment on files goes back to my earliest CD’s, where the files on them were the song names with a WAV extension. No problem coping these files off the CD. I tend to forget that for all current audio CDs you must use a ripper to copy them (something I clearly forgot at first when I tried just coping the track ID, which shows up later in windows as a shortcut). None of this is important to my original issue and I’ll try and duplicate that issue by tomorrow so I can get you more concise info - thanks. Like I said, I was trying to get stuff to play ASAP with a visitor sitting waiting on me when I had this issue so I wasn’t focused on the issue but on finding a solution (Roon/TIDAL solved it by providing me access to the same content at CD quality

Drive D is a local Window Drive (drive C: boot drive, drive D:, etc.). Have not tried putting in other files. Files ripped with Cyberlink CD/DVD utility - Format according to explorer is .WMA. Clicking on them in Windows starts Window media player which play both tracks just fine. Roon is showing no files imported for this storage location. Screen shots follow: Roon storage info, Skipped file log, Windows file directory. Forced rescan does nothing. If you want more I’ll provide it if possible. Roon is snapping up new or changed content in the other storage locations perfectly. A search of Roon for track with the names shown yields nothing

Roon does not support WMA. Bar none.


Yup - that’s why they didn’t show up in Roon. Here’s the list of supported formats.