Roon ignores my music

Roon Core Machine

Intel Core i3-7100

Networking Gear & Setup Details

AVM FRITZ!Box 6591 Cable
Ethernet only

Connected Audio Devices

3.5 mm audio jack on Roon Client

Number of Tracks in Library

approx. 16,000 tracks

Description of Issue

Everything was working until Roon suddenly didn’t showed my local music anymore. Roon Core has read and write access to my audio files and they can be seen in the Roon client Settings > Storage > Add folder dialog but they are not shown in Roon itself anymore. In Settings > Library > Clean up library it showed that I could delete 14675 (or so) files that aren’t there anymore (well, the files are still there). I did so. I removed the storage path. Restarted Core and Client. Added the correct storage path again but Roon doesn’t want to index the files.

Hey @Ben_Humpert,

Thanks for writing in, and my apologies on the delay in following up! I wanted to check in on this thread to see if you were still running into this issue?

If so, please send a screenshot of your storage path for your local library. Also, how is your music stored on your NAS? Is it stored on and SSD?

I’ll be monitoring this thread for your reply :pray:

Hi benjamin,

yes the issue still exists. The Library is on a Level 0 SSD RAID, together with libraries of other applications.

lrwxrwxrwx  1 admin administrators   51 2022-09-16 21:04 Roon -> CACHEDEV1_DATA/.qpkg/RoonServer/Library/Roon Server/

My Music is stored on a Level 5 HDD RAID consisting of four 20 TB drives, together with data for other applications.

Hi Ben,

Sometimes there have been issues with Qnap seeing local files. Take a read of this post and see if it helps your issue.

I didn’t help but I managed to get Roon to see my files again.

In Settings > Storage I added a folder and then created a new folder. I then put a bunch of music files into that folder and finally forced a rescan of that folder. Three files were imported. Then I forced a rescan of the other two folders (which did nothing in the past) but now my files are found again.

Looks to me like the database was somewhat broken and adding a new entry fixed the previous ones. That shouldn’t happen!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Continuing the discussion from Roon ignores my music:

Again Roon does the exact same thing. However, this time I wasn’t able to “trick” Roon into doing a rescan.

Hey @Ben_Humpert,

I’ve re-opened your previous thread and merged it with your new post. I’m sorry to hear you’re having issues with Roon losing track of your external SSD.

I think it would be a good thing to test the SSD for corruption on another computer if possible. Can you please share a screenshot of your Settings>Storage as well?

Thank you for re-opening and merging.

Since that SSD RAID contains a whole Plex database and all the installed apps of the NAS I highly doubt it is corrupted because only Roon is affected.

I do use two internal M.2 SATA SSDs in a RAID 0 configuration.

Hey @Ben_Humpert,

Even if it’s low-level corruption, testing the SSD certainly doesn’t hurt to rule out in this situation :+1:

If you can, please disable and re-enable just one of the watched folders, and share the date and time of when you do this. From there, we’ll be able to take a fresh look into what might be going on.

Well, since it’s a RAID I cannot check the filesystem in a different computer.

I had removed all watched folders from Roon since my last posting and just added them again. Roon does not find any files.

I wiped Roon off of my NAS (uninstalled using the App Center & SSH’ed into it to rm -rf every remaining bit of Roon) and installed it again. It still doesn’t index my music.
I entered the roonmnt directory and copied a single song from there into a remotely samba accessible folder and accessed that file from my windows computer using MPC-HC and it was played back without any issues.

@benjamin Wow … I solved the problem.

After wiping Roon off of my NAS and following the installation instructions again I noticed this “FAQ” entry.

In the first re-installation run I ignored it because I did use that custom package from that website but was positively surprised that Roon is now available at the QNAP App Store. After that re-installation worked exactly as bad as my previously working installation I wiped everything off again and ran another installtion. This time using this custom package again. Now Roon immediately finds my music.

How can I turn off updates so that you cannot break Roon again? Also, thanks for letting me know that “it is a known bug” and that I have to remove Roon and install it again. I LOVE to configure everything in detail and losing all my “play history”.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.