Roon Imported Music From A Disabled Storage Device

@support History- I originally had my music on a NAS but had an issue with constant NAS access from Roon. I posted about this in these forums. I recently copied my music to an external HDD connected via USB 3 to my iMac (Roon Core). I disabled the NAS Storage in Roon Preferences. Roon showed no music in the library. Then I Added the new external drive. Roon began importing my music and doing its thing. 10 minutes later it was all done and everything was working fine. The constant disk access was not happening on the external HDD- very happy!

Several days of bliss. With Roon running and minimized, I accessed the music share on my NAS via Finder. The NAS started making HDD access noise. Didn’t think much about it until it continued for a couple minutes. I opened (un-minimized?) Roon and saw that it was importing music! What! I went to Preferences>Storage but the NAS Storage was still disabled. The Tracks Imported number under the externally connected HDD was increasing! I took a screenshot. So now I have 2 of everything from 2 Storage locations but Roon thinks it all came from 1 Storage location.

What happened? How do I fix this?

@support After uninstalling and reinstalling 2x, I figured out what the problem is. The, never enabled, share on my NAS is named Music and the enabled USB drive is named Music. Renaming the USB drive to USB Music solved it. 2 different paths on Mac OS 10.13.4 but Roon can’t tell the difference.

Also, in my uninstalling, I deleted Library/RAATServer, Library/Roon and everything in the Roon Backups folder but my wife still shows up as another User profile on the right? What didn’t get deleted?

Hello @John_Conte,

I apologize about the slight delay in getting back to you here and I’m glad that you were able to figure out that the two folder names were the same and have resolved the main issue at hand. To Add/Remove user profiles you need to click on the Current username in the Top Bar:

Then Select the profile you wish to edit and click the pencil icon:

Navigate down to “Delete”

I hope this helps but if you have any other questions please feel free to ask and I’ll do my best to answer them!


@noris Thanks!

This topic was automatically closed after 5 days. New replies are no longer allowed.