Roon installed on QNAP NAS won't play on Naim Mu-So 2nd Generation

Roon installed on QNAP NAS will play on my MacBook Pro and the QNAP but not on my Naim Mu-So 2nd Generation, though it does find the MuSo. What am I missing?


I’ve moved your topic to the support section of the forum.
In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Thank You.

My Roon Core is installed on a QNAP NAS that is connected to my Verizon WiFi network with an Ethernet cable to a Verizon Fios Extender (See The second Ethernet port on the Fios Extender is connected to my MacBook Pro. My MuSo Gen2 is on the WiFi network and not hard wired.

When I use the Roon app to try And play music, I can do so on the Mac and on the QNAP (terrible sound on the NAS of course), but not on the MuSo. The strange thing is that till about last week it was playing fine on the MuSo as well - so it can’t be that the MacBook and QNAP are hard wired to the Extender and the MuSo is not. However some time lat week it inexplicably stopped playing through the MuSo.

Eventually I decided to uninstall Roon, delete the old Roon folders and reinstall it all again today. Unfortunately no change in the problem.

Hi @Vikas_Gore,

Does the same behavior occur if you try to the MuSo via Airplay?
Is there any change in behavior if you reboot the MuSo?

AirPlay and MuSO are fine. In fact steadier than they have been for a long time (maybe because of iOS14?). However I discovered something new. If I play music that Roon locates off on-line sources it plays fine. However if I pick music that I have sitting on the QNAP server it will not play it. So it’s probably not a problem with the WiFi link.

Hi @Vikas_Gore,

What are the file formats that you are trying to play? Are you unable to play content from the QNAP on other zones like your Macbook’s System Output or does it fail to start there as well?

I’m playing either music ripped into iTunes using a Mac or music purchased in iTunes. It plays fine to the MacBook’s System Output but not to the Naim MuSo 2 or the Naim QB1.

Hi @Vikas_Gore,

Just to clarify here System Output works as expected through Roon, correct? It sounds like you used Roon, but just double checking you didn’t perform this test through iTunes.

Can you please let me know the exact local time + date + track of the next issue? I would like to enable logging for your account after receiving this info, thanks!

Yes, this was done through Roon and not iTunes. I tried this about 48 hours ago from my MacBook Pro and just a few minutes ago from my iPad. Doesn’t work. I using Qobuz from within room, still no joy.

Using Qobuz directly with the Qobuz app and AirPlay through the Qobuz app it works fine.

Hi @Vikas_Gore,

Can you please let me know the exact local time + date + track of the next filure on your MuSo zone?

I would like to enable diagnostics mode for your account after receiving this info and take a look at your Roon logs, thanks.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.