Roon interface to Tidal not working correctly

Core Machine (Operating system/System info/Roon build number)

Windows 10 64-bit OS v2004 build 19041.746 core i7-6700K 4GHz
Roon version 1.7 build 710

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Comcast cable modem -> DLINK DIR-859 wireless router WLAN port -> DLINK DGS-1100-24V2 switch -> PC hosting Roon

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Players include NAIM ND5 XS2 and Sonos, all ethernet cable hard wire connected

Description Of Issue

Tidal connection does not seem to complete login or work correctly any more.
Tidal login completes then a wait cursor shows forever on the Settings-> Services screen next to Tidal see screen 1.
Tidal albums show wait cursor forever next to Credits see screen 2.
Cannot see Tidal albums, wait cursor shows forever for albums in Tidal but not added to my library see screen 3.
Tidal albums already in my library usually play OK.
This all worked well until about 2 weeks ago.
Possibly associated with adding new DLINK 24 port managed switch.

Moderated: removed email address from first screencap

To confirm, does this open the default web browser for you to complete authentication on the TIDAL website?

It does open the browser to accept the login. Seems like there is a lag between the browser login to Tidal completing and the Roon app recognizing it is logged in.

First things first, have you restarted Roon? Also, have you tried another web browser?

I have restarted Roon. I also had to uninstall Roon and reinstall it, using a backup, twice because the Tidal issue seems to corrupt something if I close Roon and then restart the PC while a Tidal access (like add this album to library) is in progress. This reloading has not been fun but has worked OK to get back to the status quo. I use Chrome browser, are you suggesting I use i.e. Edge or something to log in ? I will try that.

OK this seems to be getting worse. I logged out of Tidal in Roon, then closed the app. I changed the default browser to Edge.
Now when I go to run Roon it says there is a problem accessing my database.
Last time that happened I needed to uninstall/ reinstall from backup to get Roon to work again.
Is there a shorter way to get Roon to start up from the ‘cant access your database’ state ?

OK tried it with Edge browser. Same results - spinning wait cursor next to Tidal signed in message on Services screen. Oddly it takes two tries - I mean I have to press Login in the Tidal popup window in Roon twice - before Roon changes to say Signed In.

Playing with Windows Defender firewall settings. Turned off Domain, Private and Public firewalls. Retried login to Tidal. Things went better. Able to add albums from Tidal to Roon. Roon.exe and raatserver.exe are both in the firewall exceptions list. Will play with settings a bit more but this is an exciting indicator of where the issue may lie.

1 Like

hi Martin, are you still monitoring this issue ? Are there any other pathways for more direct Roon support besides this forum based method ? Thanks.

Do you still have an issue? I had assumed the login issue was resolved. If you still have problems please describe them.

BTW I am a community member. Roon support also check the #support category. Support is usually via this community site or the help centre. You can also use the contact us page listed on the main website.

Hello @Allen_Murphy, and welcome to the community! I am a member of the Roon support team. Are you still experiencing this issue? I notice you’re using a DLINK DGS-1100-24V2 which is a managed switch. If you bypass it or set it to unmanaged, do you still have the issue? Does it happen on all devices?

Hi Nuwriy, and thanks for the welcome. Still having the issues with Tidal. DLINK managed switch is set to factory default settings. Not sure what you mean by bypass it or set it to unmanaged; are there specific settings I should try with it ? Suggestions welcome. Or do you mean remove it and revert to the previous setup using my 5-port TPLink router ? Thanks for clarifying!

I spent some time today trying to make progress on this issue and I think it is resolved.
First I removed the DLINK 24-port managed switch from the network and used a TPLINK 5 port switch I used previously. No change.
Then using the TPLINK I uninstalled and reinstalled Roon using the latest release 1.7 build 710. I then restored a database backup from Dec 18, made with Roon v1.7 build 667. This was a stable time in my system, before the Tidal and Roon library issues were seen.
Restoring the older (build 667) database seems to have resolved the problem with Tidal and made the Roon local library stable once again.
I replaced the Tplink 5 port switch with the Dlink 24 port managed switch, now the network appears tostill be working OK. The Dlink questions do not seem relevant.
Something in the Roon software and/or databases after build 667 seem to have caused a Tidal issue and some instability in accessing the local library.
All these tests were done using my WD MyCloud Home NAS drive. I decided, after reading some Roon user’s feedback on this forum, to switch to a QNAP NAS drive. I switched to that after things appeared stabilized. Happily that also appears to be working normally.
I might get a NUC drive and configure up a ROCK music server as an experiment, just to seek more stability and get the Roon server off my main Windows 10 PC.
Thanks to all for your assistance and input.

Hello @Allen_Murphy, glad things are working again! Please let me know if the issue returns. Also, the reason I was mentioning the managed functionality on the switch is explained here for future reference.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.