Roon iOS app crashes at 30 sec or less from started

Roon iOS app 1.8.00943 and the previous version are crashing at around the 25-30 sec mark. It doesn’t matter if I’m playing or browsing or doing nothing in the app, it crashes. My iPhone and iPad both behave the same so I can’t listen to music on those devices.

My Roon core is also up to date.

I tried rebooting the core and rebooting the iOS devices. Also reinstalling the iOS app but no success in getting rid of the problem.

Do you have any suggestions?

Am I the only one with this issue?

Hello Benjamin, welcome to the community, and sorry that you’re having trouble. I’ve moved your post into the Support category of the forum where it will be seen and responded to by a member of the Support team.

Can you please let Roon Support know these details so that they can better assist you? Thanks!


Roon Core Machine
Include your operating system and machine info (Model, CPU, RAM)
Networking Gear & Setup Details
Your network gear (model of routers/switches) and if on WiFi/Ethernet
Connected Audio Devices
Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)
Number of Tracks in Library
Tell them how large your music library is, eg. “30,000 tracks”
Description of Issue
Tell Support about the problem you’re having in as much detail as possible.

Thanks.

1 Like

alright, let me respond to these questions inline:

Roon Core Machine
Roon 1.8 build 943 stable on Fedora 35 Linux kernel 5.15.12-200
Hardware is Intel i7 running on a VM with 2 CPU cores and 2G RAM
Stats show CPU usage at ~4% and RAM at ~30%. My core has no issues streaming to the endpoints that are not iOS apps.
Networking Gear & Setup Details
iOS devices are on wifi on a Netgear R7800 switch.
Connected Audio Devices
The two iOS devices that are crashing the app are either using the apple lightning to jack adapter (iPhone) or the USBC dongle + Audioquest Dragonfly DAC. App crashes on either of these.
Number of Tracks in Library
9350
Description of Issue
Please see the original post for the issue description. Let me know if you have questions or anything you’d like me to test. Since my iOS Roon apps in iPhone and iPad crash all the time, I can use Roon with the desktop app to my other non-iOS endpoints.

If you do not have these cables in, does the phone crash?

Affirmative, the roon remote app without anything plugged in the iphone and without any action performed, crashes 100% of the times few seconds after launched.

Hi @Benjamin_Esquivel

Welcome to Roon Community, and I appreciate you bringing this problem to our attention. We’re sorry to hear that you’re experiencing crashes on iOS.

The tech support team will be able to pinpoint the issue most efficiently if we can inspect logs from the crashing iOS remotes. We’ll investigate those and follow up with additional questions. Please follow the steps below:

  • On the iOS device(s):
  • Quit Roon
  • Go to System Settings on your iPad/iPhone
  • Scroll down until you see Roon
  • Tap on it
  • Turn on “Save logs to Files on next start up” see screenshot below

  • Launch Roon (replicate crash)
  • Open Files app on your device
  • Go to “On this iPad/iPhone”
  • There will be a Roon folder and inside of it there will be a tgz file (see screenshot below)
  • Upload the tgz file from your iPhone and iPad here.

Hey Connor, I’ve uploaded the file to the specified location.

My iPad app is not crashing anymore with update 943 so that’s good. It was crashing before this version and it was at the device selection interface where it would just hang trying to select this device. Maybe timing out? anyways, the iPad in 943 is now stable but the iPhone in 943 is still unusable. For what is worth, I did experience the device selection issue prior to 943 in the iPhone but now device selection is not an issue while crashing continues to be a problem.

Also there’s a couple of other users that reported this exact same issue recently in this other thread.

Finally, thanks for following up on my case. Let me know if there’s anything else you need from me.

Roon Core Machine

Hi,
For a couple of months I´ve been having problems with the Iphone app (but not with other IOS devices, such as the Ipad). Every time I used it, wheter to managed and control Ronn on other devises (for instance to play music thorugh my Naim gear) or as endpoint, when I used the Iphone plugged into a Chord Mojo 2 and headphones, after a few seconds, the app crashes and closes. If I want to select some album or track to play it on other gear, I have to be fast enough to find it and play it before the app crashes. I just can´t use it as endpoint. When I open it again, the app shows me the last place where I was (lets say on the album I was trying to play), and then I have to execute it. it is very annoying, as you may understand.
Does anybody else has this problem?
I tried erasing the app ans installinf again, reboot my phone, etc., and always the same.
I have an Iphone 12 Pro Max using IOS 15.4.1.
The roon app is updated.
I use an Intel NUC mini PC kit NUC7i7BNH (Intel Core i7) with Rock inside as Roon Core, with a LaCie D2 professional external SSD hard disc connected to the NUC via USB-C.
I don´t have any problem with my other endpoints (naim, hifiberry, Notebook, etc.)

Thanks
Felipe

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I have exactly the same issue but for me it happens also in the iPad, not only in the iPhone.

I tried same things you did (rebooting, reinstalling) but app still crashes a few seconds after it is started.

I also have no problem with other endpoints or remotes that are not iOS.

See my report here:

Thanks. Did you receive any solution?

Hi guys,

I’m just another user here but I get the same issues frequently and I’m just wondering/interested in how many Safari windows you have open and how many apps are running in the background.

Just wondering if there is a correlation here as my iPadOS/iOS Roon app sometimes appear more stable when there are a minimum of Safari windows or apps running.

Hey Mark, I don’t think there’s a correlation. I have max 2 tabs open, but mostly just the one. I’m getting frequent crashes. Has been happening with many releases now.

These support threads are usually marked as resolved / closed. Typically a reboot (or an entire ios reset) could be used as a temporary workaround. Support seems to consider this as ‘resolved’ but I certainly don’t.

1 Like

Hi Bart

There goes that theory then :grin:

Yeah, I usually close all apps and do a force restart and that seems to help for a bit (or not)

Turning the phone on and off should cover for the case of many apps in background interfering. But in my case and seems like the OP is same, it doesn’t help.

It looks like in your case the crashes are intermittent? In my case those are 100% of the times. It’s really unusable.

IOS crashes constantly on my iPhone just scrolling around. I don’t even need to listen to music. I have an iPhone 13 Pro. Even the newest Roon version didn’t fix it.

it’s work in progress, you might want to check that thread too, it seems like it got some attention. I’ve redirected them to this thread to look for the other users that have reported the same behavior that you and I are seeing.

If reinstalling the app is not fixing it and if more than 1 user is experiencing that then it is likely they will need to address our issue via an app update.

By the way, I’ve updated my thread that my iPad is no longer crashing after the 943 app update so that’s what I’m using as a driver now. I’m guessing your iPad is still fine?

Thanks Benjamin. I´m receiving the posts from your thread.
I will check about the last update once I get home.
Best
Felipe

Hi everyone,

Thank you for bringing this issue to our attention and for the details you’ve provided us with so far. I’ve consolidated the multiple threads related to this iOS crash into one, and my team will provide updates and request additional details in this chain moving forward.

I appreciate your continued patience as we investigate the issue. I know it’s frustrating to have an unusable endpoint in your setup.

@Benjamin_Esquivel, thank you for providing iOS logs for deeper insight into the crash, and @Felipe_Correa, I appreciate the detail in your description.

@oneofmany, @Nepherte, and @Marco_Gymnopoulos, if you also have a moment to provide your setup and network details, it will greatly increase the support team’s efficiency as we narrow down the problem. I’ve included a template below you can use if you’re willing. Thank you!

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

1 Like

Roon Core Machine

Nucleus+

Roon Remotes

1x Apple Macbook Pro 14" on macOS 12.3.1 (wired and wireless ethernet)
1x Apple iPad Mini 6 on ipadOS 15.4.1 (wireless ethernet)
1x Apple iPhone 12 Pro on iOS 15.4.1 (wireless ethenet)

Networking Gear & Setup Details

Router: 1x Ubiquiti UniFi USG-3P
Switches: 3x Ubiquiti UniFi US-8-60W
Access points: 1x Ubiquiti UniFi LR-6R

Connected Audio Devices

Mola Mola Tambaqui (wired ethernet)

Number of Tracks in Library

2,298 tracks / 178 albums

Description of Issue

The Roon app on the iPhone (and not the iPad) crashes quickly after opening. It is easily triggered by scrolling down quickly in e.g. the Albums or Tracks page. A reboot of the phone helps temporarily, only for the issue to appear after an unspecified time. All other devices work as expected.

1 Like

Roon Core Machine:

SonicTransporter i5 on 1.8 firmware

iPhone 13 Pro on iOS 15.4.1

Networking Gear & Setup Details:

Netgear Nighthawk RAX78 Firmware: 1.0.12.114
Router via ethernet connected to Sonic Transporter i5
Router connected to wifi Zen stream via Wifi (latest firmware)

Connected Audio Devices:

ifi Zen stream via USB to Rotel A14 MKII (both Roon ready)

Number of Tracks in Library:

173 albums with 4053 tracks

As mentioned by others a reboot fixes the issue temporarily.

1 Like