Roon iPad not connecting to Core

My issue is getting Roon or Roon Essentials to connect to the Core (Windows 10)

I can access Roon(music) through Yamaha receiver via endpoint (ethernet) however Roon app cannot connect with the core. I have made progress. On the Core machine, the endpoint shows up and plays music in both locations.

What should I try going forward

Attached are photos of ipad and Core

Thanks for sharing your report with us, @George_Burrows!

To start, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

May I also ask that you please verify the following:

  • Is the iPad remote the only device that can not connect? Do you have any other devices that you can use as remotes to test the connection?
  • Is the iPad on the same network as the Core machine (not a guest network or anything like that)?
  • Have you tried power cycling your Core machine, networking hardware, and iPad?
  • Have you tried reinstalling the remote application on the iPad?

Regards,
Dylan

Dylan,
Thank you for the prompt reply. I have attached the requested information.
Roon
George Burrows

CORE
• Version 1.5
• Windows 10 Pro Version 1709 - 64 bit -OS build 16299.492
• Name: User-PC (custom build) AMD FX ™ -8350 eight Core Processor 4.00 GHz, 32.0 GD (RAM)
• Storage: Synology NAS
• Connection- NAD USB Audio 2.0
• Collection: 3,045 Flac music recordings (CR and Flac downloads)

Issue
• Mac devices cannot connect to as remote to Core. I have tried iPhone X, iPad Pro and Macbook Air.

Network
• Mediacom internet 2 gig
• Aris Surf Board S8200 Modem 3.1
• Netgear Nighthawk x4 Ultimate Gaming Router-Ac2350 4X4 MU-MIMO Dual Band Router
• Netgear Nighthawk S 800 Advanced 8 port Gigibit Ethernet Switch ( at remote system downstairs via in wall cat 5 from router)
• Sonic Build SN_rpl_hifiberry_digi

Media
• Flac Music files from WAV files and Flac downloads
• Tida n/a
Output
• Sonic Build SN_rpl_hifiberry_digi into Yamaha CX-A5100 AV Preamplifier

“Is the iPad remote the only device that can not connect? Do you have any other devices that you can use as remotes to test the connection?”
• No, all Mac devices: iPad, iPhone 10, Macbook Air

“Is the iPad on the same network as the Core machine (not a guest network or anything like that)?”
• Yes

“Have you tried power cycling your Core machine, networking hardware, and iPad?”
• Yes

“Have you tried reinstalling the remote application on the iPad?”
• Yes

Thank you for the details, @George_Burrows, it’s greatly appreciated!

Just for clarification here - There are no devices that are able to connect, correct? No Android or Windows devices? I just want to make sure I’m 100% clear on the behavior experienced.

Is the MacBook connected via WiFi? If you use a wired connection to the router are you able to connect?

Can you confirm whether or not there is any active antivirus software or firewall enabled on the Core machine? If so, does disabling them allow the remotes to connect?

Thank you!
Dylan

1 Like

All Mac. I did find that Windows Defender was on/Firewall was enabled. But when I did a search inside WD i said at risk/off? No other Anti virius. Malwarebytes ?

No difference on iPad…

I am sorry this is so complicated. I have great audio, no remote control…LOL

No need to apologize, @George_Burrows, and thanks for the info!

Since disabling the firewall didn’t make a difference, and there is not firewall active, let’s look at some other options.

Have there been any changes to your setup recently that may be contributing to this behavior? Any new networking hardware, or software that uses the network (like VoIP or VPN)? This was all working for you previously, correct?

A good data point would be connecting the MacBook via Ethernet to the network. If it works, that would may point to WiFi issues. If it doesn’t work with Ethernet, that will at least rule out that possibility.

Thanks for your patience while we troubleshoot this, George! It’s greatly appreciated.

-Dylan

Yes. The Netgear and Aris is all new in the last several months. I had Apple Extreme. Problem is it did not work then or at least I was unaware on how to trouble shoot for 2 years. I am much closer today.

I have a macbook pro that I could hook up via ethernet. I would have to disconnect the ethernet to the endpoint however. Do not have another port.

Gotcha, thanks @George_Burrows. Sorry to hear you’ve been having this issue for a while, but I’m happy to help get it resolved for you!

Often when troubleshooting it helps to simplify your setup and then add things in piece by piece until you find where the problem is stemming from. In this case, it might be worth trying to simplify things by connecting your Core directly to the router, passing by the switch.

We have seen similar issues stem from the use of the configuration of managed switches. While the switch you’re using isn’t a managed switch, it looks like it may have some similar features. If the remotes can connect when the Core is not connected to the switch, then we know to look into the settings on the switch.

This would certainly be a good test as well, if you’re able to do it. You wouldn’t need to leave it this way and could reconnect the endpoint after the test, but this would allow us to know whether or not the problem is specific to WiFi or not.

Another thing that you can look into — Are all the mentioned devices, in the same IP range? An app like FING will scan your network for devices it can see. If you can’t see the Core machine while using Fing on one of the remotes, that would let us know that there are networking troubles to look into.

Thanks!
Dylan

Great. Could you give me a day to do this? I had back fusion 2 weeks ago and can’t bend, etc. George

Absolutely! No rush at all. If you have any questions at any point feel free to reach out.

I have a Windows X machine in my outside studio. I have Roon installed. It connected immediately to the ethernet core. Added a new zone to play through the default audio - Altec 2.1 audio system. It is on the same wi-fi network I was trying with the mac devices. Is this a shaking hands Apple to Netgear issue?

Good to know, @George_Burrows!

I mentioned the Fing app in my earlier post, and I think that may be a good idea to try here. Fing will scan the network for devices it can see. If it cannot see the Core machine then I think we would have a good idea of what to try next.

Thanks,
Dylan

I have used the Fing app. everything shows up. The Core is Desktop-08S6bl

It pings.
There are a few that are marked generic. iPhone and the rasberrypi show up and ping?

Roon loaded on iphone immediately.

I spoke too soon. It now says lost connection. It is 75 ft away from router? It no longer shows in the Fing app 100% of the time. The iPad does not show up as George’s iPad?

Hey @George_Burrows,

Since it doesn’t show up in Fing 100% of the time it sounds like there are some intermittent network connectivity issues with these devices. Are you seeing the same behavior using the iPad?

If possible, can you connect the MacBook to the network via Ethernet? That should tell us if we need to look into the WiFi specifically, or if it’s a more general networking issue at play.

-Dylan

I

I think there may be some latency issues. I worked with the iPad and this is what I have…
I can control the core and will go to the other zones to make sure that they are as labeled.

I have too many zones that are not functional. I only need three.

I have a 17" Macbook Pro that I can connect via ethernet. It will be some work to complete the task, but I will as soon as I am able.

Thank you for the update, @George_Burrows!

Glad to see that it looks like the iPad is connecting now! Has it been staying connected? Are the other remote devices still having the issue?

Are these audio zones you are referring to? What kind, and how are they connected? By not functional, are you able to see and enable them but not play music? Or do they not show up at all?

No rush here at all, just give it a try when you’re able. Since it looks like the iPad is connecting now it looks like we are closer to getting you up and running!

Regards,
Dylan