Roon Is Agonizingly Slow Loading Music

Core Machine (Operating system/System info/Roon build number)

Dell XPS 15 with 32 gigs of RAM and 1 TB SSD. Connected via ethernet.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

AT&T U-Verse 50 Gbps

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Streaming to Oppo 203. HDMI from Oppo to Bose Soundtouch 300 and Sennheiser headphones via 3.5 mm to base station and RF to headphones.

Description Of Issue

Roon is almost unusable because it is too slow in loading music from both Tidal and Qobuz. I’m early into a 60 day trial and like that I can stream wirelessly to my Oppo vs using a wired connection from my iPad. However, it is too slow loading music. Unless something improves soon, I will cancel.

I guess I should have said internet speed with AT&T U-Verse is 50 mbps.

This can often be caused by DNS settings. Try using Google DNS settings: and Does that change your problem?

OpenDNS is another good alternative if you wish to not give Google even more info about your habits.

CloudFlare at is a good one too.

Depending on where you are (logically not so much physically) in the world, one may work better than another

1 Like

Thanks, but why would that matter if I’m using an ethernet wired connection to my AT&T U-Verse router?

Because roon does tons of DNS lookups to various services and ISP lookups can be throttled or slow. So try the DNS change.

1 Like

Thanks everyone. That may have fixed it. At least on the first two albums I tried, they started playing right away.

I spoke too soon. That helped, but it’s still slow loading some music. Makes me wonder if it’s worth keeping or just stream directly from Tidal and Qobuz?

Definitely seemed to help my occasional slow issues at least for now. I think that needs to be part of the official directions for the roon software. Granted I’ve had roon since it was first offered years ago and I still think there has been something different since the last update as it still remains occasionally frustratingly slow. But definitely a positive difference by switching to the open DNS settings on my Verizon FiOS which should be lightning fast typically. Thanks for the tip Ged!

Any other ideas? It’s frustrating because both Tidal and Qobuz work very well by themselves. That’s using either a wired or wireless connection to my Dell XPS 15 laptop. Also, with my iPhone or iPad, both Tidal and Qobuz are very quick. It’s only when using Roon that things become agonizingly slow. This will be a deal killer for me if I can’t figure it out. And, so far, I really like Roon. Primarily because I can stream wirelessly to my Oppo 203. The Oppo is not near an ethernet connection and I don’t have any other streaming device except my Dell, iPad, and iPhone. I’m not using my Apple TV 4K due to it’s 48/16 limitation.

This isn’t typical of Roon and the Roon technical support folks should be able to get it straightened out for you.
Just for your information, Roon puts a much heavier demand on network resources than ordinary streaming services. There is a lot of metadata management, graphics processing and digital signal manipulation (if needed) happening in addition to multiple endpoint streaming. Of course, you should not have to pay a penalty for it. When things work as they should, its transparent to you. But it explains why things are performing differently between Roon and Tidal, for example.

Speed varies, but it can take 30 seconds or more to start playing a new album sometimes. What is normal?

Nearly instant is normal for me with Tidal. I did have a network switch start failing on my over the past few weeks. I replaced it with another I had and all the slow downs went away. For me, the symptom was Roon Radio would fail to find anything and fall back to my local library. After the switch replacement, it’s not missed a beat.

If you can easily remove any connections between your Roon Core machine and your AT&T device, if appears you’re already directly connect though. Reboot the AT&T device if you haven’t already, and finally get AT&T to replace the device.

Other network activities like web browsing and email are much more tolerate of network faults (and latency)…Roon really needs a very stable connection throughout to perform ideally.

The problem is definitely with Roon. I just rebooted my router and Dell XPS 15 which is running the Roon core. It’s connected to my router via ethernet.

Tidal and Qobuz start playing as soon as I click on an album. Roon takes 35 seconds. Totally unacceptable.

Let’s get @support to give you a hand. My money is on firewall rules (either Windows or router).

Hi @Jim_F,

Does this happen with all endpoints? If you play to System Output of the Core machine does it take the same amount of time?

That’s it. I turned off Windows Defender and Roon starts playing almost immediately. So, how do I let Roon through the Windows Defender firewall? Thanks.

Can’t tell you the exact steps because I don’t use Windows much at all, but if you review firewall rules or applications in defender you should see entries for Roon. Ensure it can send/receive TCP and UDP traffic on all ports (if someone else knows which ports Roon uses it’s better to accommodate only those ports rather than all ports).

Hmm, that page has a link that now goes to a generic Microsoft Help page, which is worse than useless. For specific instructions on setting up the firewall, this is clearer