Roon is damaged

when I try to open Roon I get a notification that “Roon is damaged and can’t be opened. You should move it to trash”

What platform are you on? Have you attempted to reinstall? Can you share some more information about your setup, Remote OS, Core OS etc?

Hi @Wayne_Davies,

Thank you for bringing this issue to the attention of the community on the public forum. I’m sorry to hear that Roon is out of action.

Account diagnostics show that you have a Roon Core and several Remotes active. Are you experiencing this issue on a particular device?

In any case, let’s attempt to refresh conditions with Roon by renewing the database and reinstalling across your devices.

First, on your Remotes, delete the Roon Remote and ARC apps fully (removing all data). Before attempting to reinstall, please then take this step on your Core:

  • Make a Backup of your current RoonServer Database
  • Exit out of RoonServer
  • Navigate to your RoonServer’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Reinstall the RoonServer App from our Downloads Page to generate a new RoonServer folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database

Next, reinstall the Roon apps across all your devices.

Looking through logs, the team has noticed some network failures that are likely affecting Roon’s performance, although they might be unrelated to your symptoms described here. In particular, 1) there are multicast errors, affecting device discovery, and 2) requests from Roon to our servers are failing.

Please let us know if you’re experiencing any dropouts, slowness, or other network-related performance degradation with Roon, and we’ll happily troubleshoot that, as well.

Thank you, and we’ll stand by for your response.

I received this same error after upgrading to MacOS Ventura on both my Mac Mini running Roon Core and my iMac running Roon Client. In both cases, I solved the error by going to Security and Settings in System Settings and clicking the “Open Anyway” button. After that, it ran fine.