Roon is forcing HQPlayer to use DOP for DSD [Resolved]

Hi @Support
Roon is forcing HQPlayer to use DOP for DSD

I am running Windows10 (64) on a CAPS Pipeline computer dedicated to audio only.
I am running Roon Server and HQPlayer on the same computer, connected directly by USB to a Holo Spring DAC.
I am using Roon as the front end for HQPlayer.

My computer is set up as a headless server, (although I have a monitor hooked up top it currently), so Roon Server and HQ player are run at Boot.

I have only been able to play DSD files with DOP enabled in HQPlayer. The other day I reloaded the latest Holo Spring AISO driver and before I installed it I quit Roon Server. I was able to play DSD native without DOP. When I restarted my computer I was no longer able to play DSD native and had to use DOP to get DSD to play. I quit Roon Server and restarted HQplayer and I am able to play DSD512 on my Holo Spring.

Here is my screen shot. Will you please look at it? I do not know what it should look like.

This is the default setup.
when I look at it I see three things that could be wrong but???

  1. Roon Server/Core are directly connected by USB to Holo Spring DAC.
    a). HQPlayer is using my HoloAudio ASIO Driver, is it a problem that it says device not found?
  2. HQPlayer is showing up as a “Zone” in the networked section. I have a direct connection and only one DAC, is this correct?
  3. DSD to PCM. I do not convert DSD to PCM, so this does not apply to me. Correct?


Roon talks to HQPlayer to queue/control playback via a specific API, it has nothing to do with how HQPlayer talks to your DAC. That configuration happens in HQPlayer only.

Remove the playback zone for your DAC from Roon you don’t need it if using HQPlayer.

Get playback working properly from HQPlayer itself, leave Roon out of the equation at this point. Once HQPlayer is doing Direct DSD as you want then enable Network support in HQPlayer and use Roon to control it.

If you can’t get HQPlayer itself to do Direct DSD the issue is in HQPlayer or it’s configuration, not Roon.


I have direct DSD working in HQPlayer with out DOP.
I am playing DSD512.
If I have Roon Server on before I initialize HQP, I can only do DSD over DOP.

I am very sorry, I need more hand holding than this.
How do I enable/disable network support in HQP?

In the screen shot above:
Connected to Core: what should that look like? should it say HQplayer? Should it be able to find the Holo ASIO Driver? Is it correct to say “Enable” at system output?

Networked: what should it look like? what should it say?

DSD to PCM: is it N/A? I only convert PCM to DSD.

Thank you

I don’t think you need to worry about this, since you have Roon core and HQP running on the same computer, with the DAC connected via USB.

Don’t enable System output, and as long as you’re using HQP, you can disable the “HoloAudio ASIO Driver” zone, as recommended by @DrTone. The only zone of concern is your “HQPlayer” zone.

What you have in the screen shot looks fine. You can post screen shots of your settings for the HQP zone, but I think this is down to your HQP settings. (At least until you solve your problem, be sure that all Roon DSP is disabled for your “HQPlayer” zone.) It might be helpful to post a screen shot of your HQP settings.

Correct. It doesn’t matter for the HQPlayer zone.

@orgel I think it still uses networking just (localhost) instead of a remote TCP/IP address. @William_Horan I’m not in front of HQPlayer but on the main HQPlayer screen there is network toggle, sorry can’t remember what it’s called.

In Roon 1.4 the HQP Zone setup has been relocated to Settings/Set Up.

You can create an HQP Zone using this button and entering “localhost” as the IP address for HQP. This will create a link to HQP on the same computer instead of through your router.

The “Enable Network Control” icon in HQP is the last icon on the icon bar. It needs to be pressed if HQP is going to be controlled externally through a computer on a network. That is not the case here as Roon and HQP are on the same computer. If Roon were on another computer then this icon would need to be pressed.


I’ve never had them on the same machine. Learned me something new.

1 Like

Hmmm, I went to check the HQP Manual to check that, but I only have the version prior to introduction of the Network Control Icon available atm.

Try toggling this icon to see if it makes a difference. I may have misremembered its functionality.

Edit: Looking at previous posts on the forum regarding Network Control in HQP it seems that using “localhost” doesn’t require network control to be enabled, but any external computer does.

HQPlayer can be started after Roon, you just can’t play to the HQPlayer zone until it’s running.

Make sure you give you HQPlayer zone a meaningful name so you know you are actually playing to that zone.

I updated the driver for the holo spring. When I updated the driver I quit rune server.

When I reopened HQP I saw that I was able to play DSD native without DOP.

While I had HQP playing DSD512 I opened roon server.

I looked at the Roon settings and noticed that roon was looking for the holo driver but said that it could not find it. I disabled the Holo driver.

I made sure the only network device was HQP and that it was listed as a local host.

In HQP I made sure that enable network connection was disabled. I think it already was disabled.

At the same time I was making these changes to the audio page in the settings menu roon !pushed a software update. I don’t know what exactly fixed it but it works.

Thank you very much

1 Like

This topic was automatically closed after 44 hours. New replies are no longer allowed.