Roon is grinding to a halt adding music to library

Core Machine (Operating system/System info/Roon build number)
Audio linux, Roon core 1.7 build 661

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Hi, this an issue that was reported many times apparently but seems to have multiple solutions. My Roon server is stuck adding 26 files into the library. Tried rebooting many times. Stoping and starting.

Screenshot below

I tried numerous troubleshooting including removing the current library and loading a different drive (I have a copy of my music on my NAS). The issue remains and furthermore Qobuz is also stuck. I updated to the latest version (build 667) but this did not helped. My roon core is non functional. I switched it off and will try tomorrow.


Metadata Improver Halted - Roon needs software update

Message typically means the Roon core can access Roon’s cloud services, which suggest a network issue.

Did you try rebooting your networking equipment, as that would be my next troubleshooting step after the Roon core?

I think this is the issue as well. I will try to do this.

All network equipment rebooted and things are working again. Unfortunately this happened just when I was doing some maintenance work on my Linux core machine, but next time I know.

Hello @Ariel_Levin, glad things are working again! Please let us know if the issue returns.

Hi, strange enough I have the same issue again, but it might be something that I am doing. I am testing this evening a second audio server which is running the same SW as my current one. Obiously I cannot run them in parallel as I am only able to run one Roon core at the time. So basically connect only the server currently testing to the network. However, while the “original” server has no issues, the “test server” is running Roon fine but Qobuz is simply not working. it again shows the same symptoms I had in the original post. The core shows like it is connected to my account but search as well browse playlists is not working. When I switch back to the original server all is fine. I already tried rebooting the network but nothing is working.

Ignore last post. Issue is fixed.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.