Roon is importing only half of the files scanned on drive

Roon Core Machine

Asustor 6604T, 8GB RAM, Intel Celeron CPU, Roon DB on SSD

Networking Gear & Setup Details

not of interest

Connected Audio Devices

not of interest

Number of Tracks in Library

Should be ~4000 now, but only is ~2000

Description of Issue

I realized Roon is omitting parts of albums scanned on the NAS, after some investigations I found out that roughly half of the files are missing. I searched all knowledge base and followed all tips and tricks, set up the Roon DB newly, checked for forbidden characters, disabled recycle bin, but nothing helped. Even after adding the first 3 directories I realized everything’s the same as before. The screenshot shows what is and what should be. It affects mostly albums with 2 or more disks in it. See below: only the second disk is imported, CD1 is completely missing.

I would have attached the fresh log file after database initialization, but don’t find a way to do so. I am somehow fed up with Roon because these kind of issues are occuring quite frequently (I had this a while ago with *.dsf files). I expected Roon to work flawlessly but it seems not to be the case. In Windows file explorer and other DNLA servers the tracks show up without any issues.

Do your files/folders follow:

If not, or metadata in the files is wrong, Roon may mix-up things and/or files might get hidden. See also:

So make sure: “When browsing your library Roon hides duplicates by default, but you can turn this off at any time from the General tab of Settings by toggling the Show Hidden Tracks And Albums option.” – at least while troubleshooting your issue.

Going by:

It may help if you could document/show the results for the various steps here, but in general: If nothing shows up in skipped files, and the files can also not be found when searched for by path (and hidden files are shown), then it is usually while Roon can’t read/see the files at all (path issues, access rights issue).

1 Like

Hi,

I tried all the tips and tricks (incl. those above), but nothing helped, so I opened the request. To re-post the already known topics isn’t quite helpful in this case and does not solve the problem.

I made another attempt to get rid of this: after a complete reset of the Roon app and deleting the database on the NAS I created a new share on the same RAID and COPIED (not MOVED) all files into the new share. This made all files visible inside Roon. Unfortunately I still do not know what the issue was. An expert might see this in the log, which I still have. I found one entry by using the search function, unfortunately it did not bring the solution either. Here is the line which I assume to point at the issue:

Warn: [storage] while getting mediafilegroup: Valid values are between -62135596800 and 253402300799, inclusive. (Parameter ‘seconds’)

As already written, I only copied the files from one share onto another without changes, and it worked again.

And file/folder ownership and access rights are all the same between old and new?

1 Like

Yes, absolutely identical, just newly created and files copied 1:1, no renames, no re-edits in between. For me this behaviour is not understandable, but I must admit that the logfile is filled with info and I can not get the essence out of it.

Did you actually check that or do just believe that it is so.

And pointing the all new Roon to the same old share as before didn’t work the same?

It’s hard to figure that out when changing all the parameters/variables (new Roon, new share, …?) at the same time.

Also in the new working setup or just in the old, now no longer existing one that exhibited the issue you reported?

All in all, this seems to be just a continuation of your earlier thread (or at least you provided the same log snippets as being relevant):

I don’t say that Roon is error free software, but scanning files (as a base component of the software) usually works robust. You reporting partial scans only sounds suspicious to me. As Roon just tries to read in the files, there isn’t much Roon can do wrong here I believe. To me this all sounds like one has to search the root cause on the NAS. We don’t have all the details nor access to the NAS to check our self.

Searching the forum, I found only one other thread reporting the same issue (sadly never got resolved). This user believed it might be related to btrfs as filesystem in use.

I fear troubleshooting your NAS (OS) is beyond what this forum category is meant for, and with that little details about it and a now error free working setup, I don’t see how to help further. Just enjoy your now working setup and report back if you run into issues again in the future.
Maybe @noris has something to share from the analysis done on your older thread?

I did a Roon reset before and pointed to the same “Musik” share, the situation did not change. I then created a new Share “Audio” (with the same directory structure) and copied 1 folder to the new share and added the path to Roon, it immediately imported all files and folders without issues. Moving the files had a different behaviour. That’s why I pointed out the copy method instead of move, maybe it helps someone else.

The error message “Warn: [storage] while getting mediafilegroup” does not appear any more in the current log.

What made me think: Roon did import the second of two disks (each in CD1 and CD2 subfolder) and rejected/ignored the first one. All files were named with the same standard and tagged identically. I checked with Lossless Audio Checker for issues with encoding and with MP3Tag and AIMP for the tags.

For me it is unsatisfying not to get the point (I am enigineer and network pro), so not being able to identy the issue keeps me thinking this can happen again and I still don’t know how to solve the issue without doing that 12 hour procedure of copy-paste again (it is still ongoing for the last folders in this moment but all files seem to be in).

It is still the same Roon software, using the same file scan algorithm after all. As I see it, the only relevant things that actually changed are the share and the folders/files it contains. This seems to be your responsibility to troubleshoot. Maybe there is a support forum for Asustor and some users there have run into similar issues?

PS:

None of this is helpful. No one can verify if you found all the documents, tips and tricks – you may have missed some. Your later reply even implies that you previously missed some. Maybe you also missed to perform one or more important steps inside? Nobody knows because you never confirm anything specific – even when asked for. One can also make it difficult for other people to help them.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.