Roon is not play some tidal songs

Hello, everything was fine but now I keep getting the same error on songs that used to work fine. The songs work in the regular tidal app but not in roon. The message just says A network or connectivity problem in interferring with Tidal playback

Please help.

Hi @chris_evans ----- Thank you for the report and sharing your feedback with us, both are very appreciated! Sorry to hear of the troubles.

Moving forward, to help aide in our understanding of this behavior you are reporting to us, may I very kindly ask you for the following:

  • A brief but accurate description of your current setup using this link as a guide.

  • Please describe your network configuration/topology, being sure to provide insight into any networking hardware you are current implementing. I want to have a clear understanding as to how information is being passed a long your network.

  • Are receiving the mentioned error message while using TIDAL with all of your endpoints?

  • Since noticing this issue have you tried…

    • Rebooting not only your core machine but any pertinent networking gear as well (i.e router, switches, etc)?

    • Have you tried logging out of, then back into your TIDAL account in Roon?


Hello my current setup is my Devialet 220 pro with core infinity connected to my Asus AC88 router. My PC is connected to the same router. PC is running windows 10, Roon is the most current version. The router is being fed internet From my ATT gigapower modem.

Certain songs on tidal just won’t play, they always give the same error. The songs play on my phone and on my Tidal app but not through Roon. I rebooted all devices and logged out and in multiple times.

Thank you for the help, if my information was not specific enough please let me know. I will do my best to fill in any holes I may have left.

I think I just realized something from the Tidal app most of the songs not working on Roon appear to be music videos. So maybe Roon no longer plays audio from the videos.

Thanks for taking the time to answer my questions and follow up with me @chris_evans, very appreciated!

In regard to your latest comment about the songs appearing to be music videos. I know we had fixed an issue awhile ago where TIDAL music videos had been causing distortion while being played back through the application but it is unclear to me how we are currently handling TIDAL music videos. Do we play them? Do we not? Can we do better here?

In light of this, I have placed a feedback request with our tech team to verify the above and once my request has been acknowledged, I will be sure to share the team’s thoughts with you asap. Your continued patience is very appreciated!


Is there any update I really feel this is a important issue. Also can you tell me when I add a song from and album on Tidal to my library the rest of the album disappears? And nothing I do will make it show up on Tidal again.

You can get to the whole album by finding it in your library and clicking “Go to TIDAL Version”:

1 Like

Mike, you you’re good you are really good thank you for that.

Also the latest update from today allows the songs to play again.

1 Like

Hi @chris_evans ---- I just wanted to touch base after your latest update. Apologies for the slow follow up on my end.

How have things been holding up? Seems like the latest Roon update resolved this issue. Let me know.

Many thanks!

Actually it’s been awful Roon will no longer play my entire playlist none of them. Every time a different quality song is up next Roon just stops. And I have to go play the song manually but it will happen again every time a different type of song is next, very annoying.

Thank you for getting back to me with that update @chris_evans, sorry to hear of the frustrations.

Moving forward, can you verify for me if you tried enabling of the “resync delay” feature in the application? This can be found under “device setup” on the “general tab”. Furthermore, when you notice this behavior it is when you are playing to your Devialet zone, correct? If you have any other active zones do the exhibit the same issue?


Hey @Eric yes I enabled the resync delay it did nothing. It only happens with Devialet selected, it’s like Roon thinks the current song never ends. It’s is a real pain in the ass because when it happens it will sometimes lead to the device in use error. Which requires unplugging the power to fix. If I skip to the next song before the song ends it will play. But not if I just let the playlist roll.

Thanks for getting back to me with that information @chris_evans, the insight is appreciated!

Moving forward, I would like to enable diagnostics on your account so we can try to get a sense as to why you are experiencing this behavior with the 220Pro. With this in mind may I very kindly ask you to reproduce the issue and note the time of day when the problem was observed, Having an idea of what content was playing at the time of the error would be helpful as well.

Additionally, can you also please provide the firmware version on the 220?

All the best to you and your family during the new year!

Firmware is 11.5.18, OK great how do we enable that, I can reproduce it right now. Thank you. And all the best to you and yours this NEW YEAR’S as well!

Hi @chris_evans ----- Thank you for touching base with me and my apologies for the slow response here.

As mentioned in my previous, I have went ahead and enabled diagnostics on your account as this action will automatically generated/upload a diagnostics report containing an up to date set of Roon logs to our servers the next time Roon is active on your core machine.

Once the report has been received I will confirm that we have it and then will pass over to our techs for analysis immediately. In the mean time if you are able to readily reproduce this issue with the 220, would you kindly do so and note the time when you make the observation.


it happened a lot yesterday between the hours of 4 and 6 PM central time. Thanks.

Hey @chris_evans,

Just wanted to let you know that we’ve received your logs and they are being analyzed at the moment. We will get back to you as soon as the analysis will be finished.


Any update? Thanks

Hey @chris_evans,

Sorry for slow response here, we were able to discuss your case with our dev team. And it might be a Devialet issue which they fixed in latest release. Can you check what version of firmware you gear is using ? If it is not the latest one, try to update it and let’s know where issue still occurs.


I too was hoping the newest firmware would solve the problem but alas it persists. If I do not skip to the next song the next will not play.

This is making Roon unusable to me, any help would be much appreciated.