Roon is not recognizing the external hard drive

Equipment - Wyred4sound Music Server connected to PS Audio DirectStream DAC

Issue - immediately after I upgraded the firmware in W4Smusic music server to version 2.8, Roon stopped recognizing the external Seagate Expansion HD. Right now I have to either mount the USB drive using the app (works every time) in the server or shake the USB cable (works some times). Roon will then start to rescan and import the tracks.

Roon will recognize the external HD as long as the music server is power on. Once I turn the music server off, Roon will stop recognizing the external HD.

This happened once - I left the server on and Roon started importing by itself after about 10-15 minutes.

Thank you and I would appreciate your help in fixing this issue.

This looks like a hardware issue either with your HDD, cable or USB socket.

Try a different cable.

Try and different HDD and see if the issue remains.

1 Like

I have one 4tb hard drive that is exactly the same and I have narrowed it down to a poor fit of the cable at the HDD end itself as a wiggle and push will get it recognised again.

Thank guys.

I did what you guys suggested and it seemed to point to the HDD.

I ordered a new HDD and am keeping my fingers crossed.

1 Like


I tried a new HDD and the issue still persists.

Would Roon please help?

Wyred4Sound Music Server software version 2.8. Roon Version 1.8 (build 831).

I mount the external HDD (Seagate Expansion 4 TB, also tried Toshiba Canvio Advance 4TB) using the music server’s app. Once the message showed the usb drive is reconfigured successfully, Roon starts scanning and importing the tracks. However, once the music server is turned off Roon cannot “see” the usb drive folder when it is turned on again. The usb drive folder becomes unavailable.

Are there other W4S music server users out there who is experiencing the same issue? I would love to hear from you.


It still looks like a server hardware issue or a server OS issue. Do you have a support ticket open with W4S ?

Hi Nick,

I have been talking to EJ almost non-stop ever since it happened a month ago, after I was asked to update to version 2.8 before your update on November 3. Unfortunately, still no solution after a month…

I hope you don’t mind if I ask you for your take why the music server fails to initialize an external hard drive (it spins) but has no problem recognizing a thumb drive (doesn’t spin).

Thanks, Jeff

Hi Jeff,

I don’t know what OS or drive formats are involved specifically here but they can simply be a mis-match.

For example I had a USB drive (Terramaster) that just wouldn’t initialise with a NUC running Roon’s ROCK OS.

The drive was working fine on a windows OS NUC and Roon.

The format of file system was the key. I need a Linux formatted partition on the HDD before the HDD would be properly initialised.

I used my synology NAS to reformat the HDD and it was then instantly available to the core.

Maybe have a look at what your HDD and thumb drive are and whether this is related.

It may not be relevant. The wiggling of cable is also a big factor here. That is not going to help.

Hope that helps

Hi Jeff,

Jumping in with Nick, and not official support. Just to clarify, you are saying that:

  1. initially, you plug in a USB spinning drive (USB HDD), you can get it mounted, but, once the server is turned off and on again, the drive will not mount

  2. In the same scenario and the same USB port, a USB thumb drive is seen after the server is turned off and on.

Try this. You plug in the drive, get it mounted so everything is seen. Turn off the server. Unplug the drive. Boot up the server, THEN, attached the drive again, can it mount?

EJ called this morning. The solution- leave the server on, don’t turn it off. Sure doesn’t sound like a permanent solution to me.

I will try what Daniel suggested and see it it fixes the issue permanently.


Are you still shaking the cable ? If that makes a difference then I suspect you have a faulty USB socket. That is more of an issue than leaving the server on. The latter is just a way of maintaining a working status.

If when connected and working it reads properly and plays ok then it won’t be the format issues I mentioned above. That would be more of a fatal problem I.e. not working at all.

If shaking the cable is a thing still then do it very carefully to determine which end the micro-movements make a difference. If it is the input to the server then that points to that socket.

I think USB-C can be a bit loose is some HDD units. Maybe the same here.

Hi Nick,

Shaking the cable was one of the first things that I tried. I used 3 different HDDs and different cables, all to no avail.

I am not technical but I strongly suspect it has something to do with the W4S version 2.8 because the problem started right after the update. The same HDD and cable had been working fine for years.

I am sure everyone agrees that simply leaving the unit on is not a responsible response to the problem. I am just surprised that EJ so far has refused to look into the update. The logical thing to do is to do a test on his end and see if the unit in his possession is having the same issue. He has refused to answer this as well.

That said, I truly appreciate your help in this. Thanks again.