Roon is preventing Windows from sleeping [Ticket In]

Hello @Eric_Chung,

There is a ticket with the dev team regarding this behavior, but it hasn’t reached the dev team’s queue yet. I can’t comment on an exact timeline but I’ll remind the technical team that this issue is still ongoing, thanks for your additional report!

It’s a known issue for a year now: any news?

Hi @Peter_Brand,

I took a look at our internal tracker today, and I can see that your ticket is still in our development queue.

This means our developers are still planning to look at this, but we don’t yet have a timeframe for when that’s going to happen.

Once the ticket has been scheduled and work begins, I’ll have a better sense of timing here. Thanks in advance for your patience!

@noris Any updates, this issue is really annoying?

Hi @Wei_Song,

There is a ticket regarding this behavior, but there are no updates on the ticket at this time. We are still planning to take a look at this issue, but it has not reached the top of the development queue just yet. Thank you for your patience here!

Thanks for the reply, @noris. Could you share the link to the ticket? It sounded like nobody cared about this issue. I want to make sure we are on the same page that this is a defect of the Roon server rather than a feature request, since no other software on the Windows machine is preventing the system from going into sleep. I hope your dev team agrees too that this defect is potentially generating lots of energy waste aggregated. Could you help push for a fix or a date for a fix?

Hi @Wei_Song,

We use an internal ticket tracking system, so there is no public link that I can share to the ticket. I mentioned this issue to the QA team again today, and they are aware of your reports.

As per policy, we cannot comment on timelines, but we greatly appreciate your patience here as this makes it’s way through the queue!

Hi all, I have the same situation as the OP. I have a powerful Windows 10 computer that I put Roon Core on. This thing sucks power so having it go into Standby when not in use is very important to me.

When Roon Core is open and I have not connected to another device, my system will sleep. If I have connected to a Chromecast device, even after I have closed and rebooted that device, Windows will not sleep, and the powercfg shows that it is roon.exe that is preventing sleep. I have to quite Roon for the sleep to continue

Windows has a power configuration option that prevents Windows from sleeping if media is being shared. This has worked well for me with other audio server software, where the system will sleep after I have stopped playing audio tracks after about 5 minutes. This is perfect behavior.

So please raise the importance of this ticket.

I see this as a Green Citizen issue. After all, if you look at how much power is being consumed by Roon software over all your users systems that could be sleeping instead of always on (I know that is a minority of users overall, however) you may find that Roon is responsible for a lot of wasted energy around the globe. I just hope that this might help persuade you to raising the importance of this fix :slight_smile:

my pc is being prevented to sleep by roon

we pay a LOT of money for this software - PLEASE fix this issue!!!


bump because devs ignore

This is also my issue. I sleeps after I reboot but when I use my phone it prevents it from sleeping that’s really unfortunate that it’s been a known issue for two years and you guys haven’t worked to resolve it. I love roon but this is rediculous. Please fix!

May '19: “We have been able to reproduce this issue in-house and a ticket has been filed. It is still pending review by the dev team and as soon as we have any other new info to share we will update this thread.”

Any news??

bump, wish this would get more attention.

bumping again.

devs too busy spending our $$$ rather than fixing product, as per for roon sigh

Hello All,

Thank you for the additional reminder on this issue. I spoke to the QA team regarding this issue earlier this week and we still have an active ticket regarding this in the queue.

This ticket is part of a larger investigation that is ongoing and we don’t have anything to announce quite at this time, your patience here is greatly appreciated!

I am wondering if there is an update on this. It is really making me not want to use your products as I want to be able to set and forget my streaming PC instead of turning it on and off when I want to listen.

I have exactly the same issue and would greatly appreciate this is solved soon.
Some news ?

Hi @Patrick_Soulier ,

There is still an active ticket regarding this in the queue, I’ve just sent the team a reminder on this, although I can’t comment on the specifics of a timeline for a resolution.

1 Like

This has worked for me:
1, Open Command Prompt (with “Run as administrator”)
2. Issue the following command:
powercfg /requestsoverride PROCESS Roon.exe system

So after 4 years the result is an active ticket with no timeline for a resolution. Wow, I’m impressed. The first piece of software I payed for (lifetime) and this is the supportlevel…