Roon is still trying to connect, but it is taking longer than normal [Resolved]

I get this message about connection taking longer than normal on all my control points all the time. It is normal!

For example, I get it every time I start Roon on my Windows laptop which is on wired connection with the Core. The Core is an i7 desktop machine with 16GB RAM and a 128GB SSD; Roon Server barely causes a flicker of load on the CPU, the RAM or the LAN connection.

My laptop is also an i7 device with 16GB RAM. Both the laptop and the desktop Core are running Windows 10 1709.

The LAN is gigabit throughout and I have configured Windows firewall to allow all Roon connections. Can anyone offer any ideas about the reason why the Core would always be slow to connect in this fashion please?

What kind of network hardware are you using? Certain network configurations can cause issues.

Thanks for your reply!

I have a Gigabit ProSAFE Plus Switch (GS108Ev3) to which the Roon Core desktop machine is directly connected.

My Windows laptop is currently connected to a USB 3 dock, which is then connected to the switch. That being said even if I connect the laptop directly to the switch, bypassing the USB 3 dock, I get the same behaviour.

@support might have some suggestions when it comes to that managed switch or other suggestions.

In the mean time you could try temporarily turning off the firewall on the core machine and your laptop and see if things improve. Rule out one thing at a time.

If you happen to have a regular dumb switch could you try that temporarily as well.

As a general rule: Multicast / IGMP snooping, Flow control, Jumbo Frames should all be off. Your Switch has Flow Control enabled by default (according to the manual).

thanks @Rugby and @DrTone for the suggestions

I just checked the switch and flow control is disabled on all ports

Loop detection is disabled

IGMP Snooping is enabled, however I dont have any VLANs defined at present

QoS is 802.1p/DSCP based, but I dont have any rate limits defined on any ports

Broadcast filtering is disabled

I do have an un-managed switch but it’ll take some time to swap them, so I’ll report back later

Thanks again!

Definitely turn off the IGMP snooping first before you go through the trouble of trying the other switch. You can search for it here on the forums and see the various posts on the subject.

Ooh I just installed a firmware update on the switch and it seems to have helped, things loading quicker now with no ‘connecting’ message at all.

Yeah I turned off IGMP snooping as well, although Roon startup was still delayed after that.

Having said that the firmware update rebooted the switch, so the IGMP change might have not been applied until post-reboot. Though it didn’t explicitly ask for a reboot.

As long as the connection performance is back to normal that’s what counts.

It seems to be all good now, so thanks all for your assistance :slight_smile:

1 Like

This topic was automatically closed after 24 hours. New replies are no longer allowed.