Roon is stuck importing music with "X" amount of files remaining [Resolved B247]

I am running Roon (1.3, build 234) on a MacMini i7 with 16mb ram. OS X 10.12.5 Music is stored in iTunes on a remote hard drive. There are 23156 tracks. The activity monitor is always on, with this message attached (Adding Music Music To Library: of 5 tracks, 5 added, 0 identified). FAQ suggests looking for small files (5kb), but I was unable to find any files that size in the library. Any help will be appreciated.

Hi @Rob_Stone ----- Thank you for the report and sharing your observations with us. The feedback is appreciated.

Just to make sure I am understanding this correctly. You’re iTunes library, which you are importing into Roon, contains 23,156 tracks and the activity monitor (spinning wheel) indicates that Roon is attempting to import 5 tracks but not progressing anywhere, correct?

Moving forward, can you please provide the following information to help aide in my evaluation of this behavior:

  1. Please provide further insight into where your musical collection is being stored/accessed from.

“Music is stored in iTunes on a remote hard drive.”

  1. Can you please follow the instructions found here and upload us a set of logs.


This is where the music collection is being stored: /Volumes/iTunes Server.

This is on an external hard drive

The log is now in dropbox.


Hi @Rob_Stone — Thank you for touching base with me. Can you confirm where the logs have been sent?

If you could just provide a dropbox download link, that’d be ideal.


Here is the link:

If that is not right, let me know


Hi @Rob_Stone ----- Thank you for the follow up, very appreciated!

I took a look at the contents of the dropbox link and it appears that you’ve sent me your “RAATServer” logs. Can you please provide me with your “Roon” logs.


Here is the new link:

I have the same issue, with windows.
Upon loading library roon get’s stuck. Never been able to use roon since installing
Tried on 2 different windows PC, win8 and win10.
Music library on network NAS.

My logs are here:

@Rob_Stone and @Pieter-Jan_Lanssens ----- Confirming that your Roon logs have been received.

We’ll have a look and let you know what we come up with. Your patience is very appreciated!


Please let me know what you have found in the Roon logs.



The error message has changed from “Adding Music Music To Library: of 5 tracks, 5 added, 0 identified” to this “Adding Music Music To Library: of 11,903 tracks, 11,903 added, 11,898 identified”.

I have the same problem. OSX 10.12.5, Itunes Library on FireWire disk attachted to dedicated Roon Server MacMini. After Importing whole library roon stucked with:
Adding Music Music To Library: of 18 tracks, 18 added, 0 identified
Can I send You my roon log?

Hi @Pieter-Jan_Lanssens ----- Thank you for your patience! I have an update from my team and will be contacting you via PM with instructions.


Thanks for fast response. I checked “skipped”. Don’t know how to check DRM files?
Sending my -

There is also second problem: after last update of roon server there are music dropouts and dialog box with - files are loading slowly, might be performance problem… Files are stored on firewire Disk 2,5T connected to dedicated MacMini (only roon server)----ethernet bridge (Thunderbolt/Ethernet)----CAT6----sms-200----m2techHiface Evo—DAC.
It’s very disturbing (almost every track) - I noticed that there is no dropouts when playing from SSD on MacMini.
Could you help with that as well?

Hi @Pawel_Rybak ----- I saw you had posted on this thread, as well as having opened a another topic addressing the same issue. I have since closed the other thread and moved your response over to this one, in order to keep all of your information in single location. We encourage users to not post in multiple location (addressing the same issue) as it makes keeping track of everything difficult.

Moving forward, confirming that your logs have been received and are in our queue to be evaluated by a member of our tech team. Once my report has been updated and passed back, I will be sure to reach out, asap, with the team’s thoughts/findings. Some more information on how you can tell if contented is DRM protected can be found here.

Lastly, in terms of this other behavior you’ve reported. Please start a new topic, being sure to flag support (i.e. @support) and we’ll be glad to lend a hand.

Thank you!

Hi @Rob_Stone ---- Thank you for your patience!

My team has completed their analysis of your logs and would like me to grab another set from you. This time however, they would like you to use a “command line flag” for additional logging. I will be contacting you via PM with instructions momentarily.



I have a problem which seems to have occurred to others before, but reading the threads isn’t very enlightening as to what the cure might be and none are recent.

System is latest ROCK, Version 1.0 (build 76) stable, with Server Version 1.3 (build 242) stable. Hardware is standard NUC 7i7BNH, 8GB RAM and 120GB SSD (91% free space). Everything wired Ethernet apart from iPad Remote of course. No LAN extenders or other dodgy hardware. Music stored on two Synology NAS.

The last similar thread seems to be this one:
Stuck adding music to library, some tracks still lack to be identified [Solved] , but that seems to contain two issues.

I updated to the latest ROCK build yesterday and since then I have had the spinning icon with the following showing:

A full rescan of my watched folders was triggered by the update and that is the result. It picked up around 600 tracks and was left with these 10.

This did happen once before on the original release build of ROCK at one point, but it resolved itself overnight that time with no clues as to what caused it.

So far I have done the following:
Restarted the Roon Server software twice to try and clear it (via the web interface) but with no change.
Toggled Off/On both Background Audio Analysis Speed and on Demand Audio Analysis Speed, with no change.
Cleaned the Library (I do this regularly anyway).

I have not powered off ROCK yet for a full restart, but really should not have to do this with an ‘appliance’.

If I could identify the 10 ‘stuck’ tracks that would help, but I have a fair number of tracks not imported due to being corrupt etc, but this should not cause Roon to get stuck in this way as all of them have been known about/identified as ‘Skipped Files’ since I first installed Roon for the 14 day trial.
When transferring files to the NAS, I am careful to exclude any characters which might trip up Roon, but these should just result in an exclusion rather than cause it to get stuck.

I’m also having this issue.

On a mac running roon app (1.3 build 242). 66616 tracks imported and identified, but the library is stuck on these 20.

Audio analysis is complete.

New albums that are added identify very quickly.

I’ve tried:

  • Searching for small mp3 files, found a few, removed them, restarted, forced rescan.
  • Going through log files for anything suspect, removed a few tracks that I found in there.

I want to move the library from my laptop to my server, but gather I can’t move the storage folder until the import is complete.

OK, spent a while clearing a few hundred ‘Skipped Files’ out of the watched folders, did a rescan of the folders and the problem has gone away. Will take a close look at those files now to see what may have triggered this behaviour (if anything - they have been there all the time marked as ‘skipped files’ without this issue). Will report back if I find anything.

Forgot to list that as one of the things I tried - multiple force rescans (seems as if roon does this on every startup anyway?) and deleting all the skipped files.

Skipped files shows empty now. Same 20 tracks are added but not identified.