Roon is stuck scanning files

Similar issue on my machine. Roon on Ubuntu Server 18.04 LTS.

Hi @Maarten_Boerma,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Can you share a screenshot of what you’re seeing? Has the scanning progressed at all?

Roon ROCK built on:

Intel NUC 7i7bnh
Samsung Evo 960 250GB m.2 drive PCIe (for OS + Roon)

Samsung Evo 860 4TB SSD SATA for music storage (/ROONSTORAGE) ext4 formatted inside NUC case

ROCK OS replaced with Euphony 3 OS (Linux distro specialised for music)

Transplanted into Asaka Plato X7 fanless case

Powered by Keces P8 linear power supply

Running Roon 1.6.

Apple iPad running Roon as Controller

DAC is direct attached to USB out of NUC (ALSA). However signal goes through ISO REGEN to clean up USB and then Matrix Audio X-SPDIF 2 to convert USB into I2S over HDMI. ISO REGEN powered by second DC output of Keces P8 PSU.

I2S input (HDMI) of PS Audio DirectStream DAC (Senior version running Red Cloud firmware).

Tellurium-Q Silver Diamond XLRs out of DAC to Vitus Audio RI-101 Integrated Amp.

Then Tellurium-Q Silver Diamond speaker cables to Wilson Audio Sasha Series-2 speakers on IsoAcoustic Gaia I feet.

Velodyne DD12+ subwoofer (on IsoAcostic Gaia III feet) also connected to Vitus Amp using Tellurium-Q Black II speaker cables, i.e. using speaker level inputs to sub.

PS Audio DAC does have Bridge II Ethernet endpoint installed but direct connection via I2S sounds noticeably better.

Wow… let’s see. That is quite a bit of work. First.

I built a HDPlex server using an ASRock Z370 mini-ITX motherboard. Running Ubuntu Server 18.04 LTS.
There is a Corsair SSD of 2TB SSD build in and a M.2 SSD for the OS.
The 2TB SSD contains the music files. The drive is formatted EXT4.
Roon is the latest version. Build 390, 64-bit.

Network. Not sure if this is relevant. All wired. Main router is a TP-Link. I use iPhones, iPads, Ropieee LCD, AppleTV etc to control the music. The zones are multiple. From a Sony TV and Receiver to a Violectric DAC and Amp, directly connected via USB to the HDPlex server and Core.

Below is a view of the “progress”.

Thanks for the info, @Maarten_Boerma,

I’d like to enable some diagnostics on your account so we can take a look at what you’re experiencing here. Before I do this, may I ask that you please do the following and make a note of the time you do each:

  • Reboot your Core machine.
  • Start up Roon and let the spinner go for ~5 minutes.
  • Reboot your Core machine once more.
  • Start up Roon and let the spinner go for another ~5 minutes.

This should allow the team to gain some insight into what you’re experiencing in the report. Once you’ve done this let me know the timestamps and I’ll enable diagnostics on your account. When the diagnostics report is uploaded I’ll send it over to our team for analysis.

Reboot 18:30 Central European Time
Start Core around 18:33

Rebooted again at 18:38 CET
Start Core around 18:40 - 18:41 (just now)

@Dylan any updates on this?

Hi @Maarten_Boerma,

Please accept my sincere apologies for the delay here. I had enabled diagnostics on your account after you send the timestamps but the diagnostics report did not reach our servers. I tried re-enabling them and it came through the second time — I’ve passed the report along to the team and will be sure to update you ASAP when I receive their feedback.

@dylan How is the analysis going? Need any information from me?

Hi @Maarten_Boerma,

Apologies for the delay here! I just had a chat with the team about their analysis of the diagnostics report and wanted to follow up with you regarding their findings.

Most of the time this type of behavior occurs when Roon is unable to properly scan a file (or files) in your library. We can identify those types of issues fairly easily in the diagnostics report, but that doesn’t seem to be the case here.

Can you describe what actions you were performing in Roon leading up to this behavior occurring?

  • Were you adding albums (locally or from Qobuz)?
  • Did you make any edits to your library?
  • Did you merge any albums?


Hi @Dylan,

I was adding local files. Quite a lot of them. BTW, now it says it is “Rescanning files: 1/32” without progressing.

(I didn’t even know you could merge albums).


Thanks for the update, @Maarten_Boerma.

I’ve let the team know — They’re still looking into this. As soon as I receive more info from them I’ll be sure to update you ASAP.

Hi @Maarten_Boerma,

I spoke with the technical team about their investigation here and wanted to reach out with their feedback.

Moving forward, they’ve asked that you try the following and let us know if the same behavior occurs:

  1. Navigate to Settings > Services > Qobuz and choose the Logout option.
  2. Restart your Core machine.
  3. Let us know if you see the scanning still being stuck after this reboot.

Yes, that solved it, @Dylan

Can I login to Qobuz again?

Hi @Maarten_Boerma,

Thanks for confirming that. Yes, please log back in to Qobuz and let us know if the behavior returns.

@dylan Same behaviour is back. Again stuck Rescanning 1/16 files.

Thanks for confirming, @Maarten_Boerma!

We met with the team yesterday to discuss this behavior you’re experiencing and have opened a ticket with our development team to get this resolved. I can’t provide any specific timelines here, but I’ll be sure to keep you updated once new information is available.

Thank you for your patience while we have been investigating this — It’s greatly appreciated!

Thanks, @Dylan. I’ll patiently wait. Enjoy the weekend.

Hi @Maarten_Boerma,

We’ve made a change here in Roon 1.6 (Build 416) that we believe should address this behavior. Please update Roon and let us know if you’re still seeing any issues. You can read the full release notes here:

HI @Dylan,

It is fixed! I have not yet added new files after the update. If it re-occurs I will let you know.

Thanks to you and the team.