Roon is trying to install beta version 886 [update server issue -- corrected]

Roon Core Machine


Networking Gear & Setup Details

Cocktail X 45

Connected Audio Devices

MacBook Pro

Number of Tracks in Library


Description of Issue


I don’t have all the technical information you request and I hope/believe it not to be relevant to my question. I tried to open up Roon on my Mac Book Pro which I use as an endpoint. Roon told me I should update both the Core and the remote, so i did. But now I’ve ended up with 1.8 (build 886) beta on the Core, and 1.8 (build 884) on the MacBook. I don’t want to be a beta tester. I don’t want to have to back things up at the moment and I don’t want a potentially unstable version of the Core on my machine. I’m having all sorts of problems with the Cocktail X 45 at the moment, and a stable Roon is the only thing keeping my audio brain sane. So I’d like to uninstall the new beta version and revert to 1.8 (build 884) on both computers. But I can’t find any advice on how to do that. Can you help me?

Ian Gallacher


Hmm. My Mac got updated to beta, again, without my wanting it. I then tried accessing my (new) Nucleus+ with the phone based on what I read here and got the incompatible warning again. But just 10 minutes after updating the Nucleus+ and getting the unwanted beta, it was asking me to update the Nucleus+ again. I said yes. Now it appears to have reverted to stable.

Updated the phone again, and now it works. Same just happened on the Mac. So, two updates in one day, one to the beta then back to 884.

I’m guessing the folks at Roon are scrambling after accidentally deploying 886 (a beta) to all users.

Update here:


They are pushing out the old version now, go to about in settings and there should be an update available.

Yep. Just got it. Hey, it’s a small team. This isn’t Spotify here. Nice, quick response by the Roon team


Beta has now reverted back to a proper release. Roon must have just released a fix.

Yep. All fixed

Alles wieder gut :mask: :smiley:

Everything is all right again :mask: :smiley:

I’m envious. I’m still at 886. I’m hoping it’s just a matter of time before I get the update backwards message. Thanks for your help. It does help to know that I’m not alone!

Just a quick note here while we get everything cleaned up. Build 886 beta is exactly the same as build 884 stable save for a one-line code change related to a bugfix we were testing. If you took the 886 update you can rest assured that there was nothing in that build which will cause any problems with your Roon core.

We have corrected the issue with the update server which led to this problem and you should see prompts to move back to build 884 stable shortly.

We will post later with a brief summary of what happened and the steps that are being taken to ensure that it doesn’t happen again.

Sorry for the confusion that this caused and we appreciate your patience.


I have a Nucleus Plus, and so far I have not been able to revert to build 884 and I do not see a download available for Nucleus on the Roon web site.

Any advice on how to get back to build 884 on my Nucleus will be appreciated.

First try going to Settings → About in Roon and seeing if an update is listed for your Nucleus. Going to that screen should force a check.

If that doesn’t work then point your web browser at the configuration page for your Nucleus and click on the “Reinstall” button. That will grab the correct version and load it for you. This is a non-destructive operation so you don’t need to worry about your database.

Hi - I am running Roon on a Qnap NAS and there is no updated download of the Core software for QNAP. How do I do this. Currently I cannot access since since updating the app on all devices 30 mins ago. I have build 886 beta on the QNAP (it says update required) - Thanks

Thanks! Reinstalling did the trick.

And thank you also. Reinstalling worked and all seems to be good. If I may, this seems to be a demonstration of why Roon is such an appealing product. There was an obvious mistake here, but that can happen to anyone. The problem was addressed quickly, effectively, and with transparency. And the community surrounding the product helped to bring about a speedy and satisfactory result. If all products were supported in this manner, the world would be a better place. Thanks to you and thanks to Roon for fixing this so quickly.

Ian Gallacher


@Mark_Robinson , we’re working on a solution for you which will be seamless. Please stand by.

@Mark_Robinson, this should be resolved now.

Please use the admin interface of your QNAP to restart Roon Server. Your core should restart and then take the update and restart itself again. At that point it should be running 884 stable.

Please let us know how it goes.

1 Like


I reinstalled the core on the nas and this then prompted the app to download and install the update.

Thanks for your help


No worries at all! Thanks for allowing me to take part! Just have more to learn.