ROON Issue w/Windows 11 - "Invalid Path Specified"


All of a sudden I get invalid path specified when i try to add storage folders which I previously had intact. I uninstalled Roon and reinstalled. No matter if it’s my PC or the new Grimm unit I get this message when I try to designate a new folder. I have a flat network here and all Roon devices are discovered, but I have no idea why I have this issue. Also, SMB is enabled on the laptop

Networking Gear & Setup Details

I have an EERO meshed network with 4 APs. There is nothing wrong with the network. My servers and NAS are all attached via Ethernet. IT's the same configuration that was working fine. I suspect an issue with Win 11 but no idea what it could be.

Connected Audio Devices

ZEN Innous MK3 server/streamer, NAIM storage, and 2 BlueSound Node 2 streamers. My only issue is the Invalid Path popup when trying to add folders

Number of Tracks in Library

Approximately 8000

Description of Issue

See above

I would check to make sure windows didn’t turn off network discovery and file and print sharing. I seen this happen to others after an update.

Thanks for the detailed instructions. Appreciate it. But it was already in this mode. When i get this message Invalid Path’ it’s instantaneous as if Roon doesn’t like the text (path). See path below, which I originally used along with another device.


it should be


Sorry, I didn’t capture it all when i pasted

have you tried substituting “ZEN” with its IP address instead?

Yes, but i will try it again since I reinstalled

Still get same message

Where is your core located? on the same PC? or on a NAS?
Also, where is the music stored?
If on NAS, what NAS are you using?
Can you access the share from windows explorer? Do you see it in the network section?

Whether its the laptop or the MU1 i have same issues. Storage located on network drive with IPs assigned

What’s the ‘Grimm’ thing?

I’m fairly similar but I have the core on a Mac Mini, storage is a Zen Mk3 and Wifi is eero mesh

Grimm MU1 is a front-end device that oversamples: more geared towards Ladder Dacs. Check their website in The Netherlands.

Are you using the Grimm as the core? if not what is the core?

Can you ping the NAS?

MD …

Yes I can. And just set up a new laptop and loaded Roon and still get the message. I have no idea what’s going on. Really wish Roon replied to my email from yesterday. Its hit or miss. Horrible customer service approach they have. Like I have nothing else to do than scour through hundreds of topics to find an answer. Finally decided to post here. No idea what’s going on. Cannot add a folder via conventional way or IP address. This message seems more like Roon can’t decipher the syntax. The popup is lightning quick and not getting on the network

Please state what you are using as your Roon Core - it’s still not clear what your setup is…

1 Like

Windows 11 Dell. Think I got it. I set up 2 shares then went back in selected those 2 folders for music. I tried this on my other laptop and didn’t work. But on the brand new Win 11 HP it seems to be discovering all the files now.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.