Roon issues with Cisco VPN

I ran into an interesting issue with Roon on my system at home. I am connecting to a PSAudio PerfectWave DAC. Normally it works perfectly. But if I connect to work using Cisco VPN Roon no longer sees my PWD. Once I disconnect it shows back up. I did not see a setting where I can force what network adapter to use. Are there any setting in Roon that would make a difference or is this a bug?


Cisco VPN usually makes your local network inaccessible. I am sure you won’t be able to access other resource on your local network either while the VPN is connected.

Actually I can access everything else on my network while I have the VPN running. I can also use jRiver to play to my Perfectwave DAC.


I use a linux-based RoonServer and VPN and it doesn’t work either. It worked when I was running the RoonServer on Mac OS but I’m happy I switched it over to my (linux) file server.

Split tunnelling (able to connect to VPN network and local network simultaneously) is a configuration/policy setting by your network administrator.

Why Roon Client doesn’t work over VPN is because of a) a bug in RoonServer or b)complications of TCP/IP routing over VPN client (which IP address to use? c) combo of bugs and complications.

Or the correct answer is d) Roon does not officially support use over a VPN connection.

I am not trying to use Roon over a VPN connection. I am trying to use Roon on my normal network connection, at the same time I am connected to work via a VPN.


What’s the old phrase about mixing business with pleasure ?:grin:

Roon uses multicast. Let’s drop a flag for @danny and see if that might affect how a VPN and local network interact.

(retired IT guy here). corporate VPN’s are usually configured to forward all TCP/IP traffic to the VPN server when the VPN client is active. Is is arguably the more secure configuration (because corporate firewalls and proxy servers etc) but breaks software which runs on the client workstation and requires TCP/IP (yes including multicast) for communication, such as the Roon client. Would suggest a nice new iPad to manage the music while working.

I have a nice new Ipad, but it connects to Roon my PC. Which also won’t connect when my VPN is up.