Roon keeps crashing after audio zone changed


Roon keeps crashing before start the ui after I changed a zone (airport express). I tried rebooting my computer with no luck. I even tried to uninstall and install the app again with the same results.

I’m running last version of roon on mac os x 10.10 on a mac pro 2010 with 32gb ram and my mucri collection is in a hd attached to the mac.


Hi @Alejandro_Garcia1 ---- Thank you for the report and my apologies for the troubles. In order to accurately evaluate this issue, I’d like to gather some information from you in regard what you are working with and how it is being used.

I see you have already started explaining your setup a bit. Core being ran on 2010 Mac Pro (OSX 10.10 w/ 32gb ram) and your music collection is being accessed via and external HD mounted to the Mac :sunglasses::+1:

May I kindly ask you to elaborate further on your current setup, as seen here. The more detailed you can be, the better. I want to get an exact understanding of the gear you are using ( make / model), how it’s being communicated with (USB, Wifi, Ethernet), and what your network configuration is like.

Furthermore, can you expand a bit on when the issue started. Has it always been like this OR was this something that just started happening? If that is the case, were there any changes made to your setup? New gear? New applications being ran in the background? Driver updates?


Hi Eric!

This is te info of my current setup:

-Roon 1.2 (build 157 stable) 64 bit
-Mac Pro 2010
-OS X 10.11.6
-Processor 3.33 Ghz 6-Core Intel Xeon
-Memory 32GB 1333 Mhz DDR3 ECC

-Airport express 1st gen (with latest firmware 7.6.7)

I’m running Roon in this machine and my music is in an internal HD.

The mac pro is attached to a router through ethernet and is in the same lan as the airport express.

Everything was running fine until I choose the airport express as an audio zone with the remote app installed on an iphone, at first it worked but there were some sound drops and glitches so I tried to see if there were more configuration options on the roon client on the mac pro. I selected another zone and then selected the airport express again, that moment the app crashed and couldn’t be launched again. Is as the airport express was ‘locked’ in Roon and it prevented to run.

I tried to restart Roon, restarted the Mac and finally uninstall and install Roon again with the same results.

The last thing I tried is to unplug the airport express so it couldn’t be funded and it seemed to do the trick. Roon could be launched and I select another audio zone (an apple tv) and everything was fine.

I replicated the problem, plugging the airport express, selected it in Roon and it crashed again preventing it from choosing another region.

So finally I gave up configuring the airport express as an audio zone, in fact I disabled it, and now everything is fine. The strange thing is that at least once the airport express was working with Roon, before I tried to configure it with in the Mac.

Hope this helps!


@Alejandro_Garcia1 ---- Thank you for the feedback and the very thorough report :sunglasses::clap: This information is very valuable when assessing these types of situations.

So based on this information it seems like the airport express (gen1) appears to be the troublemaker here. You mention in your post:

“The strange thing is that at least once the airport express was working with Roon, before I tried to configure it with in the Mac”

Are you able to expand on this a bit more? In other words, how were you trying to configure this device in MAC? I would like to get a sense of what possible could’ve changed.


Hi Eric!

The very first time I selected the airport express was through the roon remote app. At first it worked, but then I got some sound dropouts so I went to my mac pro to see if there were more configuration options. I can’t remember if the audio zone was selected correctly on my mac pro but I pressed the configuration button of the airport express and as there were no more configuration options maybe I selected another audio zone and then tried to select again the airport express and that was when the application crashed.

From that I couldn’t launch roon, even after a restart ande after deleting and reinstalling the app again.

After many tries I unplugged the airport express and after that I could start roon normally. Since that I never selected the airport express as an audio zone.

Hope it helps.


@Alejandro_Garcia1 ---- Thank you for the follow up and the feedback, both are greatly appreciated! I would like to gather some logs from you so our developers can have a closer look into this issue. I will be contacting you via PM momentarily with instructions. Thanks!